diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2016-05-24 14:57:00 +0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-06-08 14:55:26 +0200 |
commit | f0de8ed2c3301b8629d87a4e3357d580d4db154a (patch) | |
tree | dc7fcaa4d95b035e2a548267bb958b1f6add8ec8 | |
parent | a18991d245ec80f1c853419010713e651ed86cfc (diff) | |
download | meta-openembedded-f0de8ed2c3301b8629d87a4e3357d580d4db154a.tar.gz |
cmpi-bindings: fix build with python 3
This recipe seemed to have a floating dependency on Python 3, so
let's make it fixed.
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Add-PYTHON_ABI-suffix-to-the-python-library-name.patch | 27 | ||||
-rw-r--r-- | meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb | 5 |
2 files changed, 30 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Add-PYTHON_ABI-suffix-to-the-python-library-name.patch b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Add-PYTHON_ABI-suffix-to-the-python-library-name.patch new file mode 100644 index 000000000..b2a149b0f --- /dev/null +++ b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Add-PYTHON_ABI-suffix-to-the-python-library-name.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From a701ed30ac1bc2f77d063c237d6ae040a2d53f6b Mon Sep 17 00:00:00 2001 | ||
2 | From: Alexander Kanavin <alex.kanavin@gmail.com> | ||
3 | Date: Mon, 16 May 2016 16:52:24 +0300 | ||
4 | Subject: [PATCH] Add 'm' suffix to the python library name. | ||
5 | |||
6 | Upstream-Status: Inappropriate [oe-core specific] | ||
7 | Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> | ||
8 | --- | ||
9 | swig/python/CMakeLists.txt | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/swig/python/CMakeLists.txt b/swig/python/CMakeLists.txt | ||
13 | index 128798b..391cef7 100644 | ||
14 | --- a/swig/python/CMakeLists.txt | ||
15 | +++ b/swig/python/CMakeLists.txt | ||
16 | @@ -49,7 +49,7 @@ ADD_DEFINITIONS(-DCMPI_PLATFORM_LINUX_GENERIC_GNU -DCMPI_VERSION=200) | ||
17 | SET( NAME pyCmpiProvider ) | ||
18 | ADD_LIBRARY( ${NAME} SHARED ${SWIG_OUTPUT}) | ||
19 | #TARGET_LINK_LIBRARIES( ${NAME} ${PYTHON_LIBRARIES} ) | ||
20 | -TARGET_LINK_LIBRARIES( ${NAME} python${PYTHON_MAJOR_VERSION}.${PYTHON_MINOR_VERSION} ) | ||
21 | +TARGET_LINK_LIBRARIES( ${NAME} python${PYTHON_MAJOR_VERSION}.${PYTHON_MINOR_VERSION}m ) | ||
22 | TARGET_LINK_LIBRARIES( ${NAME} pthread ) | ||
23 | TARGET_LINK_LIBRARIES( ${NAME} dl ) | ||
24 | TARGET_LINK_LIBRARIES( ${NAME} util ) | ||
25 | -- | ||
26 | 2.8.1 | ||
27 | |||
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb index e203198af..25166ab58 100644 --- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb +++ b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb | |||
@@ -4,7 +4,7 @@ HOMEPAGE = "http://github.com/kkaempf/cmpi-bindings" | |||
4 | LICENSE = "BSD" | 4 | LICENSE = "BSD" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b19ee058d2d5f69af45da98051d91064" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b19ee058d2d5f69af45da98051d91064" |
6 | SECTION = "Development/Libraries" | 6 | SECTION = "Development/Libraries" |
7 | DEPENDS = "swig-native python sblim-cmpi-devel" | 7 | DEPENDS = "swig-native python3 sblim-cmpi-devel" |
8 | 8 | ||
9 | SRC_URI = "git://github.com/kkaempf/cmpi-bindings.git;protocol=http \ | 9 | SRC_URI = "git://github.com/kkaempf/cmpi-bindings.git;protocol=http \ |
10 | file://cmpi-bindings-0.4.17-no-ruby-perl.patch \ | 10 | file://cmpi-bindings-0.4.17-no-ruby-perl.patch \ |
@@ -13,12 +13,13 @@ SRC_URI = "git://github.com/kkaempf/cmpi-bindings.git;protocol=http \ | |||
13 | file://0001-Modify-cmakelist.patch \ | 13 | file://0001-Modify-cmakelist.patch \ |
14 | file://0001-Fix-error.patch \ | 14 | file://0001-Fix-error.patch \ |
15 | file://0001-fix-the-build-error-when-python-3.0.patch \ | 15 | file://0001-fix-the-build-error-when-python-3.0.patch \ |
16 | file://0001-Add-PYTHON_ABI-suffix-to-the-python-library-name.patch \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | SRCREV = "62f60e065aa1b901f826e4f530c0573ae32d065e" | 19 | SRCREV = "62f60e065aa1b901f826e4f530c0573ae32d065e" |
19 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
20 | 21 | ||
21 | inherit cmake pythonnative | 22 | inherit cmake python3native |
22 | 23 | ||
23 | EXTRA_OECMAKE = "-DLIB='${baselib}' \ | 24 | EXTRA_OECMAKE = "-DLIB='${baselib}' \ |
24 | -DPYTHON_INCLUDE_PATH=${STAGING_INCDIR}/python${PYTHON_BASEVERSION}" | 25 | -DPYTHON_INCLUDE_PATH=${STAGING_INCDIR}/python${PYTHON_BASEVERSION}" |