diff options
author | Carlos Rafael Giani <dv@pseudoterminal.org> | 2016-02-03 18:15:25 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-02-27 20:44:50 +0100 |
commit | efa3ff1462b9d2609526d8f25fbd20866088c346 (patch) | |
tree | 827232668edf7eaa3da12d6ee416b33743957837 | |
parent | 90d51ea3cda746054be32c0b2a726cb6649e628f (diff) | |
download | meta-openembedded-efa3ff1462b9d2609526d8f25fbd20866088c346.tar.gz |
ne10: add recipe
Add recipe for the Ne10 library ( http://projectne10.github.io/Ne10/ ).
This library provides heavily ARM NEON optimized versions of functions
that are commonly used.
Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/ne10/ne10_1.2.1.bb | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb new file mode 100644 index 000000000..5bfe80af1 --- /dev/null +++ b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | DESCRIPTION = "Library containing NEON-optimized implementations for a common set of functions" | ||
2 | HOMEPAGE = "http://projectne10.github.io/Ne10/" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=463ac0a7d64edc2b787c4206635ca2b1" | ||
5 | SECTION = "libs" | ||
6 | |||
7 | SRC_URI = "git://github.com/projectNe10/Ne10.git" | ||
8 | SRCREV = "a08b29d88e3c94d32b5b8f827e7fcf0bc2b34ac2" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | inherit cmake | ||
13 | |||
14 | NE10_TARGET_ARCH = "" | ||
15 | EXTRA_OECMAKE = '-DGNULINUX_PLATFORM=ON -DNE10_BUILD_SHARED=ON -DNE10_LINUX_TARGET_ARCH="${NE10_TARGET_ARCH}"' | ||
16 | |||
17 | COMPATIBLE_MACHINE_aarch64 = "(.*)" | ||
18 | COMPATIBLE_MACHINE_armv7a = "(.*)" | ||
19 | |||
20 | python () { | ||
21 | if any(t.startswith('armv7') for t in d.getVar('TUNE_FEATURES', True).split()): | ||
22 | d.setVar('NE10_TARGET_ARCH', 'armv7') | ||
23 | bb.note('Building Ne10 for armv7') | ||
24 | elif any(t.startswith('aarch64') for t in d.getVar('TUNE_FEATURES', True).split()): | ||
25 | d.setVar('NE10_TARGET_ARCH', 'aarch64') | ||
26 | bb.note('Building Ne10 for aarch64') | ||
27 | else: | ||
28 | raise bb.parse.SkipPackage("Incompatible with archs other than armv7 and aarch64") | ||
29 | } | ||
30 | |||
31 | do_install() { | ||
32 | install -d ${D}${libdir} | ||
33 | install -d ${D}${includedir} | ||
34 | install -m 0644 ${S}/inc/NE10*.h ${D}${includedir}/ | ||
35 | install -m 0644 ${B}/modules/libNE10.a ${D}${libdir}/ | ||
36 | install -m 0755 ${B}/modules/libNE10.so.* ${D}${libdir}/ | ||
37 | cp -a ${B}/modules/libNE10.so ${D}${libdir}/ | ||
38 | } | ||
39 | |||
40 | # ERROR: QA Issue: ELF binary 'ne10/1.2.1-r0/packages-split/ne10/usr/lib/libNE10.so.10' has relocations | ||
41 | in .text [textrel] | ||
42 | # ERROR: QA Issue: ELF binary 'ne10/1.2.1-r0/packages-split/ne10/usr/lib/libNE10.so.10' has relocations | ||
43 | in .text [textrel] | ||
44 | INSANE_SKIP_${PN} += "textrel" | ||