diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-03-28 19:30:16 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2017-04-25 15:55:36 -0400 |
commit | d946331bc00f89fd8f232405bd9fff6da035ae72 (patch) | |
tree | 5d19133541c95f814fcd2d01be64db1a2a050d97 | |
parent | 2fee586153323fa42d55438e5a8be72f253d1a31 (diff) | |
download | meta-openembedded-d946331bc00f89fd8f232405bd9fff6da035ae72.tar.gz |
rp-pppoe: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
3 files changed, 59 insertions, 1 deletions
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.12/0001-ppoe-Dont-include-linux-if_ether.h.patch b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.12/0001-ppoe-Dont-include-linux-if_ether.h.patch new file mode 100644 index 000000000..11356ce3f --- /dev/null +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.12/0001-ppoe-Dont-include-linux-if_ether.h.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 8d4d452d733bac8c5b55a90bddec8cc323cc9fa8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 28 Mar 2017 19:20:07 -0700 | ||
4 | Subject: [PATCH 1/2] ppoe: Dont include linux/if_ether.h | ||
5 | |||
6 | Fixes build with musl | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | src/pppoe.h | 4 ---- | ||
11 | 1 file changed, 4 deletions(-) | ||
12 | |||
13 | diff --git a/src/pppoe.h b/src/pppoe.h | ||
14 | index ec067a0..281879c 100644 | ||
15 | --- a/src/pppoe.h | ||
16 | +++ b/src/pppoe.h | ||
17 | @@ -127,10 +127,6 @@ typedef unsigned long UINT32_t; | ||
18 | #error Could not find a 32-bit integer type | ||
19 | #endif | ||
20 | |||
21 | -#ifdef HAVE_LINUX_IF_ETHER_H | ||
22 | -#include <linux/if_ether.h> | ||
23 | -#endif | ||
24 | - | ||
25 | #include <netinet/in.h> | ||
26 | |||
27 | #ifdef HAVE_NETINET_IF_ETHER_H | ||
28 | -- | ||
29 | 2.12.1 | ||
30 | |||
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.12/0002-Enable-support-for-the-kernel-module.patch b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.12/0002-Enable-support-for-the-kernel-module.patch new file mode 100644 index 000000000..139d1f089 --- /dev/null +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.12/0002-Enable-support-for-the-kernel-module.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From aca8473a516a8dc013866105da141fe1cd947474 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 28 Mar 2017 19:24:53 -0700 | ||
4 | Subject: [PATCH 2/2] Enable support for the kernel module | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | src/configure.in | 1 + | ||
9 | 1 file changed, 1 insertion(+) | ||
10 | |||
11 | diff --git a/src/configure.in b/src/configure.in | ||
12 | index cae0976..951a042 100644 | ||
13 | --- a/src/configure.in | ||
14 | +++ b/src/configure.in | ||
15 | @@ -33,6 +33,7 @@ AC_CHECK_HEADERS(linux/if_pppox.h, [], [], | ||
16 | #include<net/ethernet.h> | ||
17 | #include<linux/if.h> | ||
18 | #include<linux/in.h> | ||
19 | +#include<linux/in6.h> | ||
20 | ]) | ||
21 | |||
22 | dnl Checks for typedefs, structures, and compiler characteristics. | ||
23 | -- | ||
24 | 2.12.1 | ||
25 | |||
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe_3.12.bb b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe_3.12.bb index e1ca17fb3..fbe015f5e 100644 --- a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe_3.12.bb +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe_3.12.bb | |||
@@ -17,7 +17,10 @@ SRC_URI = "http://www.roaringpenguin.com/files/download/${BP}.tar.gz \ | |||
17 | file://pppoe-server.default \ | 17 | file://pppoe-server.default \ |
18 | file://pppoe-server.init \ | 18 | file://pppoe-server.init \ |
19 | file://configure.in-Error-fix.patch \ | 19 | file://configure.in-Error-fix.patch \ |
20 | file://pppoe-server.service" | 20 | file://pppoe-server.service \ |
21 | file://0001-ppoe-Dont-include-linux-if_ether.h.patch \ | ||
22 | file://0002-Enable-support-for-the-kernel-module.patch \ | ||
23 | " | ||
21 | 24 | ||
22 | SRC_URI[md5sum] = "216eb52b69062b92a64ee37fd71f4b66" | 25 | SRC_URI[md5sum] = "216eb52b69062b92a64ee37fd71f4b66" |
23 | SRC_URI[sha256sum] = "00794e04031546b0e9b8cf286f2a6d1ccfc4a621b2a3abb2d7ef2a7ab7cc86c2" | 26 | SRC_URI[sha256sum] = "00794e04031546b0e9b8cf286f2a6d1ccfc4a621b2a3abb2d7ef2a7ab7cc86c2" |