summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-02-06 22:24:06 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-12 19:35:40 +0100
commitd7fa7e96e5b5c8dd94df0b384a3c64160b119ebb (patch)
treeeb06bb93c50b4dcc161f246b094d0fe96ee25a50
parente1be8ba2b85502e173f75dc233324a7ecd9f130a (diff)
downloadmeta-openembedded-d7fa7e96e5b5c8dd94df0b384a3c64160b119ebb.tar.gz
libcap-ng: add package
this moves libcap-ng out of meta-selinux and meta-security into a common layer Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/libcap-ng/libcap-ng/python.patch39
-rw-r--r--meta-oe/recipes-support/libcap-ng/libcap-ng_0.7.4.bb37
2 files changed, 76 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libcap-ng/libcap-ng/python.patch b/meta-oe/recipes-support/libcap-ng/libcap-ng/python.patch
new file mode 100644
index 000000000..d82ceb454
--- /dev/null
+++ b/meta-oe/recipes-support/libcap-ng/libcap-ng/python.patch
@@ -0,0 +1,39 @@
1configure.ac - Avoid an incorrect check for python.
2Makefile.am - avoid hard coded host include paths.
3
4Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
5
6--- libcap-ng-0.6.5/configure.ac.orig 2012-01-17 13:59:03.645898989 -0600
7+++ libcap-ng-0.6.5/configure.ac 2012-01-17 13:59:46.353959252 -0600
8@@ -120,17 +120,8 @@
9 else
10 AC_MSG_RESULT(testing)
11 AM_PATH_PYTHON
12-if test -f /usr/include/python${am_cv_python_version}/Python.h ; then
13- python_found="yes"
14- AC_MSG_NOTICE(Python bindings will be built)
15-else
16- python_found="no"
17- if test x$use_python = xyes ; then
18- AC_MSG_ERROR([Python explicitly required and python headers found])
19- else
20- AC_MSG_WARN("Python headers not found - python bindings will not be made")
21- fi
22-fi
23+python_found="yes"
24+AC_MSG_NOTICE(Python bindings will be built)
25 fi
26 AM_CONDITIONAL(HAVE_PYTHON, test ${python_found} = "yes")
27
28--- libcap-ng-0.6.5/bindings/python/Makefile.am.orig 2010-11-03 12:31:59.000000000 -0500
29+++ libcap-ng-0.6.5/bindings/python/Makefile.am 2012-01-17 14:05:50.199834467 -0600
30@@ -24,7 +24,8 @@
31 CONFIG_CLEAN_FILES = *.loT *.rej *.orig
32 AM_CFLAGS = -fPIC -DPIC
33 PYLIBVER ?= python$(PYTHON_VERSION)
34-INCLUDES = -I. -I$(top_builddir) -I/usr/include/$(PYLIBVER)
35+PYINC ?= /usr/include/$(PYLIBVER)
36+INCLUDES = -I. -I$(top_builddir) -I$(PYINC)
37 LIBS = $(top_builddir)/src/libcap-ng.la
38 pyexec_PYTHON = capng.py
39 pyexec_LTLIBRARIES = _capng.la
diff --git a/meta-oe/recipes-support/libcap-ng/libcap-ng_0.7.4.bb b/meta-oe/recipes-support/libcap-ng/libcap-ng_0.7.4.bb
new file mode 100644
index 000000000..8823dad39
--- /dev/null
+++ b/meta-oe/recipes-support/libcap-ng/libcap-ng_0.7.4.bb
@@ -0,0 +1,37 @@
1SUMMARY = "An alternate posix capabilities library"
2DESCRIPTION = "The libcap-ng library is intended to make programming \
3with POSIX capabilities much easier than the traditional libcap library."
4HOMEPAGE = "http://freecode.com/projects/libcap-ng"
5SECTION = "base"
6LICENSE = "GPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06"
9
10SRC_URI = "http://people.redhat.com/sgrubb/libcap-ng/libcap-ng-${PV}.tar.gz \
11 file://python.patch"
12
13inherit lib_package autotools pythonnative
14
15SRC_URI[md5sum] = "55c57c0673b944ea1a755bcb2636dabd"
16SRC_URI[sha256sum] = "48a2083276f9820cb92dcb05d001b30733bcbf48c14c230303cac3cd08b45b6b"
17
18DEPENDS += "swig-native python"
19
20EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'"
21
22PACKAGES += "${PN}-python"
23
24FILES_${PN}-dbg += "${libdir}/python${PYTHON_BASEVERSION}/*/.debug"
25FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}"
26
27BBCLASSEXTEND = "native"
28
29do_install_append() {
30 # Moving libcap-ng to base_libdir
31 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
32 mkdir -p ${D}/${base_libdir}/
33 mv -f ${D}${libdir}/libcap-ng.so.* ${D}${base_libdir}/
34 relpath=${@os.path.relpath("${base_libdir}", "${libdir}")}
35 ln -sf ${relpath}/libcap-ng.so.0.0.0 ${D}${libdir}/libcap-ng.so
36 fi
37}