diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-03-19 22:31:50 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-03-31 13:25:58 +0200 |
commit | bfc16ec09d18b468f7dd73d8fca2c199d9c55417 (patch) | |
tree | 9543bdaa37daa58d907f9d4163b38cb2fa39b5e1 | |
parent | fb9224ed9e544c33aca52eb27339ab917a7e6916 (diff) | |
download | meta-openembedded-bfc16ec09d18b468f7dd73d8fca2c199d9c55417.tar.gz |
digitemp: Update past 3.7.1 release
Fetch from github
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch | 20 | ||||
-rw-r--r-- | meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb | 27 | ||||
-rw-r--r-- | meta-oe/recipes-support/digitemp/digitemp_git.bb | 25 |
3 files changed, 25 insertions, 47 deletions
diff --git a/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch b/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch deleted file mode 100644 index c0d552d54..000000000 --- a/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | digitemp: allow override of CC and CFLAGS vars | ||
2 | |||
3 | Upstream-Status: Inappropriate [embedded specific] | ||
4 | |||
5 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
6 | |||
7 | --- a/Makefile 2008-08-28 21:37:00.000000000 +0000 | ||
8 | +++ b/Makefile 2011-11-24 22:22:39.882511272 +0000 | ||
9 | @@ -11,8 +11,9 @@ | ||
10 | |||
11 | VERSION = 3.6.0 | ||
12 | |||
13 | -CC = gcc | ||
14 | -CFLAGS = -I./src -I./userial -O2 -Wall # -g | ||
15 | +CC ?= gcc | ||
16 | +CFLAGS ?= -O2 -Wall # -g | ||
17 | +CFLAGS += -I./src -I./userial | ||
18 | |||
19 | OBJS = src/digitemp.o src/device_name.o src/ds2438.o | ||
20 | HDRS = src/digitemp.h src/device_name.h | ||
diff --git a/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb b/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb deleted file mode 100644 index 2582820e6..000000000 --- a/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | SUMMARY = "read temperature sensors in a 1-Wire net" | ||
2 | SECTION = "util" | ||
3 | DEPENDS = "libusb1" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=44fee82a1d2ed0676cf35478283e0aa0" | ||
6 | |||
7 | PR = "r2" | ||
8 | |||
9 | SRC_URI = "http://www.digitemp.com/software/linux/digitemp-${PV}.tar.gz \ | ||
10 | file://makefile-fix.patch" | ||
11 | SRC_URI[md5sum] = "9be2e48db37920f21925ae6e88f83b84" | ||
12 | SRC_URI[sha256sum] = "14cfc584cd3714fe8c9a2cdc8388be49e08b5e395d95e6bcd11d4410e2505ca2" | ||
13 | |||
14 | EXTRA_OEMAKE = "ds9097 ds9097u \ | ||
15 | SYSTYPE='Linux' \ | ||
16 | " | ||
17 | # Fix GNU_HASH QA errors | ||
18 | TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}" | ||
19 | |||
20 | do_configure() { | ||
21 | rm -f digitemp_* | ||
22 | } | ||
23 | |||
24 | do_install() { | ||
25 | install -d ${D}${sbindir} | ||
26 | install digitemp_* ${D}${sbindir} | ||
27 | } | ||
diff --git a/meta-oe/recipes-support/digitemp/digitemp_git.bb b/meta-oe/recipes-support/digitemp/digitemp_git.bb new file mode 100644 index 000000000..460aa1438 --- /dev/null +++ b/meta-oe/recipes-support/digitemp/digitemp_git.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | SUMMARY = "read temperature sensors in a 1-Wire net" | ||
2 | SECTION = "util" | ||
3 | DEPENDS = "libusb1" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=44fee82a1d2ed0676cf35478283e0aa0" | ||
6 | |||
7 | PV = "3.7.1+git${SRCPV}" | ||
8 | |||
9 | SRC_URI = "git://github.com/bcl/digitemp" | ||
10 | |||
11 | SRCREV = "389f67655efa1674f595106c3a47b5ad082609a7" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | EXTRA_OEMAKE = "ds9097 ds9097u \ | ||
16 | SYSTYPE='Linux' \ | ||
17 | " | ||
18 | do_configure() { | ||
19 | rm -f digitemp_* | ||
20 | } | ||
21 | |||
22 | do_install() { | ||
23 | install -d ${D}${sbindir} | ||
24 | install -m 0755 digitemp_* ${D}${sbindir} | ||
25 | } | ||