diff options
author | Khem Raj <raj.khem@gmail.com> | 2011-05-09 22:48:03 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-05-09 18:59:00 +0200 |
commit | ba31e4eabd31af63eb0244096c8bcdcac185fac6 (patch) | |
tree | 767541ea30f41bac59766c56a3ef3793694332b9 | |
parent | 11bd2d2c2685445cfb0e61d297e70a578f0fa9ab (diff) | |
download | meta-openembedded-ba31e4eabd31af63eb0244096c8bcdcac185fac6.tar.gz |
conf/layer.conf: Use .= for BBPATH and += for BBFILES
Provide additional commentary that should help a bit more
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Acked-by: Paul Menzel <paulepanter@users.sourceforge.net>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r-- | meta-efl/conf/layer.conf | 6 | ||||
-rw-r--r-- | meta-gnome/conf/layer.conf | 6 | ||||
-rw-r--r-- | meta-gpe/conf/layer.conf | 6 | ||||
-rw-r--r-- | meta-oe/conf/layer.conf | 21 |
4 files changed, 27 insertions, 12 deletions
diff --git a/meta-efl/conf/layer.conf b/meta-efl/conf/layer.conf index 85dbacd14..272fc0490 100644 --- a/meta-efl/conf/layer.conf +++ b/meta-efl/conf/layer.conf | |||
@@ -1,8 +1,8 @@ | |||
1 | # We have a conf and classes directory, prepend to BBPATH to prefer our versions | 1 | # We have a conf and classes directory, append to BBPATH |
2 | BBPATH := "${LAYERDIR}:${BBPATH}" | 2 | BBPATH .= ":${LAYERDIR}" |
3 | 3 | ||
4 | # We have a recipes directory, add to BBFILES | 4 | # We have a recipes directory, add to BBFILES |
5 | BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend" | 5 | BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend" |
6 | 6 | ||
7 | BBFILE_COLLECTIONS += "efl-layer" | 7 | BBFILE_COLLECTIONS += "efl-layer" |
8 | BBFILE_PATTERN_efl-layer := "^${LAYERDIR}/" | 8 | BBFILE_PATTERN_efl-layer := "^${LAYERDIR}/" |
diff --git a/meta-gnome/conf/layer.conf b/meta-gnome/conf/layer.conf index c878ecf2b..902ab8f85 100644 --- a/meta-gnome/conf/layer.conf +++ b/meta-gnome/conf/layer.conf | |||
@@ -1,8 +1,8 @@ | |||
1 | # We have a conf and classes directory, prepend to BBPATH to prefer our versions | 1 | # We have a conf and classes directory, append to BBPATH |
2 | BBPATH := "${LAYERDIR}:${BBPATH}" | 2 | BBPATH .= ":${LAYERDIR}" |
3 | 3 | ||
4 | # We have a recipes directory, add to BBFILES | 4 | # We have a recipes directory, add to BBFILES |
5 | BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend" | 5 | BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend" |
6 | 6 | ||
7 | BBFILE_COLLECTIONS += "gnome-layer" | 7 | BBFILE_COLLECTIONS += "gnome-layer" |
8 | BBFILE_PATTERN_gnome-layer := "^${LAYERDIR}/" | 8 | BBFILE_PATTERN_gnome-layer := "^${LAYERDIR}/" |
diff --git a/meta-gpe/conf/layer.conf b/meta-gpe/conf/layer.conf index d25055533..6c018b1e6 100644 --- a/meta-gpe/conf/layer.conf +++ b/meta-gpe/conf/layer.conf | |||
@@ -1,8 +1,8 @@ | |||
1 | # We have a conf and classes directory, prepend to BBPATH to prefer our versions | 1 | # We have a conf and classes directory, append to BBPATH |
2 | BBPATH := "${LAYERDIR}:${BBPATH}" | 2 | BBPATH .= ":${LAYERDIR}" |
3 | 3 | ||
4 | # We have a recipes directory, add to BBFILES | 4 | # We have a recipes directory, add to BBFILES |
5 | BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend" | 5 | BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend" |
6 | 6 | ||
7 | BBFILE_COLLECTIONS += "gpe-layer" | 7 | BBFILE_COLLECTIONS += "gpe-layer" |
8 | BBFILE_PATTERN_gpe-layer := "^${LAYERDIR}/" | 8 | BBFILE_PATTERN_gpe-layer := "^${LAYERDIR}/" |
diff --git a/meta-oe/conf/layer.conf b/meta-oe/conf/layer.conf index 9fa60c1c4..267616b62 100644 --- a/meta-oe/conf/layer.conf +++ b/meta-oe/conf/layer.conf | |||
@@ -1,9 +1,24 @@ | |||
1 | # We have a conf and classes directory, prepend to BBPATH to prefer our versions | 1 | # It really depends on order of the layers appearing in BBLAYERS |
2 | BBPATH := "${LAYERDIR}:${BBPATH}" | 2 | # variable in toplevel bblayers.conf file, where bitbake will search |
3 | # for .inc files and others where bitbake uses BBPATH since it will | ||
4 | # search the directories from first to last as specified in BBPATH | ||
5 | # Therefore if you want a given layer to be considered high priority | ||
6 | # for the .inc and .conf etc. then consider it adding at the beginning | ||
7 | # of BBPATH. For bblayers bitbake will use BBFILES_PRIORITY to resolve | ||
8 | # the recipe contention so the order of directories in BBFILES does | ||
9 | # not matter. | ||
10 | |||
11 | # We have a conf and classes directory, append to BBPATH | ||
12 | BBPATH .= ":${LAYERDIR}" | ||
3 | 13 | ||
4 | # We have a recipes directory, add to BBFILES | 14 | # We have a recipes directory, add to BBFILES |
5 | BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend" | 15 | BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend" |
6 | 16 | ||
7 | BBFILE_COLLECTIONS += "openembedded-layer" | 17 | BBFILE_COLLECTIONS += "openembedded-layer" |
8 | BBFILE_PATTERN_openembedded-layer := "^${LAYERDIR}/" | 18 | BBFILE_PATTERN_openembedded-layer := "^${LAYERDIR}/" |
19 | |||
20 | # Define the priority for recipes (.bb files) from this layer, | ||
21 | # choosing carefully how this layer interacts with all of the | ||
22 | # other layers. | ||
23 | |||
9 | BBFILE_PRIORITY_openembedded-layer = "6" | 24 | BBFILE_PRIORITY_openembedded-layer = "6" |