summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-09-07 18:58:51 +0000
committerArmin Kuster <akuster808@gmail.com>2018-09-09 16:21:36 -0700
commitb3fffe67e0ac2a8ab2106d0ecf4ea00dd8b88502 (patch)
tree4ab48ccbd4a3a9b69e86157feab1b9b725956a14
parentbe79b8b111a968efdbe5e1482d0c246d0b24763e (diff)
downloadmeta-openembedded-b3fffe67e0ac2a8ab2106d0ecf4ea00dd8b88502.tar.gz
libqb: Fix build with gold
* since the upgrade to 1.0.3 more specifically since this commit: https://github.com/ClusterLabs/libqb/commit/20246f544f74866885f4d9491f74152bd95e7786#diff-67e997bcfdac55191033d57a16d1408a it was failing to build with gold * add --enable-nosection-fallback to work around the issue Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libqb/libqb_1.0.3.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libqb/libqb_1.0.3.bb b/meta-oe/recipes-extended/libqb/libqb_1.0.3.bb
index 73cea5e39..d857344e3 100644
--- a/meta-oe/recipes-extended/libqb/libqb_1.0.3.bb
+++ b/meta-oe/recipes-extended/libqb/libqb_1.0.3.bb
@@ -18,6 +18,14 @@ SRC_URI = "git://github.com/ClusterLabs/${BPN}.git \
18 " 18 "
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21# otherwise do_configure fails
22# configure:21609: checking whether linker workaround for orphan sections usable
23# configure:21639: i586-oe-linux-gcc -m32 -march=i586 --sysroot=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot -o conftest -O -fno-omit-frame-pointer -g -feliminate-unused-debug-types -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0=/usr/src/debug/libqb/1.0.3+gitAUTOINC+c235284b5f-r0 -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot= -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native= -pipe -pthread -D_REENTRANT -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,conftest.ld conftest.c >&5
24# WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: error: conftest.ld: SECTIONS seen after other input files; try -T/--script
25# WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: internal error in write_sections, at ../../gold/reloc.cc:791
26# collect2: error: ld returned 1 exit status
27EXTRA_OECONF_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' --enable-nosection-fallback', '', d)}"
28
21CFLAGS += "-pthread -D_REENTRANT" 29CFLAGS += "-pthread -D_REENTRANT"
22do_configure_prepend() { 30do_configure_prepend() {
23 ( cd ${S} 31 ( cd ${S}