diff options
author | Philip Balister <philip@balister.org> | 2014-12-18 13:40:44 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-12-19 20:13:11 +0100 |
commit | afc100a940b96628d9b99cefda65463a65b84f28 (patch) | |
tree | 47a0a8578361501b60837c41ba60abc07399cf1f | |
parent | 67c5f319b18a3728776dc1b8bb580d79164bdbd3 (diff) | |
download | meta-openembedded-afc100a940b96628d9b99cefda65463a65b84f28.tar.gz |
sip: Update to 4.14.2.
The sip configure.py script now has some support for cross compiling. This
allowed simplication of the existing OpenEmbedded sip support. The sip
recipe now produces support for builds via sip-native and target runtime
via sip.
This has been build and runtime tested on the zedboard and ettus-e300.
Signed-off-by: Philip Balister <philip@balister.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/python/python-sip_4.14.2.bb | 46 | ||||
-rw-r--r-- | meta-oe/recipes-extended/sip/sip-native_4.14.2.bb | 35 | ||||
-rw-r--r-- | meta-oe/recipes-extended/sip/sip_4.16.4.bb | 50 |
3 files changed, 50 insertions, 81 deletions
diff --git a/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb b/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb deleted file mode 100644 index acabc9721..000000000 --- a/meta-oe/recipes-devtools/python/python-sip_4.14.2.bb +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | SUMMARY = "Runtime helper for sip-generated python wrapper libraries" | ||
2 | SECTION = "devel/python" | ||
3 | HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip" | ||
4 | AUTHOR = "Phil Thompson" | ||
5 | LICENSE = "GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://siplib.sbf.in;endline=15;md5=3d462bd8cb43db3e4be998fe155ae9cf" | ||
7 | DEPENDS = "python" | ||
8 | RDEPENDS_${PN} = "python-core" | ||
9 | |||
10 | # riverbankcomputing is upstream, but keeps only latest version, sf usually have few older | ||
11 | #SRC_URI = "http://www.riverbankcomputing.com/static/Downloads/sip4/sip-${PV}.tar.gz" | ||
12 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/pyqt/sip/sip-${PV}/sip-${PV}.tar.gz" | ||
13 | SRC_URI[md5sum] = "b93442e745b3be2fad89de0686a76ce9" | ||
14 | SRC_URI[sha256sum] = "1a9d3bf26c821f369c175f8e68946b79bc994da4f96e8f5ecff06e6ee7ac0528" | ||
15 | |||
16 | S = "${WORKDIR}/sip-${PV}/siplib" | ||
17 | |||
18 | inherit qt4x11 distutils-base | ||
19 | |||
20 | EXTRA_QMAKEVARS_POST += " TEMPLATE=lib \ | ||
21 | CONFIG=console \ | ||
22 | DESTDIR= \ | ||
23 | VERSION=1.0.0 \ | ||
24 | TARGET=sip \ | ||
25 | DEFINES=SIP_QT_SUPPORT \ | ||
26 | INCLUDEPATH+=. \ | ||
27 | INCLUDEPATH+=${STAGING_INCDIR}/${PYTHON_DIR} \ | ||
28 | INCLUDEPATH+=${STAGING_INCDIR}" | ||
29 | |||
30 | |||
31 | do_configure_prepend() { | ||
32 | cat siplib.sbf.in | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, | sed s,@CFG_MODULE_BASENAME@,sip, > siplib.pro | ||
33 | cat siplib.c.in | sed s,@CFG_MODULE_BASENAME@,sip, > siplib.c | ||
34 | cat sip.h.in | sed -e s,@CFG_MODULE_NAME@,sip,g > sip.h | ||
35 | } | ||
36 | |||
37 | do_install() { | ||
38 | install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/ | ||
39 | install -m 0755 libsip.so.1.0.0 ${D}${libdir}/${PYTHON_DIR}/site-packages/sip.so | ||
40 | # sipconfig.py sipdistutils.py | ||
41 | install -d ${D}${includedir} | ||
42 | install -m 0644 ../siplib/sip.h ${D}${includedir}/sip.h | ||
43 | } | ||
44 | |||
45 | FILES_${PN} = "${libdir}/${PYTHON_DIR}/site-packages/sip.so" | ||
46 | |||
diff --git a/meta-oe/recipes-extended/sip/sip-native_4.14.2.bb b/meta-oe/recipes-extended/sip/sip-native_4.14.2.bb deleted file mode 100644 index 602dc250f..000000000 --- a/meta-oe/recipes-extended/sip/sip-native_4.14.2.bb +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | SUMMARY = "SIP is a C++/Python Wrapper Generator" | ||
2 | AUTHOR = "Phil Thompson" | ||
3 | HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip" | ||
4 | SECTION = "devel" | ||
5 | LICENSE = "GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://sipgen.sbf;endline=15;md5=61b2ce7ddd624968411804d2fa9d776c" | ||
7 | |||
8 | # riverbankcomputing is upstream, but keeps only latest version, sf usually have few older | ||
9 | #SRC_URI = "http://www.riverbankcomputing.com/static/Downloads/sip4/sip-${PV}.tar.gz" | ||
10 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/pyqt/sip/sip-${PV}/sip-${PV}.tar.gz" | ||
11 | SRC_URI[md5sum] = "b93442e745b3be2fad89de0686a76ce9" | ||
12 | SRC_URI[sha256sum] = "1a9d3bf26c821f369c175f8e68946b79bc994da4f96e8f5ecff06e6ee7ac0528" | ||
13 | S = "${WORKDIR}/sip-${PV}/sipgen" | ||
14 | |||
15 | inherit qmake2 native python-dir | ||
16 | |||
17 | EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console" | ||
18 | |||
19 | export BUILD_SYS | ||
20 | export HOST_SYS | ||
21 | export STAGING_LIBDIR | ||
22 | export STAGING_INCDIR | ||
23 | |||
24 | do_configure_prepend() { | ||
25 | cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro | ||
26 | } | ||
27 | do_install() { | ||
28 | install -d ${D}${bindir} | ||
29 | install -m 0755 sip ${D}${bindir}/sip | ||
30 | # python-pyqt expects sip4 | ||
31 | ln -sf sip ${D}${bindir}/sip4 | ||
32 | cd ${WORKDIR}/sip-${PV} && python configure.py | ||
33 | install -d ${D}${PYTHON_SITEPACKAGES_DIR} | ||
34 | install -m 0755 sip*.py ${D}${PYTHON_SITEPACKAGES_DIR} | ||
35 | } | ||
diff --git a/meta-oe/recipes-extended/sip/sip_4.16.4.bb b/meta-oe/recipes-extended/sip/sip_4.16.4.bb new file mode 100644 index 000000000..2a2674f91 --- /dev/null +++ b/meta-oe/recipes-extended/sip/sip_4.16.4.bb | |||
@@ -0,0 +1,50 @@ | |||
1 | SUMMARY = "SIP is a C++/Python Wrapper Generator" | ||
2 | AUTHOR = "Phil Thompson" | ||
3 | HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip" | ||
4 | SECTION = "devel" | ||
5 | LICENSE = "GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE-GPL2;md5=e91355d8a6f8bd8f7c699d62863c7303" | ||
7 | DEPENDS_class-target = "qt4-x11-free python" | ||
8 | |||
9 | # riverbankcomputing is upstream, but keeps only latest version, sf usually have few older | ||
10 | #SRC_URI = "http://www.riverbankcomputing.com/static/Downloads/sip4/sip-${PV}.tar.gz" | ||
11 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/pyqt/sip/sip-${PV}/sip-${PV}.tar.gz" | ||
12 | SRC_URI[md5sum] = "a9840670a064dbf8f63a8f653776fec9" | ||
13 | SRC_URI[sha256sum] = "ceda443fc5e129e67a067e2cd7b73ff037f8b10b50e407baa2b1d9f2199d57f5" | ||
14 | |||
15 | BBCLASSEXTEND = "native" | ||
16 | |||
17 | inherit qmake2 python-dir pythonnative | ||
18 | |||
19 | EXTRA_QMAKEVARS_POST += "CONFIG=console" | ||
20 | |||
21 | export BUILD_SYS | ||
22 | export HOST_SYS | ||
23 | export STAGING_LIBDIR | ||
24 | export STAGING_INCDIR | ||
25 | |||
26 | do_configure_prepend_class-target() { | ||
27 | echo "py_platform = linux" > sip.cfg | ||
28 | echo "py_inc_dir = %(sysroot)/${includedir}/python%(py_major).%(py_minor)" >> sip.cfg | ||
29 | echo "sip_bin_dir = ${D}/${bindir}" >> sip.cfg | ||
30 | echo "sip_inc_dir = ${D}/${includedir}" >> sip.cfg | ||
31 | echo "sip_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> sip.cfg | ||
32 | echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg | ||
33 | python configure.py --use-qmake --configuration sip.cfg --sysroot ${STAGING_DIR_HOST} | ||
34 | } | ||
35 | do_configure_prepend_class-native() { | ||
36 | echo "py_platform = linux" > sip.cfg | ||
37 | echo "py_inc_dir = ${includedir}/python%(py_major).%(py_minor)" >> sip.cfg | ||
38 | echo "sip_bin_dir = ${D}/${bindir}" >> sip.cfg | ||
39 | echo "sip_inc_dir = ${D}/${includedir}" >> sip.cfg | ||
40 | echo "sip_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> sip.cfg | ||
41 | echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg | ||
42 | python configure.py --use-qmake --configuration sip.cfg --sysroot ${STAGING_DIR_NATIVE} | ||
43 | } | ||
44 | do_install() { | ||
45 | oe_runmake install | ||
46 | } | ||
47 | |||
48 | FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages/" | ||
49 | FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug" | ||
50 | |||