diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-03-31 17:10:36 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-04-12 11:07:45 +0200 |
commit | af7c9165fc3a450eb56ce2475379a33a2d6b850d (patch) | |
tree | 6d33778293e1c7535d4b5ef82cb71521e21245a3 | |
parent | c7cb15542e94d58748c005656cacee3bc921253d (diff) | |
download | meta-openembedded-af7c9165fc3a450eb56ce2475379a33a2d6b850d.tar.gz |
serialcheck: Fix build with musl and mark BROKENCLEAN
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/serialcheck/serialcheck/0001-Makefile-Change-order-of-link-flags.patch | 34 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb | 9 |
2 files changed, 41 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/serialcheck/serialcheck/0001-Makefile-Change-order-of-link-flags.patch b/meta-oe/recipes-devtools/serialcheck/serialcheck/0001-Makefile-Change-order-of-link-flags.patch new file mode 100644 index 000000000..2ab48345d --- /dev/null +++ b/meta-oe/recipes-devtools/serialcheck/serialcheck/0001-Makefile-Change-order-of-link-flags.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From efc8a4e717ba919c869c2da1c7de2d08bc976926 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 24 Feb 2016 18:48:07 +0000 | ||
4 | Subject: [PATCH] Makefile: Change order of link flags | ||
5 | |||
6 | This helps in injectcting LDFLAGS from env to take effect | ||
7 | as it appears last on cmdline now | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Makefile | 10 ++++++++-- | ||
14 | 1 file changed, 8 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/Makefile b/Makefile | ||
17 | index ba2bfbb..6d13e68 100644 | ||
18 | --- a/Makefile | ||
19 | +++ b/Makefile | ||
20 | @@ -1,3 +1,9 @@ | ||
21 | -CFLAGS=-O2 -Wall -Wextra -g -Wno-sign-compare -Wno-pointer-sign | ||
22 | -CC=gcc | ||
23 | +CFLAGS?=-O2 -Wall -Wextra -g -Wno-sign-compare -Wno-pointer-sign | ||
24 | +CC?=gcc | ||
25 | all: serialcheck | ||
26 | +serialcheck : serialcheck.o | ||
27 | + $(CC) -o serialcheck serialcheck.o $(CFLAGS) $(LDFLAGS) | ||
28 | + | ||
29 | +%.o : %.c | ||
30 | + $(CC) -c $(CFLAGS) $(CPPFLAGS) $< -o $@ | ||
31 | + | ||
32 | -- | ||
33 | 1.9.1 | ||
34 | |||
diff --git a/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb b/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb index d2de523f9..cd5e0a4e5 100644 --- a/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb +++ b/meta-oe/recipes-devtools/serialcheck/serialcheck_1.0.0.bb | |||
@@ -4,16 +4,20 @@ LICENSE = "GPLv2" | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
5 | 5 | ||
6 | SRC_URI = "git://git.breakpoint.cc/bigeasy/serialcheck.git \ | 6 | SRC_URI = "git://git.breakpoint.cc/bigeasy/serialcheck.git \ |
7 | file://0001-Add-option-to-enable-internal-loopback.patch \ | 7 | file://0001-Add-option-to-enable-internal-loopback.patch \ |
8 | file://0002-Restore-original-loopback-config.patch" | 8 | file://0002-Restore-original-loopback-config.patch \ |
9 | file://0001-Makefile-Change-order-of-link-flags.patch \ | ||
10 | " | ||
9 | 11 | ||
10 | SRCREV = "63854a2d0c0129efab132ec328a75279e013fb84" | 12 | SRCREV = "63854a2d0c0129efab132ec328a75279e013fb84" |
11 | 13 | ||
12 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
13 | 15 | ||
16 | DEPENDS_append_libc-musl = " argp-standalone" | ||
14 | EXTRA_OEMAKE = "-e MAKEFLAGS=" | 17 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
15 | 18 | ||
16 | CFLAGS_prepend = "-Wall -Wextra -Wno-sign-compare -Wno-pointer-sign " | 19 | CFLAGS_prepend = "-Wall -Wextra -Wno-sign-compare -Wno-pointer-sign " |
20 | LDFLAGS_append_libc-musl = " -largp" | ||
17 | 21 | ||
18 | do_install() { | 22 | do_install() { |
19 | install -d ${D}${bindir} | 23 | install -d ${D}${bindir} |
@@ -21,5 +25,6 @@ do_install() { | |||
21 | install -d ${D}${docdir}/${BP} | 25 | install -d ${D}${docdir}/${BP} |
22 | install ${S}/Readme.txt ${D}${docdir}/${BP} | 26 | install ${S}/Readme.txt ${D}${docdir}/${BP} |
23 | } | 27 | } |
28 | CLEANBROKEN = "1" | ||
24 | 29 | ||
25 | BBCLASSEXTEND = "nativesdk" | 30 | BBCLASSEXTEND = "nativesdk" |