diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2018-04-26 00:05:05 +0200 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-05-01 18:17:02 -0700 |
commit | aedf26e08ad0dd5244c2bc49181bc77df18ebd08 (patch) | |
tree | f829572710b8bb4e46972b6a288bd3c4b08905da | |
parent | 213c47118c571dfbd3bf5749341bd944d884c7c9 (diff) | |
download | meta-openembedded-aedf26e08ad0dd5244c2bc49181bc77df18ebd08.tar.gz |
networkmanager: fix prevous commits
The wrong patches were applied:
commit c5a04600817e0d34dfa151d46073a76b506b4c3d
Author: Armin Kuster <akuster808@gmail.com>
Date: Fri Mar 30 19:56:03 2018 -0700
networkmanager: Fix many typos in DISTRO_FEATURES PACKAGECONFIG decodes
commit 575c14ded56e1e97582a6df0921d19b4da630961
Author: Andreas Müller <schnitzeltony@gmail.com>
Date: Thu Mar 22 18:40:52 2018 +0100
networkmanager: fix gobject-introspection/musl and cleanup
* musl fixed (tested)
* PACKAGECONFIG systemd: Logic was broken by c5a046. To avoid
further confusion, the expression was put into one line.
* PACKAGECONFIG wifi: The expression 'bb.utils.filter.. ' was perfectly fine.
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
3 files changed, 134 insertions, 4 deletions
diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager/musl/0005-musl-avoid-further-conflicts-by-including-net-ethern.patch b/meta-networking/recipes-connectivity/networkmanager/networkmanager/musl/0005-musl-avoid-further-conflicts-by-including-net-ethern.patch new file mode 100644 index 000000000..752fe4f58 --- /dev/null +++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager/musl/0005-musl-avoid-further-conflicts-by-including-net-ethern.patch | |||
@@ -0,0 +1,77 @@ | |||
1 | From b3b4fe35018c98ad176719b2d9ffb867974fc7c3 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> | ||
3 | Date: Mon, 16 Apr 2018 14:45:44 +0200 | ||
4 | Subject: [PATCH] musl: avoid further conflicts by including net/ethernet.h | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> | ||
12 | --- | ||
13 | src/systemd/src/systemd/sd-dhcp-client.h | 2 ++ | ||
14 | src/systemd/src/systemd/sd-dhcp-lease.h | 2 ++ | ||
15 | src/systemd/src/systemd/sd-dhcp6-client.h | 2 ++ | ||
16 | src/systemd/src/systemd/sd-ipv4ll.h | 2 ++ | ||
17 | 4 files changed, 8 insertions(+) | ||
18 | |||
19 | diff --git a/src/systemd/src/systemd/sd-dhcp-client.h b/src/systemd/src/systemd/sd-dhcp-client.h | ||
20 | index 5e46d8d..18a613f 100644 | ||
21 | --- a/src/systemd/src/systemd/sd-dhcp-client.h | ||
22 | +++ b/src/systemd/src/systemd/sd-dhcp-client.h | ||
23 | @@ -21,7 +21,9 @@ | ||
24 | ***/ | ||
25 | |||
26 | #include <inttypes.h> | ||
27 | +#if defined(__GLIBC__) | ||
28 | #include <net/ethernet.h> | ||
29 | +#endif | ||
30 | #include <netinet/in.h> | ||
31 | #include <sys/types.h> | ||
32 | |||
33 | diff --git a/src/systemd/src/systemd/sd-dhcp-lease.h b/src/systemd/src/systemd/sd-dhcp-lease.h | ||
34 | index 7ab99cc..85acdf2 100644 | ||
35 | --- a/src/systemd/src/systemd/sd-dhcp-lease.h | ||
36 | +++ b/src/systemd/src/systemd/sd-dhcp-lease.h | ||
37 | @@ -22,7 +22,9 @@ | ||
38 | ***/ | ||
39 | |||
40 | #include <inttypes.h> | ||
41 | +#if defined(__GLIBC__) | ||
42 | #include <net/ethernet.h> | ||
43 | +#endif | ||
44 | #include <netinet/in.h> | ||
45 | #include <sys/types.h> | ||
46 | |||
47 | diff --git a/src/systemd/src/systemd/sd-dhcp6-client.h b/src/systemd/src/systemd/sd-dhcp6-client.h | ||
48 | index 7819f0d..35f30ee 100644 | ||
49 | --- a/src/systemd/src/systemd/sd-dhcp6-client.h | ||
50 | +++ b/src/systemd/src/systemd/sd-dhcp6-client.h | ||
51 | @@ -21,7 +21,9 @@ | ||
52 | ***/ | ||
53 | |||
54 | #include <inttypes.h> | ||
55 | +#if defined(__GLIBC__) | ||
56 | #include <net/ethernet.h> | ||
57 | +#endif | ||
58 | #include <sys/types.h> | ||
59 | |||
60 | #include "sd-dhcp6-lease.h" | ||
61 | diff --git a/src/systemd/src/systemd/sd-ipv4ll.h b/src/systemd/src/systemd/sd-ipv4ll.h | ||
62 | index 5ba9208..c90eca6 100644 | ||
63 | --- a/src/systemd/src/systemd/sd-ipv4ll.h | ||
64 | +++ b/src/systemd/src/systemd/sd-ipv4ll.h | ||
65 | @@ -20,7 +20,9 @@ | ||
66 | along with systemd; If not, see <http://www.gnu.org/licenses/>. | ||
67 | ***/ | ||
68 | |||
69 | +#if defined(__GLIBC__) | ||
70 | #include <net/ethernet.h> | ||
71 | +#endif | ||
72 | #include <netinet/in.h> | ||
73 | |||
74 | #include "sd-event.h" | ||
75 | -- | ||
76 | 2.14.3 | ||
77 | |||
diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager/musl/0006-Add-a-strndupa-replacement-for-musl.patch b/meta-networking/recipes-connectivity/networkmanager/networkmanager/musl/0006-Add-a-strndupa-replacement-for-musl.patch new file mode 100644 index 000000000..8ed7ee64f --- /dev/null +++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager/musl/0006-Add-a-strndupa-replacement-for-musl.patch | |||
@@ -0,0 +1,47 @@ | |||
1 | From 6db6596e450062601d18b2ae812a4a58d2e03a53 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> | ||
3 | Date: Mon, 16 Apr 2018 15:07:20 +0200 | ||
4 | Subject: [PATCH] Add a strndupa replacement for musl | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> | ||
12 | --- | ||
13 | src/systemd/src/basic/in-addr-util.c | 1 + | ||
14 | src/systemd/src/basic/string-util.h | 5 +++++ | ||
15 | 2 files changed, 6 insertions(+) | ||
16 | |||
17 | diff --git a/src/systemd/src/basic/in-addr-util.c b/src/systemd/src/basic/in-addr-util.c | ||
18 | index 2a02d90..a57c360 100644 | ||
19 | --- a/src/systemd/src/basic/in-addr-util.c | ||
20 | +++ b/src/systemd/src/basic/in-addr-util.c | ||
21 | @@ -30,6 +30,7 @@ | ||
22 | #include "in-addr-util.h" | ||
23 | #include "macro.h" | ||
24 | #include "parse-util.h" | ||
25 | +#include "string-util.h" | ||
26 | #include "util.h" | ||
27 | |||
28 | bool in4_addr_is_null(const struct in_addr *a) { | ||
29 | diff --git a/src/systemd/src/basic/string-util.h b/src/systemd/src/basic/string-util.h | ||
30 | index 4c94b18..a6dc446 100644 | ||
31 | --- a/src/systemd/src/basic/string-util.h | ||
32 | +++ b/src/systemd/src/basic/string-util.h | ||
33 | @@ -44,6 +44,11 @@ | ||
34 | #define strcaseeq(a,b) (strcasecmp((a),(b)) == 0) | ||
35 | #define strncaseeq(a, b, n) (strncasecmp((a), (b), (n)) == 0) | ||
36 | |||
37 | +/* musl does not know strndupa */ | ||
38 | +#if !defined(__GLIBC__) | ||
39 | +#define strndupa(x,s) strncpy(alloca(strlen(x)+1),x,s) | ||
40 | +#endif | ||
41 | + | ||
42 | int strcmp_ptr(const char *a, const char *b) _pure_; | ||
43 | |||
44 | static inline bool streq_ptr(const char *a, const char *b) { | ||
45 | -- | ||
46 | 2.14.3 | ||
47 | |||
diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.10.6.bb b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.10.6.bb index d90b78268..31fa13241 100644 --- a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.10.6.bb +++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.10.6.bb | |||
@@ -35,6 +35,8 @@ SRC_URI = " \ | |||
35 | file://musl/0002-musl-dlopen-configure-ac.patch \ | 35 | file://musl/0002-musl-dlopen-configure-ac.patch \ |
36 | file://musl/0003-musl-network-support.patch \ | 36 | file://musl/0003-musl-network-support.patch \ |
37 | file://musl/0004-musl-process-util.patch \ | 37 | file://musl/0004-musl-process-util.patch \ |
38 | file://musl/0005-musl-avoid-further-conflicts-by-including-net-ethern.patch \ | ||
39 | file://musl/0006-Add-a-strndupa-replacement-for-musl.patch \ | ||
38 | " | 40 | " |
39 | SRC_URI[md5sum] = "de3c7147a693da6f80eb22f126086a14" | 41 | SRC_URI[md5sum] = "de3c7147a693da6f80eb22f126086a14" |
40 | SRC_URI[sha256sum] = "6af0b1e856a3725f88791f55c4fbb04105dc0b20dbf182aaec8aad16481fac76" | 42 | SRC_URI[sha256sum] = "6af0b1e856a3725f88791f55c4fbb04105dc0b20dbf182aaec8aad16481fac76" |
@@ -54,17 +56,21 @@ EXTRA_OECONF = " \ | |||
54 | # gobject-introspection related | 56 | # gobject-introspection related |
55 | GI_DATA_ENABLED_libc-musl = "False" | 57 | GI_DATA_ENABLED_libc-musl = "False" |
56 | 58 | ||
59 | # stolen from https://github.com/voidlinux/void-packages/blob/master/srcpkgs/NetworkManager/template | ||
60 | CFLAGS_libc-musl_append = " \ | ||
61 | -DHAVE_SECURE_GETENV -Dsecure_getenv=getenv \ | ||
62 | -D__USE_POSIX199309 -DRTLD_DEEPBIND=0 \ | ||
63 | " | ||
64 | |||
57 | do_compile_prepend() { | 65 | do_compile_prepend() { |
58 | export GIR_EXTRA_LIBS_PATH="${B}/libnm/.libs:${B}/libnm-glib/.libs:${B}/libnm-util/.libs" | 66 | export GIR_EXTRA_LIBS_PATH="${B}/libnm/.libs:${B}/libnm-glib/.libs:${B}/libnm-util/.libs" |
59 | } | 67 | } |
60 | 68 | ||
61 | PACKAGECONFIG ??= "nss ifupdown netconfig dhclient dnsmasq \ | 69 | PACKAGECONFIG ??= "nss ifupdown netconfig dhclient dnsmasq \ |
62 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \ | 70 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \ |
63 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d)} \ | ||
64 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', '${BLUEZ}', '', d)} \ | 71 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', '${BLUEZ}', '', d)} \ |
65 | ${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'wifi', '', d)} \ | 72 | ${@bb.utils.filter('DISTRO_FEATURES', 'wifi', d)} \ |
66 | " | 73 | " |
67 | |||
68 | PACKAGECONFIG[systemd] = " \ | 74 | PACKAGECONFIG[systemd] = " \ |
69 | --with-systemdsystemunitdir=${systemd_unitdir}/system --with-session-tracking=systemd --enable-polkit, \ | 75 | --with-systemdsystemunitdir=${systemd_unitdir}/system --with-session-tracking=systemd --enable-polkit, \ |
70 | --without-systemdsystemunitdir, \ | 76 | --without-systemdsystemunitdir, \ |