diff options
author | Armin Kuster <akuster@mvista.com> | 2015-01-23 09:43:46 -0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2015-01-26 10:27:55 -0500 |
commit | 8912083e23e0fde68a2619f3df6b48e2e6f28197 (patch) | |
tree | cf990f0a7517fd8d5b59aabb1f39a5c7c8ae6b7f | |
parent | 6b76fffbb16351d0031c6b863a2deb9c60ec8dc7 (diff) | |
download | meta-openembedded-8912083e23e0fde68a2619f3df6b48e2e6f28197.tar.gz |
wireshark: fix rdepends issue
Added a few more PACKAGECONF options
Signed-off-by: Armin Kuster <akuster@mvista.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r-- | meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb | 14 |
1 files changed, 11 insertions, 3 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb b/meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb index 2dd99d698..7604bd7ff 100644 --- a/meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb +++ b/meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb | |||
@@ -4,7 +4,7 @@ SECTION = "network" | |||
4 | LICENSE = "GPL-2.0" | 4 | LICENSE = "GPL-2.0" |
5 | LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0" | 5 | LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0" |
6 | 6 | ||
7 | DEPENDS = "perl-native libcap libpcap pcre expat glib-2.0 libnl sbc" | 7 | DEPENDS = "perl-native libcap libpcap pcre expat glib-2.0 sbc" |
8 | 8 | ||
9 | SRC_URI = " \ | 9 | SRC_URI = " \ |
10 | http://wiresharkdownloads.riverbed.com/wireshark/src/wireshark-${PV}.tar.bz2 \ | 10 | http://wiresharkdownloads.riverbed.com/wireshark/src/wireshark-${PV}.tar.bz2 \ |
@@ -23,11 +23,12 @@ ARM_INSTRUCTION_SET = "arm" | |||
23 | # Works with either gtk+ or gtk3. | 23 | # Works with either gtk+ or gtk3. |
24 | WHICH_GTK = "gtk3" | 24 | WHICH_GTK = "gtk3" |
25 | 25 | ||
26 | PACKAGECONFIG ??= "gnutls gcrypt" | 26 | PACKAGECONFIG ??= "gnutls gcrypt libnl" |
27 | PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "${WHICH_GTK} graphics", "", d)}" | 27 | PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "${WHICH_GTK} graphics", "", d)}" |
28 | PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}" | 28 | PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}" |
29 | 29 | ||
30 | PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi" | 30 | PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi" |
31 | PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl" | ||
31 | PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19" | 32 | PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19" |
32 | PACKAGECONFIG[gtk2] = "--with-gtk2=yes, --with-gtk2=no, gtk+" | 33 | PACKAGECONFIG[gtk2] = "--with-gtk2=yes, --with-gtk2=no, gtk+" |
33 | PACKAGECONFIG[gtk3] = "--with-gtk3=yes, --with-gtk3=no, gtk+3" | 34 | PACKAGECONFIG[gtk3] = "--with-gtk3=yes, --with-gtk3=no, gtk+3" |
@@ -36,8 +37,15 @@ PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6," | |||
36 | PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls" | 37 | PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls" |
37 | PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt" | 38 | PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt" |
38 | PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5" | 39 | PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5" |
40 | PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua" | ||
41 | PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib" | ||
42 | PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip" | ||
39 | 43 | ||
40 | EXTRA_OECONF = "--with-qt=no --enable-usr-local=no --enable-tshark --with-c-ares=no" | 44 | # these next two options require addional layers |
45 | PACKAGECONFIG[adns] = "--with-adns=yes, --with-adns=no, adns" | ||
46 | PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares" | ||
47 | |||
48 | EXTRA_OECONF = "--with-qt=no --enable-usr-local=no --enable-tshark" | ||
41 | 49 | ||
42 | do_configure_prepend() { | 50 | do_configure_prepend() { |
43 | # force to use fallback | 51 | # force to use fallback |