diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2013-10-16 22:42:16 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-10-21 12:15:02 +0200 |
commit | 86543b7c3c31e31bb6819245a397e12688d77d70 (patch) | |
tree | e2bf35d40f7b21c696c0468d8a155b5a532b7b99 | |
parent | 19943f942746b0e628ef894c02a1c7f26288d682 (diff) | |
download | meta-openembedded-86543b7c3c31e31bb6819245a397e12688d77d70.tar.gz |
xfconf: fix compile
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-xfce/recipes-xfce/xfconf/files/0001-Simplify-checks.patch | 112 | ||||
-rw-r--r-- | meta-xfce/recipes-xfce/xfconf/xfconf_4.10.0.bb | 1 |
2 files changed, 113 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfconf/files/0001-Simplify-checks.patch b/meta-xfce/recipes-xfce/xfconf/files/0001-Simplify-checks.patch new file mode 100644 index 000000000..ef68f7acd --- /dev/null +++ b/meta-xfce/recipes-xfce/xfconf/files/0001-Simplify-checks.patch | |||
@@ -0,0 +1,112 @@ | |||
1 | From 233f7d3a9b0f98b794548433cead77633aab5f7d Mon Sep 17 00:00:00 2001 | ||
2 | From: Nick Schermer <nick@xfce.org> | ||
3 | Date: Sun, 6 Jan 2013 12:46:47 +0100 | ||
4 | Subject: [PATCH] Simplify checks. | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Upstream-Status: backport [1] | ||
10 | |||
11 | [1] http://git.xfce.org/xfce/xfconf/commit/?id=233f7d3a9b0f98b794548433cead77633aab5f7d | ||
12 | |||
13 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
14 | --- | ||
15 | tests/Makefile.am | 1 - | ||
16 | tests/Makefile.inc | 9 +-------- | ||
17 | tests/test-template.sh.in | 49 ----------------------------------------------- | ||
18 | 3 files changed, 1 insertion(+), 58 deletions(-) | ||
19 | delete mode 100644 tests/test-template.sh.in | ||
20 | |||
21 | diff --git a/tests/Makefile.am b/tests/Makefile.am | ||
22 | index 57165d9..57ba7e8 100644 | ||
23 | --- a/tests/Makefile.am | ||
24 | +++ b/tests/Makefile.am | ||
25 | @@ -13,5 +13,4 @@ clean-local: | ||
26 | |||
27 | EXTRA_DIST = \ | ||
28 | $(test_scripts) \ | ||
29 | - test-template.sh.in \ | ||
30 | tests-common.h | ||
31 | diff --git a/tests/Makefile.inc b/tests/Makefile.inc | ||
32 | index 2ed3431..7a5a715 100644 | ||
33 | --- a/tests/Makefile.inc | ||
34 | +++ b/tests/Makefile.inc | ||
35 | @@ -13,9 +13,7 @@ | ||
36 | # along with this program; if not, write to the Free Software | ||
37 | # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA | ||
38 | |||
39 | -check_SCRIPTS = $(addsuffix .sh,$(check_PROGRAMS)) | ||
40 | - | ||
41 | -TESTS = $(check_SCRIPTS) | ||
42 | +TESTS = $(check_PROGRAMS) | ||
43 | TESTS_ENVIRONMENT = XDG_CONFIG_HOME="$(top_builddir)/tests/test-xdg_config_home" XFCONFD="$(top_builddir)/xfconfd/xfconfd" | ||
44 | |||
45 | AM_CFLAGS = \ | ||
46 | @@ -27,8 +25,3 @@ AM_CFLAGS = \ | ||
47 | LIBS = \ | ||
48 | $(top_builddir)/xfconf/libxfconf-$(LIBXFCONF_VERSION_API).la | ||
49 | |||
50 | -%.sh: $(top_srcdir)/tests/test-template.sh.in Makefile | ||
51 | - sed -e 's/@TEST_NAME@/$@/; s/\.sh//;' <$(top_srcdir)/tests/test-template.sh.in >$@ | ||
52 | - chmod 755 $@ | ||
53 | - | ||
54 | -CLEANFILES = $(check_SCRIPTS) | ||
55 | diff --git a/tests/test-template.sh.in b/tests/test-template.sh.in | ||
56 | deleted file mode 100644 | ||
57 | index 2e638a8..0000000 | ||
58 | --- a/tests/test-template.sh.in | ||
59 | +++ /dev/null | ||
60 | @@ -1,49 +0,0 @@ | ||
61 | -#!/bin/sh | ||
62 | - | ||
63 | -cleanup() { | ||
64 | - if [ "$XFCONFD_PID" ]; then | ||
65 | - kill -TERM $XFCONFD_PID 2>/dev/null | ||
66 | - sleep 1 | ||
67 | - kill -KILL $XFCONFD_PID 2>/dev/null | ||
68 | - fi | ||
69 | - | ||
70 | - kill -TERM $DBUS_SESSION_BUS_PID 2>/dev/null | ||
71 | - sleep 1 | ||
72 | - kill -KILL $DBUS_SESSION_BUS_PID 2>/dev/null | ||
73 | -} | ||
74 | - | ||
75 | -die() { | ||
76 | - [ "$1" ] && echo "$1" >&2 | ||
77 | - cleanup | ||
78 | - exit 1 | ||
79 | -} | ||
80 | - | ||
81 | -# some buildbots have problems with the tests (dbus not | ||
82 | -# working properly without an X11 server). | ||
83 | -if [ -n "$XFCONF_SKIP_TESTS" ]; then | ||
84 | - echo "Warning: Tests disabled, skipping @TEST_NAME@" >&2 | ||
85 | - exit 0 | ||
86 | -fi | ||
87 | - | ||
88 | -unset DBUS_SESSION_BUS_ADDRESS | ||
89 | -unset DBUS_SESSION_BUS_PID | ||
90 | -unset XFCONFD_PID | ||
91 | - | ||
92 | -eval `dbus-launch --sh-syntax` | ||
93 | -export DBUS_SESSION_BUS_ADDRESS | ||
94 | -export DBUS_SESSION_BUS_PID | ||
95 | - | ||
96 | -[ "$DBUS_SESSION_BUS_PID" ] || die "DBus failed to start" | ||
97 | - | ||
98 | -trap "die Interrupted" INT | ||
99 | - | ||
100 | -eval `$XFCONFD --daemon 2>/dev/null` || die "Failed to start xfconfd" | ||
101 | - | ||
102 | -export XDG_CONFIG_HOME # make sure it's exported from the makefile | ||
103 | -export XDG_CONFIG_DIRS="" | ||
104 | - | ||
105 | -./@TEST_NAME@ || die "Test Failed" | ||
106 | - | ||
107 | -cleanup | ||
108 | - | ||
109 | -exit 0 | ||
110 | -- | ||
111 | 1.8.3.1 | ||
112 | |||
diff --git a/meta-xfce/recipes-xfce/xfconf/xfconf_4.10.0.bb b/meta-xfce/recipes-xfce/xfconf/xfconf_4.10.0.bb index 5dceb0902..4ea2b8848 100644 --- a/meta-xfce/recipes-xfce/xfconf/xfconf_4.10.0.bb +++ b/meta-xfce/recipes-xfce/xfconf/xfconf_4.10.0.bb | |||
@@ -6,6 +6,7 @@ DEPENDS = "dbus-glib libxfce4util perl-native" | |||
6 | 6 | ||
7 | inherit xfce | 7 | inherit xfce |
8 | 8 | ||
9 | SRC_URI += "file://0001-Simplify-checks.patch" | ||
9 | SRC_URI[md5sum] = "4ed48150a03fb5f42b455494307b7f28" | 10 | SRC_URI[md5sum] = "4ed48150a03fb5f42b455494307b7f28" |
10 | SRC_URI[sha256sum] = "175219a441cc7d0f210bbd1a3b0abba41598627cd9db27235811400c3e100576" | 11 | SRC_URI[sha256sum] = "175219a441cc7d0f210bbd1a3b0abba41598627cd9db27235811400c3e100576" |
11 | 12 | ||