diff options
author | Pascal Bach <pascal.bach@siemens.com> | 2017-04-21 15:20:16 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-26 20:13:29 +0200 |
commit | 850ab4df1679e675b26acec5442c9604ac04ebf4 (patch) | |
tree | e654808d48005c104b8d3fccac2e6d09b7f2f95c | |
parent | 8c1c8c269b3e798cd410326ed6c4ff25bc7c290d (diff) | |
download | meta-openembedded-850ab4df1679e675b26acec5442c9604ac04ebf4.tar.gz |
python3-pytest-runner: make available for both Python 2 & 3
Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
3 files changed, 23 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest-runner.inc b/meta-python/recipes-devtools/python/python-pytest-runner.inc new file mode 100644 index 000000000..85a8de1f5 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pytest-runner.inc | |||
@@ -0,0 +1,17 @@ | |||
1 | SUMMARY = "Invoke py.test as distutils command with dependency resolution" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e38b971c2b4c33b978d1b9c9ece9ae63" | ||
4 | |||
5 | SRC_URI[md5sum] = "bdb73eb18eca2727944a2dcf963c5a81" | ||
6 | SRC_URI[sha256sum] = "983a31eab45e375240e250161a556163bc8d250edaba97960909338c273a89b3" | ||
7 | |||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | DEPENDS += " \ | ||
12 | ${PYTHON_PN}-setuptools-scm-native" | ||
13 | |||
14 | RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-argparse ${PYTHON_PN}-debugger ${PYTHON_PN}-json \ | ||
15 | ${PYTHON_PN}-io" | ||
16 | |||
17 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb b/meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb index 188ef2b3c..0a5055cb3 100644 --- a/meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb +++ b/meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb | |||
@@ -1,14 +1,5 @@ | |||
1 | SUMMARY = "Invoke py.test as distutils command with dependency resolution" | 1 | inherit setuptools |
2 | LICENSE = "MIT" | 2 | require python-pytest-runner.inc |
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e38b971c2b4c33b978d1b9c9ece9ae63" | ||
4 | 3 | ||
5 | SRC_URI[md5sum] = "bdb73eb18eca2727944a2dcf963c5a81" | 4 | # Dependency only exists for python2 |
6 | SRC_URI[sha256sum] = "983a31eab45e375240e250161a556163bc8d250edaba97960909338c273a89b3" | 5 | RDEPENDS_${PN} += "python-compiler" |
7 | |||
8 | DEPENDS += " \ | ||
9 | python-setuptools-scm" | ||
10 | |||
11 | RDEPENDS_${PN} = "python-py python-setuptools python-argparse python-debugger python-json \ | ||
12 | python-compiler python-io" | ||
13 | |||
14 | inherit pypi setuptools | ||
diff --git a/meta-python/recipes-devtools/python/python3-pytest-runner_2.11.1.bb b/meta-python/recipes-devtools/python/python3-pytest-runner_2.11.1.bb new file mode 100644 index 000000000..df56ba6d4 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pytest-runner_2.11.1.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-pytest-runner.inc | ||