diff options
author | Andrea Galbusera <gizero@gmail.com> | 2018-04-26 09:46:53 +0200 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-05-01 18:17:03 -0700 |
commit | 76326951d683c9d4a754d0837370a45462fec28a (patch) | |
tree | 72be603aa765baaa5a4fdb7a746df882e2ce4f4e | |
parent | aedf26e08ad0dd5244c2bc49181bc77df18ebd08 (diff) | |
download | meta-openembedded-76326951d683c9d4a754d0837370a45462fec28a.tar.gz |
python-flask-restful: add recipe for 0.3.6 version
Flask-RESTful is a simple framework for creating REST APIs with Flask
Signed-off-by: Andrea Galbusera <gizero@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
3 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-restful.inc b/meta-python/recipes-devtools/python/python-flask-restful.inc new file mode 100644 index 000000000..0485f85aa --- /dev/null +++ b/meta-python/recipes-devtools/python/python-flask-restful.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "Simple framework for creating REST APIs" | ||
2 | DESCRIPTION = "\ | ||
3 | Flask-RESTful is an extension for Flask that adds support for quickly building \ | ||
4 | REST APIs" | ||
5 | HOMEPAGE = "https://github.com/flask-restful/flask-restful" | ||
6 | LICENSE = "BSD-3-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=685bb55ed99a366bb431995f5eef2783" | ||
8 | |||
9 | SRC_URI[md5sum] = "8243ca101185b130d8fa529cbdbdbddd" | ||
10 | SRC_URI[sha256sum] = "5795519501347e108c436b693ff9a4d7b373a3ac9069627d64e4001c05dd3407" | ||
11 | |||
12 | inherit pypi | ||
13 | |||
14 | PYPI_PACKAGE = "Flask-RESTful" | ||
15 | |||
16 | RDEPENDS_${PN} = "${PYTHON_PN}-flask" | ||
diff --git a/meta-python/recipes-devtools/python/python-flask-restful_0.3.6.bb b/meta-python/recipes-devtools/python/python-flask-restful_0.3.6.bb new file mode 100644 index 000000000..1968d1d9d --- /dev/null +++ b/meta-python/recipes-devtools/python/python-flask-restful_0.3.6.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-flask-restful.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-flask-restful_0.3.6.bb b/meta-python/recipes-devtools/python/python3-flask-restful_0.3.6.bb new file mode 100644 index 000000000..6bff59a56 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-flask-restful_0.3.6.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-flask-restful.inc | ||