diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2014-03-14 16:36:47 +0800 |
---|---|---|
committer | Joe MacDonald <joe@deserted.net> | 2014-03-14 08:51:44 -0400 |
commit | 60c49640554b62afc8c9e5ce54db93b76b03f6c3 (patch) | |
tree | d4a67da9442a5db768e8b38a5da680900fd0f468 | |
parent | 5c9849cd39422ba28f217ba954cdde859a3fe75b (diff) | |
download | meta-openembedded-60c49640554b62afc8c9e5ce54db93b76b03f6c3.tar.gz |
netcf: fix offline rebuilding failed
The netcf downloaded gnulib source to ${S} at the configure time,
while the network disconnected, if sstate cache was cleaned, the
netcf rebuilding failed.
Added a new recipe named 'gnulib' to download gnulib source to
${GITDIR} and populate it to the staging data dir.
So netcf could specify this local directory where gnulib sources
reside to save the bandwidth downloading.
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r-- | meta-networking/recipes-support/netcf/gnulib_git.bb | 35 | ||||
-rw-r--r-- | meta-networking/recipes-support/netcf/netcf_git.bb | 5 |
2 files changed, 38 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/netcf/gnulib_git.bb b/meta-networking/recipes-support/netcf/gnulib_git.bb new file mode 100644 index 000000000..730f5cd78 --- /dev/null +++ b/meta-networking/recipes-support/netcf/gnulib_git.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | SUMMARY = "The GNU portability library" | ||
2 | DESCRIPTION = "A collection of software subroutines which are designed to \ | ||
3 | be usable on many operating systems. The goal of the project \ | ||
4 | is to make it easy for free software authors to make their \ | ||
5 | software run on many operating systems. Since source is designed \ | ||
6 | to be copied from gnulib, it is not a library per-se, as much \ | ||
7 | as a collection of portable idioms to be used in other projects." | ||
8 | |||
9 | HOMEPAGE = "http://www.gnu.org/software/gnulib/" | ||
10 | SECTION = "libs" | ||
11 | LICENSE = "LGPLv2+" | ||
12 | |||
13 | LIC_FILES_CHKSUM = "file://COPYING;md5=e4cf3810f33a067ea7ccd2cd889fed21" | ||
14 | SRCREV = "24379a9217fa4bd62685795aaaa010fd90ced9e3" | ||
15 | SRC_URI = "git://git.sv.gnu.org/gnulib;protocol=git \ | ||
16 | " | ||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | # Git clone a copy of gnulib source to the staging data dir | ||
20 | sysroot_stage_all () { | ||
21 | [ -d ${STAGING_DATADIR}/gnulib/ ] && rm -rf ${STAGING_DATADIR}/gnulib/ | ||
22 | cd ${S} | ||
23 | git checkout master | ||
24 | git clone ${S} ${STAGING_DATADIR}/gnulib | ||
25 | } | ||
26 | |||
27 | do_patch[noexec] = "1" | ||
28 | do_configure[noexec] = "1" | ||
29 | do_compile[noexec] = "1" | ||
30 | do_install[noexec] = "1" | ||
31 | do_package[noexec] = "1" | ||
32 | do_packagedata[noexec] = "1" | ||
33 | do_package_write_ipk[noexec] = "1" | ||
34 | do_package_write_deb[noexec] = "1" | ||
35 | do_package_write_rpm[noexec] = "1" | ||
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb index 93f8c70d3..6c36ce848 100644 --- a/meta-networking/recipes-support/netcf/netcf_git.bb +++ b/meta-networking/recipes-support/netcf/netcf_git.bb | |||
@@ -12,7 +12,7 @@ PV = "0.2.3+git${SRCPV}" | |||
12 | SRC_URI = "git://git.fedorahosted.org/netcf.git;protocol=git \ | 12 | SRC_URI = "git://git.fedorahosted.org/netcf.git;protocol=git \ |
13 | " | 13 | " |
14 | 14 | ||
15 | DEPENDS += "augeas libnl libxslt libxml2" | 15 | DEPENDS += "augeas libnl libxslt libxml2 gnulib" |
16 | 16 | ||
17 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
18 | 18 | ||
@@ -21,6 +21,7 @@ inherit gettext autotools | |||
21 | EXTRA_OECONF_append_class-target = " --with-driver=redhat" | 21 | EXTRA_OECONF_append_class-target = " --with-driver=redhat" |
22 | do_configure_prepend() { | 22 | do_configure_prepend() { |
23 | cd ${S} | 23 | cd ${S} |
24 | ./bootstrap | 24 | rm -f .gitmodules |
25 | ./bootstrap --gnulib-srcdir=${STAGING_DATADIR}/gnulib | ||
25 | } | 26 | } |
26 | 27 | ||