summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2018-04-17 16:20:18 +0200
committerArmin Kuster <akuster808@gmail.com>2018-05-01 18:15:44 -0700
commit266ccace9cd382d565ff1585c7bd8c19da147a39 (patch)
tree0d20e95e049c5b2a12a5e68909b716c59703ff9a
parent331e3d406e445c27f024dc73202ec4478a7ab32b (diff)
downloadmeta-openembedded-266ccace9cd382d565ff1585c7bd8c19da147a39.tar.gz
libgpiod: split recipe into .inc and .bb files
The build works the same for v0.x and v1.x series - leave only the hashes in the .bb file and put everything else into .inc. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod.inc21
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_0.3.2.bb22
2 files changed, 22 insertions, 21 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod.inc b/meta-oe/recipes-support/libgpiod/libgpiod.inc
new file mode 100644
index 000000000..cd7750623
--- /dev/null
+++ b/meta-oe/recipes-support/libgpiod/libgpiod.inc
@@ -0,0 +1,21 @@
1SUMMARY = "C library and tools for interacting with the linux GPIO character device"
2
3LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
5
6SRC_URI = "https://www.kernel.org/pub/software/libs/libgpiod/${BP}.tar.xz"
7
8inherit autotools pkgconfig
9
10# enable tools
11PACKAGECONFIG ?= "tools"
12
13PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
14PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,"
15
16PACKAGES =+ " ${PN}-tools"
17
18FILES_${PN}-tools = "${bindir}/*"
19
20RRECOMMENDS_TOOLS = "${@bb.utils.contains('PACKAGECONFIG', 'tools', '${PN}-tools', '',d)}"
21RRECOMMENDS_${PN} += "${RRECOMMENDS_TOOLS}"
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_0.3.2.bb b/meta-oe/recipes-support/libgpiod/libgpiod_0.3.2.bb
index 20068894e..ea785ad0c 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_0.3.2.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_0.3.2.bb
@@ -1,24 +1,4 @@
1SUMMARY = "C library and tools for interacting with the linux GPIO character device" 1require libgpiod.inc
2
3LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
5
6SRC_URI = "https://www.kernel.org/pub/software/libs/libgpiod/${BP}.tar.xz"
7 2
8SRC_URI[md5sum] = "9c1966bea7dffd59bd099a8b2930e2ea" 3SRC_URI[md5sum] = "9c1966bea7dffd59bd099a8b2930e2ea"
9SRC_URI[sha256sum] = "50c7862428ca90b58672e2475aea66d33a6fc86c6bab1928c0660f3aedf44a37" 4SRC_URI[sha256sum] = "50c7862428ca90b58672e2475aea66d33a6fc86c6bab1928c0660f3aedf44a37"
10
11inherit autotools pkgconfig
12
13# enable tools
14PACKAGECONFIG ?= "tools"
15
16PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
17PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,"
18
19PACKAGES =+ " ${PN}-tools"
20
21FILES_${PN}-tools = "${bindir}/*"
22
23RRECOMMENDS_TOOLS = "${@bb.utils.contains('PACKAGECONFIG', 'tools', '${PN}-tools', '',d)}"
24RRECOMMENDS_${PN} += "${RRECOMMENDS_TOOLS}"