diff options
author | Ross Burton <ross.burton@intel.com> | 2016-10-10 17:31:05 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-10-21 18:20:44 +0200 |
commit | fded4cf6a8cf1ff065af97f3283b55aeba458d28 (patch) | |
tree | a0cd377de2e76bed6c237cdf675822ed424fc056 | |
parent | df9dac1d6ccb5087428b4be73d62faeaf5ce516e (diff) | |
download | meta-openembedded-fded4cf6a8cf1ff065af97f3283b55aeba458d28.tar.gz |
opencv: fix packaging and install
The OpenCV*.cmake files and the static library should be in the opencv-dev
package, not opencv-apps.
There is no need to specify files for PN-dbg as they're automatically found, so
remove the FILES_PN-dbg assignment.
Conditionalise the installation of the example and tutorial binaries so it
doesn't abort if samples are disabled.
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv_3.1.bb | 11 |
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_3.1.bb b/meta-oe/recipes-support/opencv/opencv_3.1.bb index da1131616..2136b0747 100644 --- a/meta-oe/recipes-support/opencv/opencv_3.1.bb +++ b/meta-oe/recipes-support/opencv/opencv_3.1.bb | |||
@@ -116,15 +116,14 @@ PACKAGES_DYNAMIC += "^libopencv-.*" | |||
116 | 116 | ||
117 | FILES_${PN} = "" | 117 | FILES_${PN} = "" |
118 | FILES_${PN}-apps = "${bindir}/* ${datadir}/OpenCV" | 118 | FILES_${PN}-apps = "${bindir}/* ${datadir}/OpenCV" |
119 | FILES_${PN}-dbg += "${libdir}/.debug" | 119 | FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig ${datadir}/OpenCV/*.cmake ${datadir}/OpenCV/3rdparty/lib/*.a" |
120 | FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig" | ||
121 | FILES_${PN}-doc = "${datadir}/OpenCV/doc" | 120 | FILES_${PN}-doc = "${datadir}/OpenCV/doc" |
122 | FILES_${PN}-java = "${datadir}/OpenCV/java" | 121 | FILES_${PN}-java = "${datadir}/OpenCV/java" |
123 | FILES_${PN}-java-dbg = "${datadir}/OpenCV/java/.debug/" | 122 | FILES_${PN}-java-dbg = "${datadir}/OpenCV/java/.debug/" |
124 | FILES_${PN}-samples = "${datadir}/OpenCV/samples/" | 123 | FILES_${PN}-samples = "${datadir}/OpenCV/samples/" |
125 | FILES_${PN}-samples-dbg = "${datadir}/OpenCV/samples/bin/.debug" | 124 | FILES_${PN}-samples-dbg = "${datadir}/OpenCV/samples/bin/.debug" |
126 | 125 | ||
127 | INSANE_SKIP_${PN}-apps = "staticdev" | 126 | INSANE_SKIP_${PN}-dev = "staticdev" |
128 | INSANE_SKIP_${PN}-java = "libdir" | 127 | INSANE_SKIP_${PN}-java = "libdir" |
129 | INSANE_SKIP_${PN}-java-dbg = "libdir" | 128 | INSANE_SKIP_${PN}-java-dbg = "libdir" |
130 | 129 | ||
@@ -144,6 +143,8 @@ do_install_append() { | |||
144 | rm -rf ${D}/usr/lib | 143 | rm -rf ${D}/usr/lib |
145 | fi | 144 | fi |
146 | 145 | ||
147 | install -d ${D}${datadir}/OpenCV/samples/bin/ | 146 | if ${@bb.utils.contains("PACKAGECONFIG", "samples", "true", "false", d)}; then |
148 | cp -f bin/*-tutorial-* bin/*-example-* ${D}${datadir}/OpenCV/samples/bin/ | 147 | install -d ${D}${datadir}/OpenCV/samples/bin/ |
148 | cp -f bin/*-tutorial-* bin/*-example-* ${D}${datadir}/OpenCV/samples/bin/ | ||
149 | fi | ||
149 | } | 150 | } |