diff options
author | Felipe F. Tonello <eu@felipetonello.com> | 2013-09-19 19:09:13 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-10-05 12:36:02 +0200 |
commit | f480becafec5315192f6671601f973e41bf2d4ae (patch) | |
tree | f53c64295540ce3eb10322843a9ce66d9cf87878 | |
parent | 653c667a56a2134a883fadc64fccb8a7a6b8bd8e (diff) | |
download | meta-openembedded-f480becafec5315192f6671601f973e41bf2d4ae.tar.gz |
gypsy: Improvements in recipes
Some improvements were made:
* Fix recipes to use .inc file
* Fix git recipe that was not passing do_configure step
* Separeted gypsy daemon from libgypsy in different packages
Signed-off-by: Felipe F. Tonello <eu@felipetonello.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-navigation/gypsy/gypsy.inc | 16 | ||||
-rw-r--r-- | meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb | 21 | ||||
-rw-r--r-- | meta-oe/recipes-navigation/gypsy/gypsy_git.bb | 12 |
3 files changed, 26 insertions, 23 deletions
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy.inc b/meta-oe/recipes-navigation/gypsy/gypsy.inc index ba543568d..747b61d23 100644 --- a/meta-oe/recipes-navigation/gypsy/gypsy.inc +++ b/meta-oe/recipes-navigation/gypsy/gypsy.inc | |||
@@ -5,11 +5,21 @@ concurrently. Gypsy also hides the details of parsing NMEA from the \ | |||
5 | client applications, passing the data as simple values for the clients \ | 5 | client applications, passing the data as simple values for the clients \ |
6 | to use." | 6 | to use." |
7 | LICENSE = "GPLv2.0 & LGPLv2.1" | 7 | LICENSE = "GPLv2.0 & LGPLv2.1" |
8 | SECTION = "x11" | 8 | SECTION = "console/network" |
9 | DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt-native" | 9 | DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt-native libxslt" |
10 | 10 | ||
11 | inherit autotools pkgconfig gtk-doc | 11 | inherit autotools pkgconfig gtk-doc |
12 | PACKAGES += "libgypsy" | ||
12 | 13 | ||
13 | EXTRA_OECONF += "--with-distro=debian" | 14 | EXTRA_OECONF += "--with-distro=debian" |
14 | 15 | ||
15 | FILES_${PN} += "/usr/share/dbus-1/services/" | 16 | FILES_${PN} = " \ |
17 | ${sysconfdir}/gypsy.conf \ | ||
18 | ${sysconfdir}/dbus-1 \ | ||
19 | ${libexecdir}/gypsy-daemon \ | ||
20 | ${datadir}/dbus-1 \ | ||
21 | " | ||
22 | |||
23 | FILES_libgypsy = " \ | ||
24 | ${libdir}/libgypsy${SOLIBS} \ | ||
25 | " | ||
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb b/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb index 564d3d96f..24c8987ef 100644 --- a/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb +++ b/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb | |||
@@ -1,26 +1,15 @@ | |||
1 | SUMMARY = "GPS Multiplexing Daemon" | 1 | require gypsy.inc |
2 | DESCRIPTION = "Gypsy is a GPS multiplexing daemon which allows \ | 2 | |
3 | multiple clients to access GPS data from multiple GPS sources \ | 3 | PR = "r2" |
4 | concurrently. Gypsy also hides the details of parsing NMEA from the \ | 4 | |
5 | client applications, passing the data as simple values for the clients \ | ||
6 | to use." | ||
7 | LICENSE = "GPLv2+ & LGPLv2+" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ |
9 | file://COPYING.lib;md5=7fbc338309ac38fefcd64b04bb903e34 \ | 6 | file://COPYING.lib;md5=7fbc338309ac38fefcd64b04bb903e34 \ |
10 | file://src/main.c;beginline=1;endline=25;md5=3fe64e27e61b289b77383a54a982cbdd \ | 7 | file://src/main.c;beginline=1;endline=25;md5=3fe64e27e61b289b77383a54a982cbdd \ |
11 | file://gypsy/gypsy-time.h;beginline=1;endline=24;md5=06432ea19a7b6607428d04d9dadc37fd" | 8 | file://gypsy/gypsy-time.h;beginline=1;endline=24;md5=06432ea19a7b6607428d04d9dadc37fd" |
12 | 9 | ||
13 | SECTION = "x11" | 10 | SRC_URI += "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz \ |
14 | DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt" | ||
15 | |||
16 | SRC_URI = "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz \ | ||
17 | file://0001-g_type_init-is-deprecated-for-glib-2.35.0.patch \ | 11 | file://0001-g_type_init-is-deprecated-for-glib-2.35.0.patch \ |
18 | " | 12 | " |
19 | PR = "r1" | ||
20 | |||
21 | inherit autotools pkgconfig | ||
22 | |||
23 | FILES_${PN} += "/usr/share/dbus-1/system-services/" | ||
24 | 13 | ||
25 | SRC_URI[md5sum] = "e2d186df9c2cc3b70a027043e22acf1a" | 14 | SRC_URI[md5sum] = "e2d186df9c2cc3b70a027043e22acf1a" |
26 | SRC_URI[sha256sum] = "14e1cbe17351f408538e033ca370b4bf51ccf9c88744e236ddfb271904f154d6" | 15 | SRC_URI[sha256sum] = "14e1cbe17351f408538e033ca370b4bf51ccf9c88744e236ddfb271904f154d6" |
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy_git.bb b/meta-oe/recipes-navigation/gypsy/gypsy_git.bb index 5431c682b..6ab16e6be 100644 --- a/meta-oe/recipes-navigation/gypsy/gypsy_git.bb +++ b/meta-oe/recipes-navigation/gypsy/gypsy_git.bb | |||
@@ -4,15 +4,19 @@ DEFAULT_PREFERENCE = "-1" | |||
4 | 4 | ||
5 | SRCREV = "be8c9c382d2d1d37b51d29b0843045121ec90213" | 5 | SRCREV = "be8c9c382d2d1d37b51d29b0843045121ec90213" |
6 | PV = "0.9+git${SRCPV}" | 6 | PV = "0.9+git${SRCPV}" |
7 | PR = "r1" | 7 | PR = "r2" |
8 | 8 | ||
9 | S = "${WORKDIR}/git" | 9 | S = "${WORKDIR}/git" |
10 | 10 | ||
11 | LICENSE = "GPLv2+ & LGPLv2+" | ||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ |
13 | file://COPYING.lib;md5=7fbc338309ac38fefcd64b04bb903e34 \ | 12 | file://COPYING.lib;md5=7fbc338309ac38fefcd64b04bb903e34 \ |
14 | file://src/main.c;beginline=1;endline=25;md5=3fe64e27e61b289b77383a54a982cbdd \ | 13 | file://src/main.c;beginline=1;endline=25;md5=3fe64e27e61b289b77383a54a982cbdd \ |
15 | file://gypsy/gypsy-time.h;beginline=1;endline=24;md5=06432ea19a7b6607428d04d9dadc37fd" | 14 | file://gypsy/gypsy-time.h;beginline=1;endline=24;md5=06432ea19a7b6607428d04d9dadc37fd" |
16 | 15 | ||
17 | SRC_URI = "git://anongit.freedesktop.org/gypsy \ | 16 | SRC_URI += "git://anongit.freedesktop.org/gypsy \ |
18 | file://fixups.patch" | 17 | file://fixups.patch" |
18 | |||
19 | do_configure_prepend() { | ||
20 | # from patch 563716fc596d53f1085949a9dd11a62f39b2d624 | ||
21 | test -d ${S}/m4 || mkdir -p ${S}/m4 | ||
22 | } | ||