summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2019-12-10 23:23:34 +0000
committerKhem Raj <raj.khem@gmail.com>2019-12-11 16:22:40 -0800
commitf0a641554d4f17e90d03a83bdd63687c07714414 (patch)
tree0dac752758960b5a405e5f7c65a1d4a2e85dc609
parentc3a3470b1ba3768e04e0a938870ad487bd848120 (diff)
downloadmeta-openembedded-f0a641554d4f17e90d03a83bdd63687c07714414.tar.gz
ostree: Upgrade 2019.5 -> 2019.6
Drop all patches as they now exist upstream. Add tar to the dependencies for ptest as this is required when running with libarchive enabled (and the busybox version doesn't suffice). Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0001-Avoid-race-condition-when-building-outside-of-source.patch33
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch60
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0001-build-create-tests-directory-for-split-builds.patch43
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0001-macros-Add-TEMP_FAILURE_RETRY-for-musl.patch40
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0001-tests-Handle-EPIPE-failures-when-head-terminates.patch51
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0001-tests-core-Fallback-to-en_US.UTF-8-locale.patch42
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0001-tests-repo-finder-Run-realpath-on-tmp.patch44
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0002-tests-core-Assume-C.UTF-8-if-locale-isn-t-found.patch40
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0003-tests-Avoid-musl-failure-with-cp-a.patch52
-rw-r--r--meta-oe/recipes-extended/ostree/ostree_2019.6.bb (renamed from meta-oe/recipes-extended/ostree/ostree_2019.5.bb)12
10 files changed, 2 insertions, 415 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-Avoid-race-condition-when-building-outside-of-source.patch b/meta-oe/recipes-extended/ostree/ostree/0001-Avoid-race-condition-when-building-outside-of-source.patch
deleted file mode 100644
index c926965de..000000000
--- a/meta-oe/recipes-extended/ostree/ostree/0001-Avoid-race-condition-when-building-outside-of-source.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 77b27c07df2bdff86945766a4728b6012062535c Mon Sep 17 00:00:00 2001
2From: Stefan Agner <stefan@agner.ch>
3Date: Tue, 26 Nov 2019 09:20:30 +0100
4Subject: [PATCH] Avoid race condition when building outside of source tree
5
6When building outside of source tree it can happen that src/ostree/
7does not exist (yet) when bison is called. This leads to an build
8error like so:
9 bison: src/ostree/parse-datetime.c: cannot open: No such file or directory
10
11Make sure that src/ostree/ exists when parse-datetime.c is built.
12
13Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
14Upstream-Status: Backport
15---
16 Makefile-ostree.am | 1 +
17 1 file changed, 1 insertion(+)
18
19diff --git a/Makefile-ostree.am b/Makefile-ostree.am
20index 76f39cad4b74..f861afe42168 100644
21--- a/Makefile-ostree.am
22+++ b/Makefile-ostree.am
23@@ -123,6 +123,7 @@ ostree_SOURCES += src/ostree/ot-remote-builtin-add-cookie.c \
24 endif
25
26 src/ostree/parse-datetime.c: src/ostree/parse-datetime.y Makefile
27+ mkdir -p src/ostree/
28 $(AM_V_GEN) $(YACC) $< -o $@
29
30 EXTRA_DIST += src/ostree/parse-datetime.y
31--
322.17.1
33
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch b/meta-oe/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch
deleted file mode 100644
index 4b1c02a62..000000000
--- a/meta-oe/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch
+++ /dev/null
@@ -1,60 +0,0 @@
1From de8e0765a4a54f0367999f682ce4cc53bfaa60b0 Mon Sep 17 00:00:00 2001
2From: Ricardo Salveti <ricardo@foundries.io>
3Date: Tue, 5 Nov 2019 21:16:07 -0300
4Subject: [PATCH] Makefile: declare ostree_boot_SCRIPTS and append values
5
6ostree_boot_SCRIPTS was being set on both Makefile-boot.am and
7Makefile-switchroot.am, causing the first one to be replaced by the
8other at the final Makefile, so declare as empty and append on both
9places instead.
10
11Signed-off-by: Ricardo Salveti <ricardo@foundries.io>
12Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
13Upstream-Status: Backport
14---
15 Makefile-boot.am | 2 +-
16 Makefile-decls.am | 1 +
17 Makefile-switchroot.am | 2 +-
18 3 files changed, 3 insertions(+), 2 deletions(-)
19
20diff --git a/Makefile-boot.am b/Makefile-boot.am
21index b4d4a1af670e..b51928f08d7c 100644
22--- a/Makefile-boot.am
23+++ b/Makefile-boot.am
24@@ -60,7 +60,7 @@ grub2configdir = $(sysconfdir)/grub.d
25 INSTALL_DATA_HOOKS += install-grub2-config-hook
26 else
27 # We're using our internal generator
28-ostree_boot_SCRIPTS = src/boot/grub2/ostree-grub-generator
29+ostree_boot_SCRIPTS += src/boot/grub2/ostree-grub-generator
30 endif
31
32 EXTRA_DIST += src/boot/dracut/module-setup.sh \
33diff --git a/Makefile-decls.am b/Makefile-decls.am
34index 115c19fb663f..086ee1384a0b 100644
35--- a/Makefile-decls.am
36+++ b/Makefile-decls.am
37@@ -47,6 +47,7 @@ typelibdir = $(libdir)/girepository-1.0
38 typelib_DATA =
39 gsettings_SCHEMAS =
40 ostree_bootdir = $(prefix)/lib/ostree
41+ostree_boot_SCRIPTS =
42 ostree_boot_PROGRAMS =
43
44 # This initializes some more variables
45diff --git a/Makefile-switchroot.am b/Makefile-switchroot.am
46index ff44d4bc3981..b81b843febbc 100644
47--- a/Makefile-switchroot.am
48+++ b/Makefile-switchroot.am
49@@ -42,7 +42,7 @@ if BUILDOPT_USE_STATIC_COMPILER
50 # to get autotools to install this as an executable but without generating rules
51 # to make it itself which we have specified manually. See
52 # https://lists.gnu.org/archive/html/help-gnu-utils/2007-01/msg00007.html
53-ostree_boot_SCRIPTS = ostree-prepare-root
54+ostree_boot_SCRIPTS += ostree-prepare-root
55
56 ostree-prepare-root : $(ostree_prepare_root_SOURCES)
57 $(STATIC_COMPILER) -o $@ -static $(top_srcdir)/src/switchroot/ostree-prepare-root.c $(ostree_prepare_root_CPPFLAGS) $(AM_CFLAGS) $(DEFAULT_INCLUDES) -DOSTREE_PREPARE_ROOT_STATIC=1
58--
592.17.1
60
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-build-create-tests-directory-for-split-builds.patch b/meta-oe/recipes-extended/ostree/ostree/0001-build-create-tests-directory-for-split-builds.patch
deleted file mode 100644
index d94b3ded9..000000000
--- a/meta-oe/recipes-extended/ostree/ostree/0001-build-create-tests-directory-for-split-builds.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 114fe5067b58a2434b44855eee48f865186fe0fa Mon Sep 17 00:00:00 2001
2From: Alex Kiernan <alex.kiernan@gmail.com>
3Date: Tue, 5 Nov 2019 22:26:23 +0000
4Subject: [PATCH] build: create tests directory for split builds
5
6When `--disable-dependency-tracking` is in effect with separate build
7directory, the tests directory isn't created as a result of the
8dependency generation, which leads to a build race for the tests
9directory being created and failures:
10
11 Making all in .
12 make[2]: Entering directory 'TOPDIR/build/tmp/work/riscv64-yoe-linux-musl/ostree/2019.5-r0/build'
13 (echo '[Test]' > tests/test-local-pull-depth.sh.test.tmp; \
14 echo 'Type=session' >> tests/test-local-pull-depth.sh.test.tmp; \
15 echo 'Exec=env G_TEST_SRCDIR=/usr/libexec/installed-tests/libostree G_TEST_BUILDDIR=/usr/libexec/installed-tests/libostree /usr/libexec/installed-tests/libostree/test-local-pull-depth.sh' >> tests/test-local-pull-depth.sh.test.tmp; \
16 mv tests/test-local-pull-depth.sh.test.tmp tests/test-local-pull-depth.sh.test)
17 /bin/sh: tests/test-local-pull-depth.sh.test.tmp: No such file or directory
18 /bin/sh: line 1: tests/test-local-pull-depth.sh.test.tmp: No such file or directory
19 /bin/sh: line 2: tests/test-local-pull-depth.sh.test.tmp: No such file or directory
20 mv: cannot stat 'tests/test-local-pull-depth.sh.test.tmp': No such file or directory
21 make[2]: *** [Makefile:9282: tests/test-local-pull-depth.sh.test] Error 1
22
23Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
24Upstream-Status: Pending
25---
26 buildutil/glib-tap.mk | 1 +
27 1 file changed, 1 insertion(+)
28
29diff --git a/buildutil/glib-tap.mk b/buildutil/glib-tap.mk
30index 34b8f21ea26a..9a944a0acc88 100644
31--- a/buildutil/glib-tap.mk
32+++ b/buildutil/glib-tap.mk
33@@ -116,6 +116,7 @@ installed_testcases = $(test_programs) $(installed_test_programs) \
34 installed_test_meta_DATA = $(installed_testcases:=.test)
35
36 %.test: %$(EXEEXT) Makefile
37+ @$(MKDIR_P) $(dir $@)
38 $(AM_V_GEN) (echo '[Test]' > $@.tmp; \
39 echo 'Type=session' >> $@.tmp; \
40 echo 'Exec=env G_TEST_SRCDIR=$(installed_testdir) G_TEST_BUILDDIR=$(installed_testdir) $(installed_testdir)/$(notdir $<)' >> $@.tmp; \
41--
422.17.1
43
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-macros-Add-TEMP_FAILURE_RETRY-for-musl.patch b/meta-oe/recipes-extended/ostree/ostree/0001-macros-Add-TEMP_FAILURE_RETRY-for-musl.patch
deleted file mode 100644
index d8c044cb9..000000000
--- a/meta-oe/recipes-extended/ostree/ostree/0001-macros-Add-TEMP_FAILURE_RETRY-for-musl.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 5a4f2ddb0a6c656b425a3caa41f5af766ed5f44b Mon Sep 17 00:00:00 2001
2From: Alex Kiernan <alex.kiernan@gmail.com>
3Date: Mon, 9 Sep 2019 14:19:18 +0100
4Subject: [PATCH] macros: Add TEMP_FAILURE_RETRY for musl
5
6TEMP_FAILURE_RETRY is glibc specific, add a definition for musl.
7
8See https://github.com/ostreedev/ostree/issues/731
9
10Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
11Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
12Upstream-Status: Accepted [https://gitlab.gnome.org/GNOME/libglnx/commit/15c06468804014fc49f6f340132930703f919b19]
13---
14 glnx-macros.h | 10 ++++++++++
15 1 file changed, 10 insertions(+)
16
17diff --git a/libglnx.glnx-macros.h b/libglnx/glnx-macros.h
18index 6d8aca93f8a3..700fc75ceed0 100644
19--- a/libglnx.glnx-macros.h
20+++ b/libglnx/glnx-macros.h
21@@ -31,6 +31,16 @@ G_BEGIN_DECLS
22 /* All of these are for C only. */
23 #ifndef __GI_SCANNER__
24
25+/* fixes builds against musl, taken from glibc unistd.h */
26+#ifndef TEMP_FAILURE_RETRY
27+#define TEMP_FAILURE_RETRY(expression) \
28+ (__extension__ \
29+ ({ long int __result; \
30+ do __result = (long int) (expression); \
31+ while (__result == -1L && errno == EINTR); \
32+ __result; }))
33+#endif
34+
35 /* Taken from https://github.com/systemd/systemd/src/basic/string-util.h
36 * at revision v228-666-gcf6c8c4
37 */
38--
392.17.1
40
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-tests-Handle-EPIPE-failures-when-head-terminates.patch b/meta-oe/recipes-extended/ostree/ostree/0001-tests-Handle-EPIPE-failures-when-head-terminates.patch
deleted file mode 100644
index fdb733ebe..000000000
--- a/meta-oe/recipes-extended/ostree/ostree/0001-tests-Handle-EPIPE-failures-when-head-terminates.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1From fb519f0361565cad0d340095263a1e8866ec4f89 Mon Sep 17 00:00:00 2001
2From: Alex Kiernan <alex.kiernan@gmail.com>
3Date: Thu, 31 Oct 2019 11:30:00 +0000
4Subject: [PATCH 1/3] tests: Handle EPIPE failures when head terminates
5
6When using musl, it appears that the default is line buffered output, so
7when `head -1` reads from a pipe we have to handle the source end of the
8pipe getting EPIPE.
9
10Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
11Upstream-Status: Accepted [v2019.6]
12---
13 tests/pull-test.sh | 2 +-
14 tests/test-pull-mirrorlist.sh | 4 ++--
15 2 files changed, 3 insertions(+), 3 deletions(-)
16
17diff --git a/tests/pull-test.sh b/tests/pull-test.sh
18index 0a97a1195582..2cfd8e02f790 100644
19--- a/tests/pull-test.sh
20+++ b/tests/pull-test.sh
21@@ -177,7 +177,7 @@ if ! skip_one_without_user_xattrs; then
22 ${CMD_PREFIX} ostree --repo=cacherepo pull-local ostree-srv/gnomerepo main
23 rev=$(ostree --repo=cacherepo rev-parse main)
24 ${CMD_PREFIX} ostree --repo=cacherepo ls -R -C main > ls.txt
25- regfile_hash=$(grep -E -e '^-0' ls.txt | head -1 | awk '{ print $5 }')
26+ regfile_hash=$((grep -E -e '^-0' ls.txt || true) | head -1 | awk '{ print $5 }')
27 ${CMD_PREFIX} ostree --repo=repo remote add --set=gpg-verify=false corruptrepo $(cat httpd-address)/ostree/corruptrepo
28 # Make this a loop so in the future we can add more object types like commit etc.
29 for object in ${regfile_hash}.file; do
30diff --git a/tests/test-pull-mirrorlist.sh b/tests/test-pull-mirrorlist.sh
31index 4e44852d3971..85ff66e99f8e 100755
32--- a/tests/test-pull-mirrorlist.sh
33+++ b/tests/test-pull-mirrorlist.sh
34@@ -47,12 +47,12 @@ setup_mirror content_mirror3
35
36 # Let's delete a file from 1 so that it falls back on 2
37 cd ${test_tmpdir}/content_mirror1/ostree/gnomerepo
38-filez=$(find objects/ -name '*.filez' | head -n 1)
39+filez=$((find objects/ -name '*.filez' || true) | head -n 1)
40 rm ${filez}
41
42 # Let's delete a file from 1 and 2 so that it falls back on 3
43 cd ${test_tmpdir}/content_mirror1/ostree/gnomerepo
44-filez=$(find objects/ -name '*.filez' | head -n 1)
45+filez=$((find objects/ -name '*.filez' || true) | head -n 1)
46 rm ${filez}
47 cd ${test_tmpdir}/content_mirror2/ostree/gnomerepo
48 rm ${filez}
49--
502.17.1
51
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-tests-core-Fallback-to-en_US.UTF-8-locale.patch b/meta-oe/recipes-extended/ostree/ostree/0001-tests-core-Fallback-to-en_US.UTF-8-locale.patch
deleted file mode 100644
index dcafb0995..000000000
--- a/meta-oe/recipes-extended/ostree/ostree/0001-tests-core-Fallback-to-en_US.UTF-8-locale.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From 4d17cd917fe4fb67d2f9e4881b6693ac7289f423 Mon Sep 17 00:00:00 2001
2From: Alex Kiernan <alex.kiernan@gmail.com>
3Date: Wed, 30 Oct 2019 07:55:41 +0000
4Subject: [PATCH 1/4] tests/core: Fallback to en_US.UTF-8 locale
5
6A number of tests expect explicit left/right single quotes in their
7messages, which will never happen in the C locale. Change so we pick a
8likely UTF-8 locale, or fail if we can't find one.
9
10Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
11Upstream-Status: Accepted [v2019.6]
12---
13 tests/libtest-core.sh | 12 ++++--------
14 1 file changed, 4 insertions(+), 8 deletions(-)
15
16diff --git a/tests/libtest-core.sh b/tests/libtest-core.sh
17index f6f94288fc61..bc191332c916 100644
18--- a/tests/libtest-core.sh
19+++ b/tests/libtest-core.sh
20@@ -35,15 +35,11 @@ assert_not_reached () {
21 }
22
23 # Some tests look for specific English strings. Use a UTF-8 version
24-# of the C (POSIX) locale if we have one, or fall back to POSIX
25+# of the C (POSIX) locale if we have one, or fall back to en_US.UTF-8
26 # (https://sourceware.org/glibc/wiki/Proposals/C.UTF-8)
27-if locale -a | grep '^C.UTF-8$' >/dev/null; then
28- export LC_ALL=C.UTF-8
29-elif locale -a | grep '^C.utf8$' >/dev/null; then
30- export LC_ALL=C.utf8
31-else
32- export LC_ALL=C
33-fi
34+export LC_ALL=$(locale -a | grep -Ee '\.(UTF-8|utf8)' | grep -iEe '^(C|en_US)' | head -1 || true)
35+if [ -z "${LC_ALL}" ]; then fatal "Can't find suitable UTF-8 locale"; fi
36+
37 # A GNU extension, used whenever LC_ALL is not C
38 unset LANGUAGE
39
40--
412.17.1
42
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-tests-repo-finder-Run-realpath-on-tmp.patch b/meta-oe/recipes-extended/ostree/ostree/0001-tests-repo-finder-Run-realpath-on-tmp.patch
deleted file mode 100644
index ba116a9ef..000000000
--- a/meta-oe/recipes-extended/ostree/ostree/0001-tests-repo-finder-Run-realpath-on-tmp.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1From 16bb294384bb4ae4ba83af51fbb64fdd14d02838 Mon Sep 17 00:00:00 2001
2From: Colin Walters <walters@verbum.org>
3Date: Thu, 21 Nov 2019 18:37:48 +0000
4Subject: [PATCH] tests/repo-finder: Run realpath() on /tmp
5
6This fixes running this test case inside
7https://github.com/cgwalters/coretoolbox
8
9Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
10Upstream-Status: Backport
11---
12 tests/test-repo-finder-mount.c | 9 +++++----
13 1 file changed, 5 insertions(+), 4 deletions(-)
14
15diff --git a/tests/test-repo-finder-mount.c b/tests/test-repo-finder-mount.c
16index 847f4becd1c6..af2f5e085f68 100644
17--- a/tests/test-repo-finder-mount.c
18+++ b/tests/test-repo-finder-mount.c
19@@ -62,7 +62,9 @@ setup (Fixture *fixture,
20 g_clear_error (&error);
21 g_assert_no_error (error);
22
23- fixture->working_dir = g_file_new_for_path (fixture->tmpdir.path);
24+ /* Realpath since at least coretoolbox makes /tmp a symlink to /host/tmp */
25+ g_autofree char *tmpdir_real_path = realpath (fixture->tmpdir.path, NULL);
26+ fixture->working_dir = g_file_new_for_path (tmpdir_real_path);
27
28 fixture->parent_repo = ot_test_setup_repo (NULL, &error);
29 g_assert_no_error (error);
30@@ -443,9 +445,8 @@ test_repo_finder_mount_mixed_mounts (Fixture *fixture,
31 }
32 else
33 {
34- g_test_message ("Unknown result ‘%s’ with keyring ‘%s’.",
35- result->remote->name, result->remote->keyring);
36- g_assert_not_reached ();
37+ g_error ("Unknown result ‘%s’ with keyring ‘%s’",
38+ result->remote->name, result->remote->keyring);
39 }
40 }
41
42--
432.17.1
44
diff --git a/meta-oe/recipes-extended/ostree/ostree/0002-tests-core-Assume-C.UTF-8-if-locale-isn-t-found.patch b/meta-oe/recipes-extended/ostree/ostree/0002-tests-core-Assume-C.UTF-8-if-locale-isn-t-found.patch
deleted file mode 100644
index 5ab9c8f6d..000000000
--- a/meta-oe/recipes-extended/ostree/ostree/0002-tests-core-Assume-C.UTF-8-if-locale-isn-t-found.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 3d48021fb0892721fab8359b49470e521aaed493 Mon Sep 17 00:00:00 2001
2From: Alex Kiernan <alex.kiernan@gmail.com>
3Date: Thu, 31 Oct 2019 11:28:07 +0000
4Subject: [PATCH 2/3] tests/core: Assume C.UTF-8 if locale isn't found
5
6When building with musl there's no locale command, also its default
7locale is C.UTF-8, so just get C.UTF-8 if we can't find locale.
8
9Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
10Upstream-Status: Accepted [v2019.6]
11---
12 tests/libtest-core.sh | 12 +++++++++---
13 1 file changed, 9 insertions(+), 3 deletions(-)
14
15diff --git a/tests/libtest-core.sh b/tests/libtest-core.sh
16index bc191332c916..46aafab03cc8 100644
17--- a/tests/libtest-core.sh
18+++ b/tests/libtest-core.sh
19@@ -37,9 +37,15 @@ assert_not_reached () {
20 # Some tests look for specific English strings. Use a UTF-8 version
21 # of the C (POSIX) locale if we have one, or fall back to en_US.UTF-8
22 # (https://sourceware.org/glibc/wiki/Proposals/C.UTF-8)
23-export LC_ALL=$(locale -a | grep -Ee '\.(UTF-8|utf8)' | grep -iEe '^(C|en_US)' | head -1 || true)
24-if [ -z "${LC_ALL}" ]; then fatal "Can't find suitable UTF-8 locale"; fi
25-
26+#
27+# If we can't find the locale command assume we have support for C.UTF-8
28+# (e.g. musl based systems)
29+if type -p locale >/dev/null; then
30+ export LC_ALL=$(locale -a | grep -Ee '\.(UTF-8|utf8)' | grep -iEe '^(C|en_US)' | head -1 || true)
31+ if [ -z "${LC_ALL}" ]; then fatal "Can't find suitable UTF-8 locale"; fi
32+else
33+ export LC_ALL=C.UTF-8
34+fi
35 # A GNU extension, used whenever LC_ALL is not C
36 unset LANGUAGE
37
38--
392.17.1
40
diff --git a/meta-oe/recipes-extended/ostree/ostree/0003-tests-Avoid-musl-failure-with-cp-a.patch b/meta-oe/recipes-extended/ostree/ostree/0003-tests-Avoid-musl-failure-with-cp-a.patch
deleted file mode 100644
index 834617c12..000000000
--- a/meta-oe/recipes-extended/ostree/ostree/0003-tests-Avoid-musl-failure-with-cp-a.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1From abf1a7392b2fa1945286a39a35190d74fe141e52 Mon Sep 17 00:00:00 2001
2From: Alex Kiernan <alex.kiernan@gmail.com>
3Date: Thu, 31 Oct 2019 17:09:36 +0000
4Subject: [PATCH 3/3] tests: Avoid musl failure with `cp -a`
5
6When copying the tree, using musl and GNU coreutils, something gets confused
7when setting the ownership of symlinks and the copy fails with:
8
9 cp: failed to preserve ownership for osdata-devel/bin: Not supported
10
11Rework using tar to avoid the problem.
12
13Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
14Upstream-Status: Accepted [v2019.6]
15---
16 tests/libtest.sh | 4 +++-
17 tests/test-admin-gpg.sh | 4 +++-
18 2 files changed, 6 insertions(+), 2 deletions(-)
19
20diff --git a/tests/libtest.sh b/tests/libtest.sh
21index ba00073a10a7..3f5fd931bc1e 100755
22--- a/tests/libtest.sh
23+++ b/tests/libtest.sh
24@@ -440,7 +440,9 @@ EOF
25 ${CMD_PREFIX} ostree --repo=${test_tmpdir}/testos-repo commit --add-metadata-string version=1.0.10 -b testos/buildmaster/x86_64-runtime -s "Build"
26
27 cd ${test_tmpdir}
28- cp -a osdata osdata-devel
29+ rm -rf osdata-devel
30+ mkdir osdata-devel
31+ tar -C osdata -cf - . | tar -C osdata-devel -xf -
32 cd osdata-devel
33 mkdir -p usr/include
34 echo "a development header" > usr/include/foo.h
35diff --git a/tests/test-admin-gpg.sh b/tests/test-admin-gpg.sh
36index 1f50c8a9a508..dc776743776c 100755
37--- a/tests/test-admin-gpg.sh
38+++ b/tests/test-admin-gpg.sh
39@@ -90,7 +90,9 @@ EOF
40 ${CMD_PREFIX} ostree --repo=${test_tmpdir}/testos-repo commit --add-metadata-string version=1.0.10 -b testos/buildmaster/x86_64-runtime -s "Build" --gpg-sign=$keyid --gpg-homedir=${test_tmpdir}/gpghome
41
42 cd ${test_tmpdir}
43- cp -a osdata osdata-devel
44+ rm -rf osdata-devel
45+ mkdir osdata-devel
46+ tar -C osdata -cf - . | tar -C osdata-devel -xf -
47 cd osdata-devel
48 mkdir -p usr/include
49 echo "a development header" > usr/include/foo.h
50--
512.17.1
52
diff --git a/meta-oe/recipes-extended/ostree/ostree_2019.5.bb b/meta-oe/recipes-extended/ostree/ostree_2019.6.bb
index 4f437f348..86a7aac31 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2019.5.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2019.6.bb
@@ -24,18 +24,9 @@ PREMIRRORS = ""
24 24
25SRC_URI = " \ 25SRC_URI = " \
26 gitsm://github.com/ostreedev/ostree \ 26 gitsm://github.com/ostreedev/ostree \
27 file://0001-macros-Add-TEMP_FAILURE_RETRY-for-musl.patch \
28 file://run-ptest \ 27 file://run-ptest \
29 file://0001-tests-core-Fallback-to-en_US.UTF-8-locale.patch \
30 file://0001-tests-Handle-EPIPE-failures-when-head-terminates.patch \
31 file://0002-tests-core-Assume-C.UTF-8-if-locale-isn-t-found.patch \
32 file://0003-tests-Avoid-musl-failure-with-cp-a.patch \
33 file://0001-build-create-tests-directory-for-split-builds.patch \
34 file://0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch \
35 file://0001-Avoid-race-condition-when-building-outside-of-source.patch \
36 file://0001-tests-repo-finder-Run-realpath-on-tmp.patch \
37" 28"
38SRCREV = "980ca07b03b3aa7e0012729dd6c84b0878775d93" 29SRCREV = "43706202f7de2ce0c829a46caab350ae1656f6ad"
39 30
40UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+\.\d+)" 31UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+\.\d+)"
41 32
@@ -176,6 +167,7 @@ RDEPENDS_${PN}-ptest += " \
176 python3-core \ 167 python3-core \
177 python3-multiprocessing \ 168 python3-multiprocessing \
178 python3-pyyaml \ 169 python3-pyyaml \
170 tar \
179 ${PN}-trivial-httpd \ 171 ${PN}-trivial-httpd \
180" 172"
181RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils glibc-localedata-en-us" 173RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils glibc-localedata-en-us"