diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2018-03-26 18:44:52 -0700 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-04-08 17:00:06 -0700 |
commit | f054d90a9d6838b9f88c4afcf230e4fb6f75478d (patch) | |
tree | 3d695ea683ed632a9e3227c1fb78da008e40d576 | |
parent | 8c1655e099d69d777ce3f297cc664cb0f4c70aeb (diff) | |
download | meta-openembedded-f054d90a9d6838b9f88c4afcf230e4fb6f75478d.tar.gz |
libtest-harness-perl: upgrade v3.39 -> v3.42; inherit ptest-perl
* Remove tests which require "-T" (taint) command line option
* Remove tests which are inappropriate for on-target testing
* Install "prove" to /usr/local/bin to avoid conflict with perl-misc
Upstream release notes:
3.42 19-03-2018
- Enable rulesfile.t to run in core
3.41 27-02-2018
- Released 3.40_01 without code modifications
3.40_01 23-07-2017
- Return handle for pipes and sockets #58 (Erik Huelsmann)
- TAP v13 plan allows trailing whitespace (Steffen Schwigon)
- prove: add a --statefile=<path> option to customize the .prove file
(Ævar Arnfjörð Bjarmason)
- Avoid non-deterministic source handling, make a SourceHandler tie an
error. (Michael Schwern, Leon Timmermans)
- Fix and simplify MSWin32 colorization (Roy Ivy III)
- Fix file source handler to accept single extensions option (Tomoki Aonuma)
- Spelling fixes (Brian Wightman)
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r-- | meta-perl/recipes-perl/libtest/libtest-harness-perl_3.42.bb (renamed from meta-perl/recipes-perl/libtest/libtest-harness-perl_3.39.bb) | 35 |
1 files changed, 32 insertions, 3 deletions
diff --git a/meta-perl/recipes-perl/libtest/libtest-harness-perl_3.39.bb b/meta-perl/recipes-perl/libtest/libtest-harness-perl_3.42.bb index 35054c758..c9ba59480 100644 --- a/meta-perl/recipes-perl/libtest/libtest-harness-perl_3.39.bb +++ b/meta-perl/recipes-perl/libtest/libtest-harness-perl_3.42.bb | |||
@@ -26,14 +26,14 @@ LICENSE = "Artistic-1.0 | GPL-1.0+" | |||
26 | LIC_FILES_CHKSUM = "file://README;beginline=29;endline=30;md5=b08db4360eec119e875dddd7cb8a5ddd" | 26 | LIC_FILES_CHKSUM = "file://README;beginline=29;endline=30;md5=b08db4360eec119e875dddd7cb8a5ddd" |
27 | 27 | ||
28 | SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Test-Harness-${PV}.tar.gz" | 28 | SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Test-Harness-${PV}.tar.gz" |
29 | SRC_URI[md5sum] = "7877298e3b717734095ecb8e918b043e" | 29 | SRC_URI[md5sum] = "c794906473f88d6b74194e2d56f16bd6" |
30 | SRC_URI[sha256sum] = "69bd44c81c6e1d2db18e298ecf631852608893ddfddb332a7d55285bbfc51132" | 30 | SRC_URI[sha256sum] = "0fd90d4efea82d6e262e6933759e85d27cbcfa4091b14bf4042ae20bab528e53" |
31 | 31 | ||
32 | UPSTREAM_CHECK_REGEX = "Test\-Harness\-(?P<pver>(\d+\.\d+))(?!_\d+).tar" | 32 | UPSTREAM_CHECK_REGEX = "Test\-Harness\-(?P<pver>(\d+\.\d+))(?!_\d+).tar" |
33 | 33 | ||
34 | S = "${WORKDIR}/Test-Harness-${PV}" | 34 | S = "${WORKDIR}/Test-Harness-${PV}" |
35 | 35 | ||
36 | inherit cpan | 36 | inherit cpan ptest-perl |
37 | 37 | ||
38 | RDEPENDS_${PN} += "\ | 38 | RDEPENDS_${PN} += "\ |
39 | perl-module-benchmark \ | 39 | perl-module-benchmark \ |
@@ -88,4 +88,33 @@ RPROVIDES_${PN} += "libapp-prove-perl \ | |||
88 | libtap-parser-yamlish-writer-perl \ | 88 | libtap-parser-yamlish-writer-perl \ |
89 | " | 89 | " |
90 | 90 | ||
91 | do_install_prepend() { | ||
92 | # these tests are inappropriate on target | ||
93 | rm -rf ${B}/t/000-load.t | ||
94 | rm -rf ${B}/t/state.t | ||
95 | # these tests require "-T" (taint) option on command line | ||
96 | rm -rf ${B}/t/aggregator.t | ||
97 | rm -rf ${B}/t/bailout.t | ||
98 | rm -rf ${B}/t/base.t | ||
99 | rm -rf ${B}/t/callbacks.t | ||
100 | rm -rf ${B}/t/errors.t | ||
101 | rm -rf ${B}/t/nested.t | ||
102 | rm -rf ${B}/t/object.t | ||
103 | rm -rf ${B}/t/premature-bailout.t | ||
104 | rm -rf ${B}/t/results.t | ||
105 | rm -rf ${B}/t/streams.t | ||
106 | rm -rf ${B}/t/yamlish-output.t | ||
107 | rm -rf ${B}/t/compat/version.t | ||
108 | } | ||
109 | |||
110 | do_install_append() { | ||
111 | install -d ${D}/usr/local/bin | ||
112 | # do not clobber perl-misc /usr/bin/prove | ||
113 | install -m 0755 ${B}/bin/prove ${D}/usr/local/bin/ | ||
114 | rm -rf ${D}${bindir}/prove | ||
115 | rm -rf ${D}${bindir} | ||
116 | } | ||
117 | |||
118 | FILES_${PN} += "/usr/local/bin/prove" | ||
119 | |||
91 | BBCLASSEXTEND = "native" | 120 | BBCLASSEXTEND = "native" |