diff options
author | Carlos Rodriguez <carlos.rodriguez@ridgerun.com> | 2018-04-30 15:33:08 -0600 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-05-17 08:18:19 -0700 |
commit | e3ba2f061ea4f9320cffcbd634ff0c7da391d94e (patch) | |
tree | c1705716bed0ab78c1cf82318e4a5989f57a987a | |
parent | f51ba94d3a09500dba2fa607dd3f6b08de5d43fe (diff) | |
download | meta-openembedded-e3ba2f061ea4f9320cffcbd634ff0c7da391d94e.tar.gz |
gst-shark: Add Gst-Shark recipe
GstShark is an open-source project from RidgeRun that provides
benchmarks and profiling tools for GStreamer 1.7.1 (and above).
It includes tracers for generating debug information plus some
tools to analyze the debug information. GstShark provides easy
to use and useful tracers, paired with analysis tools to enable
straightforward optimizations.
Signed-off-by: rrcarlosrodriguez <carlos.rodriguez@ridgerun.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r-- | meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_0.2.1.bb | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_0.2.1.bb b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_0.2.1.bb new file mode 100644 index 000000000..5409f3204 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_0.2.1.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | SUMMARY = "Gst-Shark Tracers" | ||
2 | DESCRIPTION = "Benchmarks and profiling tools for GStreamer" | ||
3 | HOMEPAGE = "https://developer.ridgerun.com/wiki/index.php?title=GstShark" | ||
4 | SECTION = "multimedia" | ||
5 | LICENSE = "GPLv2+" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=e1caa368743492879002ad032445fa97" | ||
8 | |||
9 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad " | ||
10 | |||
11 | SRCBRANCH ?= "master" | ||
12 | |||
13 | SRCREV_base = "a60b3996fe3376d42334fc89014e9d6f6af62899" | ||
14 | SRCREV_common = "b64f03f6090245624608beb5d2fff335e23a01c0" | ||
15 | |||
16 | SRC_URI = " \ | ||
17 | git://github.com/RidgeRun/gst-shark.git;protocol=https;branch=${SRCBRANCH};name=base \ | ||
18 | git://anongit.freedesktop.org/git/gstreamer/common.git;protocol=https;destsuffix=git/common;name=common; \ | ||
19 | " | ||
20 | |||
21 | S = "${WORKDIR}/git" | ||
22 | |||
23 | PACKAGECONFIG_CONFARGS = " \ | ||
24 | --disable-graphviz \ | ||
25 | --enable-gtk-doc=no \ | ||
26 | " | ||
27 | |||
28 | FILES_${PN} += "\ | ||
29 | ${libdir}/gstreamer-1.0/libgstsharktracers.so \ | ||
30 | ${libdir}/gstreamer-1.0/libgstsharktracers.la \ | ||
31 | " | ||
32 | |||
33 | inherit autotools gettext | ||
34 | |||
35 | do_configure() { | ||
36 | ${S}/autogen.sh --noconfigure | ||
37 | oe_runconf | ||
38 | } | ||