diff options
author | Pierre-Jean Texier <pjtexier@koncepto.io> | 2020-02-24 21:03:56 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-02-25 17:57:15 -0800 |
commit | da1f9f63612ae67991bc0339958aacbe664f6981 (patch) | |
tree | 8647ae860637ac72e971ebc15b3af4a9bad5601d | |
parent | 7cd1a972723e3ebcf27d85fc07de9e051e71707e (diff) | |
download | meta-openembedded-da1f9f63612ae67991bc0339958aacbe664f6981.tar.gz |
inotify-tools: upgrade 3.20.1 -> 3.20.2.2
Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
3 files changed, 50 insertions, 35 deletions
diff --git a/meta-oe/recipes-support/inotify-tools/inotify-tools/0001-Makefile.am-add-build-rule-for-README.patch b/meta-oe/recipes-support/inotify-tools/inotify-tools/0001-Makefile.am-add-build-rule-for-README.patch new file mode 100644 index 000000000..2c7cd9970 --- /dev/null +++ b/meta-oe/recipes-support/inotify-tools/inotify-tools/0001-Makefile.am-add-build-rule-for-README.patch | |||
@@ -0,0 +1,46 @@ | |||
1 | From 22bff509e2a0e5640994bc92ded62c383d99bc37 Mon Sep 17 00:00:00 2001 | ||
2 | From: Pierre-Jean Texier <pjtexier@koncepto.io> | ||
3 | Date: Mon, 24 Feb 2020 21:44:45 +0100 | ||
4 | Subject: [PATCH] Makefile.am: add build rule for README | ||
5 | |||
6 | Fixes: | ||
7 | |||
8 | | configure.ac:17: installing 'config/config.sub' | ||
9 | | configure.ac:16: installing 'config/install-sh' | ||
10 | | configure.ac:16: installing 'config/missing' | ||
11 | | Makefile.am: error: required file './README' not found | ||
12 | | libinotifytools/src/Makefile.am: installing 'config/depcomp' | ||
13 | |||
14 | Upstream-Status: Submitted [https://github.com/inotify-tools/inotify-tools/pull/111] | ||
15 | |||
16 | Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io> | ||
17 | --- | ||
18 | Makefile.am | 2 ++ | ||
19 | autogen.sh | 1 - | ||
20 | 2 files changed, 2 insertions(+), 1 deletion(-) | ||
21 | |||
22 | diff --git a/Makefile.am b/Makefile.am | ||
23 | index 56e4531..d08c8fe 100644 | ||
24 | --- a/Makefile.am | ||
25 | +++ b/Makefile.am | ||
26 | @@ -2,6 +2,8 @@ ACLOCAL_AMFLAGS = -I m4 | ||
27 | |||
28 | SUBDIRS = libinotifytools src man | ||
29 | |||
30 | +README: README.md | ||
31 | + | ||
32 | dist-hook: | ||
33 | # Automake official documentation states that dist-hook should assume files | ||
34 | # are not writable. | ||
35 | diff --git a/autogen.sh b/autogen.sh | ||
36 | index 48eb21d..31572c2 100755 | ||
37 | --- a/autogen.sh | ||
38 | +++ b/autogen.sh | ||
39 | @@ -1,4 +1,3 @@ | ||
40 | #!/bin/sh | ||
41 | |||
42 | -cp README.md README | ||
43 | autoreconf --install "$@" || exit 1 | ||
44 | -- | ||
45 | 2.7.4 | ||
46 | |||
diff --git a/meta-oe/recipes-support/inotify-tools/inotify-tools/inotify-nosys-fix-system-call-number.patch b/meta-oe/recipes-support/inotify-tools/inotify-tools/inotify-nosys-fix-system-call-number.patch deleted file mode 100644 index 89b890dda..000000000 --- a/meta-oe/recipes-support/inotify-tools/inotify-tools/inotify-nosys-fix-system-call-number.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | inotify-tools: fix __NR_inotify_add_watch system call number on _MIPS_SIM_ABI64 | ||
2 | |||
3 | The correct value should be the same as defined in | ||
4 | linux/arch/mips/include/uapi/asm/unistd.h | ||
5 | |||
6 | Upstream-Status: Summitted [https://github.com/rvoicilas/inotify-tools/pull/71] | ||
7 | |||
8 | Signed-off-by: Roy Li <rongqing.li@windriver.com> | ||
9 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> | ||
10 | --- | ||
11 | libinotifytools/src/inotifytools/inotify-nosys.h | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/libinotifytools/src/inotifytools/inotify-nosys.h b/libinotifytools/src/inotifytools/inotify-nosys.h | ||
15 | index db76b2c..5f7b11b 100644 | ||
16 | --- a/libinotifytools/src/inotifytools/inotify-nosys.h | ||
17 | +++ b/libinotifytools/src/inotifytools/inotify-nosys.h | ||
18 | @@ -100,8 +100,8 @@ struct inotify_event { | ||
19 | # endif | ||
20 | # if _MIPS_SIM == _MIPS_SIM_ABI64 | ||
21 | # define __NR_inotify_init (__NR_Linux + 243) | ||
22 | -# define __NR_inotify_add_watch (__NR_Linux + 243) | ||
23 | -# define __NR_inotify_rm_watch (__NR_Linux + 243) | ||
24 | +# define __NR_inotify_add_watch (__NR_Linux + 244) | ||
25 | +# define __NR_inotify_rm_watch (__NR_Linux + 245) | ||
26 | # endif | ||
27 | # if _MIPS_SIM == _MIPS_SIM_NABI32 | ||
28 | # define __NR_inotify_init (__NR_Linux + 247) | ||
29 | -- | ||
30 | 1.7.10.4 | ||
31 | |||
diff --git a/meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb b/meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb index 05ca4b4ad..f42abeb2b 100644 --- a/meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb +++ b/meta-oe/recipes-support/inotify-tools/inotify-tools_git.bb | |||
@@ -5,12 +5,12 @@ SECTION = "console/devel" | |||
5 | LICENSE = "GPL-2.0" | 5 | LICENSE = "GPL-2.0" |
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=ac6c26e52aea428ee7f56dc2c56424c6" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=ac6c26e52aea428ee7f56dc2c56424c6" |
7 | 7 | ||
8 | SRCREV = "e203934e46784bb34c213078423ba1678e0c4936" | 8 | SRCREV = "cfa93aa19f81d85b63cd64da30c7499890d4c07d" |
9 | PV = "3.20.1" | 9 | PV = "3.20.2.2" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/rvoicilas/${BPN} \ | 11 | SRC_URI = "git://github.com/rvoicilas/${BPN} \ |
12 | file://inotify-nosys-fix-system-call-number.patch \ | 12 | file://0001-Makefile.am-add-build-rule-for-README.patch \ |
13 | " | 13 | " |
14 | 14 | ||
15 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
16 | 16 | ||