summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-06-27 15:25:52 -0700
committerKhem Raj <raj.khem@gmail.com>2018-06-27 22:17:33 -0700
commitd56219b4119901c223fd7929d3208c44e951c9d2 (patch)
treede05c0a017586d010978d9e721c64ecde2e669a3
parent00d5219d6515982ecdbe2f3c5d9eff852ef02589 (diff)
downloadmeta-openembedded-d56219b4119901c223fd7929d3208c44e951c9d2.tar.gz
mosquitto: minor recipe cleanups
- Passing prefix, mandir and localedir via the Make command line allows patching of config.mk to be dropped. - The variable PREFIX isn't used anywhere in the mosquitto 1.4.15 Makefiles, so doesn't need to be passed on the Make command line. That means the default do_compile() from base.bbclass can be used and the recipe specific do_compile() can be dropped. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/files/0001-config.mk-allow-prefix-mandir-localedir-from-environ.patch35
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/mosquitto_1.4.15.bb24
2 files changed, 13 insertions, 46 deletions
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/0001-config.mk-allow-prefix-mandir-localedir-from-environ.patch b/meta-networking/recipes-connectivity/mosquitto/files/0001-config.mk-allow-prefix-mandir-localedir-from-environ.patch
deleted file mode 100644
index a5aa277a0..000000000
--- a/meta-networking/recipes-connectivity/mosquitto/files/0001-config.mk-allow-prefix-mandir-localedir-from-environ.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 0be38301249d797ec1f59071cc868ceda6d4720a Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andr=C3=A9=20Draszik?= <andre.draszik@jci.com>
3Date: Tue, 12 Apr 2016 12:50:32 +0100
4Subject: [PATCH 1/2] config.mk: allow prefix / mandir / localedir from
5 environment
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10We want to control them using OE environment variables.
11
12Upstream-Status: Inappropriate [embedded-specific]
13Signed-off-by: André Draszik <andre.draszik@jci.com>
14---
15 config.mk | 6 +++---
16 1 file changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/config.mk b/config.mk
19index 71f17e5..81d9702 100644
20--- a/config.mk
21+++ b/config.mk
22@@ -249,7 +249,7 @@ ifeq ($(WITH_DOCS),yes)
23 endif
24
25 INSTALL?=install
26-prefix=/usr/local
27-mandir=${prefix}/share/man
28-localedir=${prefix}/share/locale
29+prefix?=/usr/local
30+mandir?=${prefix}/share/man
31+localedir?=${prefix}/share/locale
32 STRIP?=strip
33--
342.15.1
35
diff --git a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.4.15.bb b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.4.15.bb
index 8dd2124c4..f451687a6 100644
--- a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.4.15.bb
+++ b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.4.15.bb
@@ -11,7 +11,6 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=62ddc846179e908dc0c8efec4a42ef20 \
11DEPENDS = "uthash" 11DEPENDS = "uthash"
12 12
13SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \ 13SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \
14 file://0001-config.mk-allow-prefix-mandir-localedir-from-environ.patch \
15 file://0002-uthash-remove-in-tree-version.patch \ 14 file://0002-uthash-remove-in-tree-version.patch \
16 file://mosquitto.service \ 15 file://mosquitto.service \
17 file://mosquitto.init \ 16 file://mosquitto.init \
@@ -27,20 +26,23 @@ PACKAGECONFIG ??= "ssl uuid"
27PACKAGECONFIG[dns-srv] = ",,c-ares" 26PACKAGECONFIG[dns-srv] = ",,c-ares"
28PACKAGECONFIG[ssl] = ",,openssl" 27PACKAGECONFIG[ssl] = ",,openssl"
29PACKAGECONFIG[uuid] = ",,util-linux" 28PACKAGECONFIG[uuid] = ",,util-linux"
30EXTRA_OEMAKE = "${@bb.utils.contains('PACKAGECONFIG', 'dns-srv', 'WITH_SRV=yes', 'WITH_SRV=no', d)} \
31 STRIP=/bin/true \
32 WITH_DOCS=no \
33 ${@bb.utils.contains('PACKAGECONFIG', 'ssl', 'WITH_TLS=yes WITH_TLS_PSK=yes', 'WITH_TLS=no WITH_TLS_PSK=no', d)} \
34 ${@bb.utils.contains('PACKAGECONFIG', 'uuid', 'WITH_UUID=yes', 'WITH_UUID=no', d)}"
35 29
36export LIB_SUFFIX="${@d.getVar('baselib', True).replace('lib', '')}" 30EXTRA_OEMAKE = " \
31 prefix=${prefix} \
32 mandir=${mandir} \
33 localedir=${localedir} \
34 ${@bb.utils.contains('PACKAGECONFIG', 'dns-srv', 'WITH_SRV=yes', 'WITH_SRV=no', d)} \
35 ${@bb.utils.contains('PACKAGECONFIG', 'ssl', 'WITH_TLS=yes WITH_TLS_PSK=yes', 'WITH_TLS=no WITH_TLS_PSK=no', d)} \
36 ${@bb.utils.contains('PACKAGECONFIG', 'uuid', 'WITH_UUID=yes', 'WITH_UUID=no', d)} \
37 STRIP=/bin/true \
38 WITH_DOCS=no \
39"
37 40
38do_compile() { 41export LIB_SUFFIX = "${@d.getVar('baselib', True).replace('lib', '')}"
39 oe_runmake PREFIX=${prefix}
40}
41 42
42do_install() { 43do_install() {
43 oe_runmake install DESTDIR=${D} 44 oe_runmake 'DESTDIR=${D}' install
45
44 install -d ${D}${libdir} 46 install -d ${D}${libdir}
45 install -m 0644 lib/libmosquitto.a ${D}${libdir}/ 47 install -m 0644 lib/libmosquitto.a ${D}${libdir}/
46 48