diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2024-02-08 14:30:38 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-09 09:52:15 -0800 |
commit | d43386035a9c9126ef7c8de6264499caa00c2234 (patch) | |
tree | 19c4c1c0e2dddc5c612f9e0f77cc2f2da93bdfef | |
parent | 5a45aa504a37a45fa28daeb26b56c046f0419ade (diff) | |
download | meta-openembedded-d43386035a9c9126ef7c8de6264499caa00c2234.tar.gz |
nana: upgrade to latest commit from github
* nana 2.5 release is from 2005 and since then the development was
moved from savannah to github, see:
https://savannah.gnu.org/projects/nana
https://savannah.gnu.org/news/?id=8130
* the latest commit on https://github.com/pjmaker/nana
was also 10 years ago now, so don't expect nana-3.0 release any
time soon, but the commits after the 2.5 help with some autotools
issues, so it's worth taking them
* 0001-Include-stdlib.h-for-exit-and-abort-prototypes.patch was resolved in:
https://github.com/pjmaker/nana/commit/bed0de4e64250ad6aea810f8e5521e23b26e655b#diff-44df4b12f1a47b20b5e0e107fad4f7692a17a2861337fb6e984db755feb912b6
* sent as RFC, because I've only build tested this,
but only nana-src has fewer files (possibly due to B != S)
and nana.1 man page is still installed as before (hopefully without random
build failures now)
buildhistory-diff -p buildhistory 1b5542b7fe608fc952c94bea65103883be1b9f32 master
packages/core2-64-oe-linux/nana/nana-dbg: PKGV changed from 2.5 [default] to 2.5+git0+6d70617db8
packages/core2-64-oe-linux/nana/nana-dbg: PKGR changed from r0.0 to r0.11
packages/core2-64-oe-linux/nana/nana-dev: PKGV changed from 2.5 [default] to 2.5+git0+6d70617db8
packages/core2-64-oe-linux/nana/nana-dev: PKGR changed from r0.0 to r0.11
packages/core2-64-oe-linux/nana/nana-doc: PKGV changed from 2.5 [default] to 2.5+git0+6d70617db8
packages/core2-64-oe-linux/nana/nana-doc: PKGR changed from r0.0 to r0.11
packages/core2-64-oe-linux/nana/nana-locale: PKGV changed from 2.5 [default] to 2.5+git0+6d70617db8
packages/core2-64-oe-linux/nana/nana-locale: PKGR changed from r0.0 to r0.11
packages/core2-64-oe-linux/nana/nana-src: FILELIST: removed all items "/usr/src/debug/nana/2.5/src/L_buffer.h /usr/src/debug/nana/2.5/src/nana_error.h /usr/src/debug/nana/2.5/src/calls.h /usr/src/debug/nana/2.5/src/L_times.h"
packages/core2-64-oe-linux/nana/nana-src: PKGV changed from 2.5 [default] to 2.5+git0+6d70617db8
packages/core2-64-oe-linux/nana/nana-src: PKGR changed from r0.0 to r0.11
packages/core2-64-oe-linux/nana/nana-src: PKGSIZE changed from 9569 to 0 (-100%)
packages/core2-64-oe-linux/nana/nana-staticdev: PKGV changed from 2.5 [default] to 2.5+git0+6d70617db8
packages/core2-64-oe-linux/nana/nana-staticdev: PKGR changed from r0.0 to r0.11
packages/core2-64-oe-linux/nana/nana: PKGV changed from 2.5 [default] to 2.5+git0+6d70617db8
packages/core2-64-oe-linux/nana/nana: PKGR changed from r0.0 to r0.11
Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
7 files changed, 127 insertions, 264 deletions
diff --git a/meta-oe/recipes-extended/nana/nana/0001-Include-stdlib.h-for-exit-and-abort-prototypes.patch b/meta-oe/recipes-extended/nana/nana/0001-Include-stdlib.h-for-exit-and-abort-prototypes.patch deleted file mode 100644 index f1712b17f..000000000 --- a/meta-oe/recipes-extended/nana/nana/0001-Include-stdlib.h-for-exit-and-abort-prototypes.patch +++ /dev/null | |||
@@ -1,52 +0,0 @@ | |||
1 | From 0e32b1a07b1b032576c7b0a73d7f1a090a50dd23 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 31 Aug 2022 10:40:52 -0700 | ||
4 | Subject: [PATCH] Include stdlib.h for exit and abort prototypes | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | src/I.c | 1 + | ||
10 | src/nana_error.c | 1 + | ||
11 | src/nanafilter.c | 1 + | ||
12 | 3 files changed, 3 insertions(+) | ||
13 | |||
14 | diff --git a/src/I.c b/src/I.c | ||
15 | index e4577ae..4761af4 100644 | ||
16 | --- a/src/I.c | ||
17 | +++ b/src/I.c | ||
18 | @@ -30,6 +30,7 @@ | ||
19 | |||
20 | |||
21 | #include <stdio.h> | ||
22 | +#include <stdlib.h> | ||
23 | #include <I.h> | ||
24 | |||
25 | /* | ||
26 | diff --git a/src/nana_error.c b/src/nana_error.c | ||
27 | index 51f99f2..c3a67d2 100644 | ||
28 | --- a/src/nana_error.c | ||
29 | +++ b/src/nana_error.c | ||
30 | @@ -30,6 +30,7 @@ | ||
31 | |||
32 | #include <nana_error.h> | ||
33 | #include <stdio.h> | ||
34 | +#include <stdlib.h> | ||
35 | |||
36 | void nana_error(const char *message) { | ||
37 | fprintf(stderr, "nana_error: %s\n", message); | ||
38 | diff --git a/src/nanafilter.c b/src/nanafilter.c | ||
39 | index 191e8ef..1ab1978 100644 | ||
40 | --- a/src/nanafilter.c | ||
41 | +++ b/src/nanafilter.c | ||
42 | @@ -33,6 +33,7 @@ | ||
43 | static const char rcs[] ="Id: nanafilter.c,v 1.2 1998/06/10 06:58:55 pjm Exp "; | ||
44 | |||
45 | #include <stdio.h> | ||
46 | +#include <stdlib.h> | ||
47 | |||
48 | void do_input(void); | ||
49 | void do_string(void); | ||
50 | -- | ||
51 | 2.37.3 | ||
52 | |||
diff --git a/meta-oe/recipes-extended/nana/nana/0001-Makefile.am-fix-build-with-separate-build-dir.patch b/meta-oe/recipes-extended/nana/nana/0001-Makefile.am-fix-build-with-separate-build-dir.patch new file mode 100644 index 000000000..aee27e803 --- /dev/null +++ b/meta-oe/recipes-extended/nana/nana/0001-Makefile.am-fix-build-with-separate-build-dir.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 22485e13c6e32e63ff522cd367bf63ab0a8848b1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <martin.jansa@gmail.com> | ||
3 | Date: Wed, 7 Feb 2024 15:42:30 +0000 | ||
4 | Subject: [PATCH] Makefile.am: fix build with separate build dir | ||
5 | |||
6 | Signed-off-by: Martin Jansa <martin.jansa@gmail.com> | ||
7 | Upstream-Status: Pending | ||
8 | --- | ||
9 | Makefile.am | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/Makefile.am b/Makefile.am | ||
13 | index 54ceda6..9e9ffe4 100755 | ||
14 | --- a/Makefile.am | ||
15 | +++ b/Makefile.am | ||
16 | @@ -33,7 +33,7 @@ PROJECTS: doc/nana.info | ||
17 | # | ||
18 | |||
19 | showconfig: | ||
20 | - $(CPP) $(CPPFLAGS) -I$(top_srcdir)/src $(DEFS) $(top_srcdir)/showconfig.c | grep "==>" | ||
21 | + $(CPP) $(CPPFLAGS) -I$(top_builddir)/src -I$(top_srcdir)/src $(DEFS) $(top_srcdir)/showconfig.c | grep "==>" | ||
22 | |||
23 | # | ||
24 | # various targets for the maintainer to build patches, releases, etc. | ||
25 | -- | ||
26 | 2.43.0 | ||
27 | |||
diff --git a/meta-oe/recipes-extended/nana/nana/0002-man-Makefile.am-we-seem-not-to-need-the-work-around-.patch b/meta-oe/recipes-extended/nana/nana/0002-man-Makefile.am-we-seem-not-to-need-the-work-around-.patch new file mode 100644 index 000000000..31a0f045a --- /dev/null +++ b/meta-oe/recipes-extended/nana/nana/0002-man-Makefile.am-we-seem-not-to-need-the-work-around-.patch | |||
@@ -0,0 +1,56 @@ | |||
1 | From 5519de933d851789a672d47be3f53258d036aa18 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <martin.jansa@gmail.com> | ||
3 | Date: Thu, 8 Feb 2024 14:12:17 +0100 | ||
4 | Subject: [PATCH] man/Makefile.am: we seem not to need the work around anymore | ||
5 | |||
6 | * I'm trying to fix random build failure in world builds which sometimes | ||
7 | fail with: | ||
8 | |||
9 | Making install in man | ||
10 | make[1]: Entering directory 'nana/2.5/nana-2.5/man' | ||
11 | make[2]: Entering directory 'nana/2.5/nana-2.5/man' | ||
12 | make[2]: Nothing to be done for 'install-exec-am'. | ||
13 | TOPDIR/BUILD/hosttools/mkdir -p 'nana/2.5/image/usr/share/man/man1' | ||
14 | installing nana.1 as /usr/share/man/man1/nana.1 | ||
15 | TOPDIR/BUILD/hosttools/mkdir -p 'nana/2.5/image/usr/share/man/man3' | ||
16 | TOPDIR/BUILD/hosttools/install -c -m 644 I.3 DI.3 L.3 DL.3 Q.3 Qstl.3 nana.3 'nana/2.5/image/usr/share/man/man3' | ||
17 | TOPDIR/BUILD/hosttools/install -c -m 644 nana.1 nana-clg.1 'nana/2.5/image/usr/share/man/man1' | ||
18 | TOPDIR/BUILD/hosttools/install: cannot create regular file 'nana/2.5/image/usr/share/man/man1/nana.1': File exists | ||
19 | make[2]: *** [Makefile:314: install-man1] Error 1 | ||
20 | make[2]: *** Waiting for unfinished jobs.... | ||
21 | make[2]: Leaving directory 'nana/2.5/nana-2.5/man' | ||
22 | make[1]: Leaving directory 'nana/2.5/nana-2.5/man' | ||
23 | make[1]: *** [Makefile:450: install-am] Error 2 | ||
24 | make: *** [Makefile:380: install-recursive] Error 1 | ||
25 | |||
26 | I guess it's related to install-data-local work around in: | ||
27 | https://github.com/pjmaker/nana/blob/master/man/Makefile.am#L15 | ||
28 | |||
29 | which might not be needed on some make versions and then it ends | ||
30 | installing nana.1 multiple times | ||
31 | |||
32 | Signed-off-by: Martin Jansa <martin.jansa@gmail.com> | ||
33 | Upstream-Status: Pending | ||
34 | --- | ||
35 | man/Makefile.am | 11 ----------- | ||
36 | 1 file changed, 11 deletions(-) | ||
37 | |||
38 | diff --git a/man/Makefile.am b/man/Makefile.am | ||
39 | index 4cc5b28..3b2936d 100755 | ||
40 | --- a/man/Makefile.am | ||
41 | +++ b/man/Makefile.am | ||
42 | @@ -7,14 +7,3 @@ CLEANFILES = *~ | ||
43 | EXTRA_DIST = nana.1 nana-clg.1 I.3 DI.3 L.3 DL.3 Q.3 Qstl.3 nana.3 | ||
44 | |||
45 | man_MANS = nana.1 nana-clg.1 I.3 DI.3 L.3 DL.3 Q.3 Qstl.3 nana.3 | ||
46 | - | ||
47 | -# We seem to have a problem with automake, if I include nana.1 in the | ||
48 | -# man_MANS variable we don't install it. The following dodgey aims | ||
49 | -# to fix it. | ||
50 | - | ||
51 | -install-data-local: | ||
52 | - @sect=1; \ | ||
53 | - inst=`echo "nana" | sed '$(transform)'`.1; \ | ||
54 | - echo installing nana.1 as $(mandir)/man$$sect/$$inst; \ | ||
55 | - $(INSTALL_DATA) $(srcdir)/nana.1 $(mandir)/man$$sect/$$inst | ||
56 | - | ||
diff --git a/meta-oe/recipes-extended/nana/nana/change-mandir-to-DESTDIR.patch b/meta-oe/recipes-extended/nana/nana/change-mandir-to-DESTDIR.patch deleted file mode 100644 index 54098f721..000000000 --- a/meta-oe/recipes-extended/nana/nana/change-mandir-to-DESTDIR.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From 7b04c4873c0a4510bdaf9145bf01ca34b3549fdb Mon Sep 17 00:00:00 2001 | ||
2 | From: Li xin <lixin.fnst@cn.fujitsu.com> | ||
3 | Date: Thu, 4 Dec 2014 03:50:19 +0900 | ||
4 | Subject: [PATCH 1/2] change mandir to DESTDIR | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> | ||
9 | --- | ||
10 | man/Makefile.am | 2 +- | ||
11 | man/Makefile.in | 2 +- | ||
12 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/man/Makefile.am b/man/Makefile.am | ||
15 | index 80d24d8..944bc57 100644 | ||
16 | --- a/man/Makefile.am | ||
17 | +++ b/man/Makefile.am | ||
18 | @@ -16,5 +16,5 @@ install-data-local: | ||
19 | @sect=1; \ | ||
20 | inst=`echo "nana" | sed '$(transform)'`.1; \ | ||
21 | echo installing nana.1 as $(mandir)/man$$sect/$$inst; \ | ||
22 | - $(INSTALL_DATA) $(srcdir)/nana.1 $(mandir)/man$$sect/$$inst | ||
23 | + $(INSTALL_DATA) $(srcdir)/nana.1 $(DESTDIR)$(mandir)/man$$sect/$$inst | ||
24 | |||
25 | diff --git a/man/Makefile.in b/man/Makefile.in | ||
26 | index 6008b20..64bb84c 100644 | ||
27 | --- a/man/Makefile.in | ||
28 | +++ b/man/Makefile.in | ||
29 | @@ -274,7 +274,7 @@ install-data-local: | ||
30 | @sect=1; \ | ||
31 | inst=`echo "nana" | sed '$(transform)'`.1; \ | ||
32 | echo installing nana.1 as $(mandir)/man$$sect/$$inst; \ | ||
33 | - $(INSTALL_DATA) $(srcdir)/nana.1 $(mandir)/man$$sect/$$inst | ||
34 | + $(INSTALL_DATA) $(srcdir)/nana.1 $(DESTDIR)$(mandir)/man$$sect/$$inst | ||
35 | |||
36 | # Tell versions [3.59,3.63) of GNU make to not export all variables. | ||
37 | # Otherwise a system limit (for SysV at least) may be exceeded. | ||
38 | -- | ||
39 | 1.8.4.2 | ||
40 | |||
diff --git a/meta-oe/recipes-extended/nana/nana/modify-acinclude.m4-and-configure.in.patch b/meta-oe/recipes-extended/nana/nana/modify-acinclude.m4-and-configure.in.patch deleted file mode 100644 index 043fd8550..000000000 --- a/meta-oe/recipes-extended/nana/nana/modify-acinclude.m4-and-configure.in.patch +++ /dev/null | |||
@@ -1,137 +0,0 @@ | |||
1 | From 679e33bfe74d713240fdd930602b993b937dce39 Mon Sep 17 00:00:00 2001 | ||
2 | From: Li xin <lixin.fnst@cn.fujitsu.com> | ||
3 | Date: Fri, 23 Jan 2015 03:30:47 +0900 | ||
4 | Subject: [PATCH] modify acinclude.m4 and configure.in | ||
5 | |||
6 | this patch is from Debian to fix build errors. | ||
7 | "acinclude.m4:34: error: automatic de-ANSI-fication | ||
8 | support has been removed" | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | |||
12 | Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> | ||
13 | --- | ||
14 | acinclude.m4 | 79 ------------------------------------------------------------ | ||
15 | configure.in | 12 +++++++++ | ||
16 | 2 files changed, 12 insertions(+), 79 deletions(-) | ||
17 | |||
18 | diff --git a/acinclude.m4 b/acinclude.m4 | ||
19 | index e9e5500..d467fb5 100644 | ||
20 | --- a/acinclude.m4 | ||
21 | +++ b/acinclude.m4 | ||
22 | @@ -30,82 +30,3 @@ AC_SUBST($1) | ||
23 | ## ------------------------------- ## | ||
24 | ## Check for function prototypes. ## | ||
25 | ## ------------------------------- ## | ||
26 | - | ||
27 | -AC_DEFUN(fp_C_PROTOTYPES, | ||
28 | -[AC_REQUIRE([AM_PROG_CC_STDC]) | ||
29 | -AC_MSG_CHECKING([for function prototypes]) | ||
30 | -if test "$ac_cv_prog_cc_stdc" != no; then | ||
31 | - AC_MSG_RESULT(yes) | ||
32 | - AC_DEFINE(PROTOTYPES) | ||
33 | - U= ANSI2KNR= | ||
34 | -else | ||
35 | - AC_MSG_RESULT(no) | ||
36 | - U=_ ANSI2KNR=./ansi2knr | ||
37 | -fi | ||
38 | -AC_SUBST(U)dnl | ||
39 | -AC_SUBST(ANSI2KNR)dnl | ||
40 | -]) | ||
41 | - | ||
42 | -## ----------------------------------------- ## | ||
43 | -## ANSIfy the C compiler whenever possible. ## | ||
44 | -## ----------------------------------------- ## | ||
45 | - | ||
46 | -# @defmac AC_PROG_CC_STDC | ||
47 | -# @maindex PROG_CC_STDC | ||
48 | -# @ovindex CC | ||
49 | -# If the C compiler in not in ANSI C mode by default, try to add an option | ||
50 | -# to output variable @code{CC} to make it so. This macro tries various | ||
51 | -# options that select ANSI C on some system or another. It considers the | ||
52 | -# compiler to be in ANSI C mode if it defines @code{__STDC__} to 1 and | ||
53 | -# handles function prototypes correctly. | ||
54 | -# | ||
55 | -# If you use this macro, you should check after calling it whether the C | ||
56 | -# compiler has been set to accept ANSI C; if not, the shell variable | ||
57 | -# @code{ac_cv_prog_cc_stdc} is set to @samp{no}. If you wrote your source | ||
58 | -# code in ANSI C, you can make an un-ANSIfied copy of it by using the | ||
59 | -# program @code{ansi2knr}, which comes with Ghostscript. | ||
60 | -# @end defmac | ||
61 | - | ||
62 | -AC_DEFUN(fp_PROG_CC_STDC, | ||
63 | -[AC_MSG_CHECKING(for ${CC-cc} option to accept ANSI C) | ||
64 | -AC_CACHE_VAL(ac_cv_prog_cc_stdc, | ||
65 | -[ac_cv_prog_cc_stdc=no | ||
66 | -ac_save_CFLAGS="$CFLAGS" | ||
67 | -# Don't try gcc -ansi; that turns off useful extensions and | ||
68 | -# breaks some systems' header files. | ||
69 | -# AIX -qlanglvl=ansi | ||
70 | -# Ultrix and OSF/1 -std1 | ||
71 | -# HP-UX -Aa -D_HPUX_SOURCE | ||
72 | -# SVR4 -Xc | ||
73 | -for ac_arg in "" -qlanglvl=ansi -std1 "-Aa -D_HPUX_SOURCE" -Xc | ||
74 | -do | ||
75 | - CFLAGS="$ac_save_CFLAGS $ac_arg" | ||
76 | - AC_TRY_COMPILE( | ||
77 | -[#if !defined(__STDC__) || __STDC__ != 1 | ||
78 | -choke me | ||
79 | -#endif | ||
80 | -], [int test (int i, double x); | ||
81 | -struct s1 {int (*f) (int a);}; | ||
82 | -struct s2 {int (*f) (double a);};], | ||
83 | -[ac_cv_prog_cc_stdc="$ac_arg"; break]) | ||
84 | -done | ||
85 | -CFLAGS="$ac_save_CFLAGS" | ||
86 | -]) | ||
87 | -AC_MSG_RESULT($ac_cv_prog_cc_stdc) | ||
88 | -case "x$ac_cv_prog_cc_stdc" in | ||
89 | - x|xno) ;; | ||
90 | - *) CC="$CC $ac_cv_prog_cc_stdc" ;; | ||
91 | -esac | ||
92 | -]) | ||
93 | - | ||
94 | -## --------------------------------------------------------- ## | ||
95 | -## Use AC_PROG_INSTALL, supplementing it with INSTALL_SCRIPT ## | ||
96 | -## substitution. ## | ||
97 | -## --------------------------------------------------------- ## | ||
98 | - | ||
99 | -AC_DEFUN(fp_PROG_INSTALL, | ||
100 | -[AC_PROG_INSTALL | ||
101 | -test -z "$INSTALL_SCRIPT" && INSTALL_SCRIPT='${INSTALL} -m 755' | ||
102 | -AC_SUBST(INSTALL_SCRIPT)dnl | ||
103 | -]) | ||
104 | - | ||
105 | diff --git a/configure.in b/configure.in | ||
106 | index 6b25ed5..a6a7f5b 100644 | ||
107 | --- a/configure.in | ||
108 | +++ b/configure.in | ||
109 | @@ -103,6 +103,12 @@ nana_DEFINE(DI_MAKE_VALID_BREAKPOINT,(exprn), | ||
110 | sparc-*-*|i?86-*-*) | ||
111 | DI_MAKE_VALID_BREAKPOINT='asm("nop")' | ||
112 | ;; | ||
113 | + arm*-*-*|frv-*-*|mips*-*-*) | ||
114 | + DI_MAKE_VALID_BREAKPOINT='asm("nop")' | ||
115 | + ;; | ||
116 | + sh*-*-*) | ||
117 | + DI_MAKE_VALID_BREAKPOINT='asm("nop\n\tnop\n\t")' | ||
118 | + ;; | ||
119 | esac | ||
120 | ]) | ||
121 | |||
122 | @@ -113,6 +119,12 @@ nana_DEFINE(DL_MAKE_VALID_BREAKPOINT,(), | ||
123 | sparc-*-*|i?86-*-*) | ||
124 | DL_MAKE_VALID_BREAKPOINT='asm("nop")' | ||
125 | ;; | ||
126 | + arm*-*-*|frv-*-*|mips*-*-*) | ||
127 | + DL_MAKE_VALID_BREAKPOINT='asm("nop")' | ||
128 | + ;; | ||
129 | + sh*-*-*) | ||
130 | + DL_MAKE_VALID_BREAKPOINT='asm("nop\n\tnop\n\t")' | ||
131 | + ;; | ||
132 | esac | ||
133 | ]) | ||
134 | |||
135 | -- | ||
136 | 1.8.4.2 | ||
137 | |||
diff --git a/meta-oe/recipes-extended/nana/nana_2.5.bb b/meta-oe/recipes-extended/nana/nana_2.5.bb deleted file mode 100644 index c109d4f0f..000000000 --- a/meta-oe/recipes-extended/nana/nana_2.5.bb +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | SUMMARY = "Support for assertion checking and logging in GNU C/C++" | ||
2 | DESCRIPTION = "GNU Nana is a free library providing improved support for assertion\ | ||
3 | checking (as in assert.h) and logging (printf style debugging) in \ | ||
4 | GNU C and C++." | ||
5 | SECTION = "Development/Languages/C and C++" | ||
6 | |||
7 | SRC_URI = "http://download.savannah.gnu.org/releases/${BPN}/${BP}.tar.gz \ | ||
8 | file://change-mandir-to-DESTDIR.patch \ | ||
9 | file://modify-acinclude.m4-and-configure.in.patch \ | ||
10 | file://0001-Include-stdlib.h-for-exit-and-abort-prototypes.patch \ | ||
11 | " | ||
12 | SRC_URI[md5sum] = "66c88aa0ad095b2e67673773135475f1" | ||
13 | SRC_URI[sha256sum] = "fd1819ffea94b209513959447e4802afe2719600e7d161cd78b265a42812affa" | ||
14 | |||
15 | LICENSE = "BSD-2-Clause" | ||
16 | |||
17 | LIC_FILES_CHKSUM = "file://COPYING;md5=16aa57f3b7fdda870cee597275bd5d11" | ||
18 | |||
19 | inherit autotools-brokensep pkgconfig texinfo | ||
20 | |||
21 | EXTRA_OEMAKE = "DESTDIR=${D}" | ||
22 | |||
23 | do_configure:prepend:class-nativesdk() { | ||
24 | sed -i -e 's:@CPP@:\$\{CXX\} \$\{CXXFLAGS\} \-E:g' ${S}/src/nana.in | ||
25 | sed -i -e 's:@CC@:\$\{CC\} \$\{CFLAGS\} \-E:g' ${S}/src/nana-clg.in | ||
26 | sed -i -e 's:@CXX@::g' ${S}/src/nana-c++lg.in | ||
27 | sed -i -e 's:@GDB@:\$\{GDB\}:g' ${S}/src/nana-run.in | ||
28 | } | ||
29 | |||
30 | do_install:prepend() { | ||
31 | install -d ${D}${mandir}/man1 | ||
32 | install -d ${D}${mandir}/man3 | ||
33 | install -d ${D}${datadir}/info | ||
34 | } | ||
35 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-oe/recipes-extended/nana/nana_git.bb b/meta-oe/recipes-extended/nana/nana_git.bb new file mode 100644 index 000000000..7c748bc49 --- /dev/null +++ b/meta-oe/recipes-extended/nana/nana_git.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | SUMMARY = "Support for assertion checking and logging in GNU C/C++" | ||
2 | DESCRIPTION = "GNU Nana is a free library providing improved support for assertion\ | ||
3 | checking (as in assert.h) and logging (printf style debugging) in \ | ||
4 | GNU C and C++." | ||
5 | SECTION = "Development/Languages/C and C++" | ||
6 | |||
7 | PV = "2.5+git" | ||
8 | SRCREV = "6d70617db8b9972e6c1008265fc228aba91c2042" | ||
9 | SRC_URI = "git://github.com/pjmaker/nana;protocol=https;branch=master \ | ||
10 | file://0001-Makefile.am-fix-build-with-separate-build-dir.patch \ | ||
11 | file://0002-man-Makefile.am-we-seem-not-to-need-the-work-around-.patch \ | ||
12 | " | ||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | LICENSE = "BSD-2-Clause" | ||
16 | |||
17 | LIC_FILES_CHKSUM = "file://COPYING;md5=16aa57f3b7fdda870cee597275bd5d11" | ||
18 | |||
19 | inherit autotools pkgconfig texinfo | ||
20 | |||
21 | EXTRA_OEMAKE = "DESTDIR=${D}" | ||
22 | |||
23 | do_configure:prepend() { | ||
24 | # make distclean but in ${S} | ||
25 | rm -rf ${S}/src/*.o ${S}/src/.deps \ | ||
26 | ${S}/Makefile ${S}/config.log ${S}/config.status \ | ||
27 | ${S}/doc/Makefile ${S}/doc/nana.pdf \ | ||
28 | ${S}/emacs/Makefile ${S}/examples/Makefile \ | ||
29 | ${S}/gdb/Makefile ${S}/gdb/nana-libtrace ${S}/gdb/nana-trace \ | ||
30 | ${S}/man/Makefile ${S}/perf/Makefile \ | ||
31 | ${S}/shortform/Makefile ${S}/shortform/nana-sfdir ${S}/shortform/nana-sfg \ | ||
32 | ${S}/src/Makefile ${S}/src/libnana.a \ | ||
33 | ${S}/src/nana ${S}/src/nana-c++lg ${S}/src/nana-clg ${S}/src/nana-config.h ${S}/src/nana-run ${S}/src/nanafilter \ | ||
34 | ${S}/test/Makefile ${S}/test/gammon | ||
35 | } | ||
36 | |||
37 | do_configure:prepend:class-nativesdk() { | ||
38 | sed -i -e 's:@CPP@:\$\{CXX\} \$\{CXXFLAGS\} \-E:g' ${S}/src/nana.in | ||
39 | sed -i -e 's:@CC@:\$\{CC\} \$\{CFLAGS\} \-E:g' ${S}/src/nana-clg.in | ||
40 | sed -i -e 's:@CXX@::g' ${S}/src/nana-c++lg.in | ||
41 | sed -i -e 's:@GDB@:\$\{GDB\}:g' ${S}/src/nana-run.in | ||
42 | } | ||
43 | |||
44 | BBCLASSEXTEND = "native nativesdk" | ||