diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2016-05-10 21:39:12 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-19 12:02:39 +0200 |
commit | c9c82d313e6341231497f73fc66e189e7d2543bb (patch) | |
tree | 971437d609e7d57ec457121098387ba3de9fec20 | |
parent | beac69f84e8a45809555e0c5f9df7f1ab8f4a268 (diff) | |
download | meta-openembedded-c9c82d313e6341231497f73fc66e189e7d2543bb.tar.gz |
efivar: fix unknown option while gold linker used
- Use '-fPIC' to replace 'PIC';
- Use 'pie' to replace 'PIE'
- Remove unknown '--add-needed'
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-extended/efivar/efivar/0004-fix-unknow-option-for-gold-linker.patch | 38 | ||||
-rw-r--r-- | meta-oe/recipes-extended/efivar/efivar_0.23.bb | 1 |
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/efivar/efivar/0004-fix-unknow-option-for-gold-linker.patch b/meta-oe/recipes-extended/efivar/efivar/0004-fix-unknow-option-for-gold-linker.patch new file mode 100644 index 000000000..5d50c1906 --- /dev/null +++ b/meta-oe/recipes-extended/efivar/efivar/0004-fix-unknow-option-for-gold-linker.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From b3d35e7dd27a755df5acbe050837885914dbb28b Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Tue, 10 May 2016 11:34:50 -0400 | ||
4 | Subject: [PATCH] fix unknow option for gold linker | ||
5 | |||
6 | - Revert the following patch, since oe-core work with gcc 5 | ||
7 | ... | ||
8 | commit 3055a3797f16693dfdd855fa68bc57fd900dc408 | ||
9 | Author: Peter Jones <pjones@redhat.com> | ||
10 | Date: Mon Feb 15 14:15:40 2016 -0500 | ||
11 | |||
12 | Make gcc.specs work with gcc 6 / binutils 2.26 | ||
13 | |||
14 | Apparently binutils 2.26 gets real picky about "ld -PIC" vs "ld -fPIC". | ||
15 | |||
16 | Signed-off-by: Peter Jones <pjones@redhat.com> | ||
17 | ... | ||
18 | |||
19 | - Remove unknown option '--add-needed' | ||
20 | |||
21 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
22 | --- | ||
23 | gcc.specs | 2 +- | ||
24 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
25 | |||
26 | diff --git a/gcc.specs b/gcc.specs | ||
27 | index 24fabc2..5b0fdef 100644 | ||
28 | --- a/gcc.specs | ||
29 | +++ b/gcc.specs | ||
30 | @@ -14,4 +14,4 @@ | ||
31 | + %{!shared:%{!static:%{!r:-pie}}} %{static:-Wl,-no-fatal-warnings -Wl,-static -static -Wl,-z,relro,-z,now} | ||
32 | |||
33 | *link: | ||
34 | -+ %{!static:--fatal-warnings} --no-undefined-version --no-allow-shlib-undefined --add-needed -z now --build-id %{!static:%{!shared:-PIE}} %{shared:-z relro -PIC} %{static:%<pie} | ||
35 | ++ %{!static:--fatal-warnings} --no-undefined-version --no-allow-shlib-undefined -z now --build-id %{!static:%{!shared:-pie}} %{shared:-z relro -fPIC} %{static:%<pie} | ||
36 | -- | ||
37 | 2.8.1 | ||
38 | |||
diff --git a/meta-oe/recipes-extended/efivar/efivar_0.23.bb b/meta-oe/recipes-extended/efivar/efivar_0.23.bb index 9c474612a..6e9a51fc9 100644 --- a/meta-oe/recipes-extended/efivar/efivar_0.23.bb +++ b/meta-oe/recipes-extended/efivar/efivar_0.23.bb | |||
@@ -12,6 +12,7 @@ SRC_URI = "git://github.com/rhinstaller/efivar.git" | |||
12 | SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch \ | 12 | SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch \ |
13 | file://0002-disable-static-build.patch \ | 13 | file://0002-disable-static-build.patch \ |
14 | file://0003-efivar-fix-for-cross-compile.patch \ | 14 | file://0003-efivar-fix-for-cross-compile.patch \ |
15 | file://0004-fix-unknow-option-for-gold-linker.patch \ | ||
15 | " | 16 | " |
16 | 17 | ||
17 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |