diff options
author | Jose Quaresma <quaresma.jose@gmail.com> | 2024-09-27 11:08:22 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-11-19 13:13:24 -0800 |
commit | c72a62caaf1a71d03df19789a056bb66e4a2c753 (patch) | |
tree | 311e5b199d22c784483a8aa69aa84c847f12620f | |
parent | d96334544c8b0162c74598821c699a6774553d7c (diff) | |
download | meta-openembedded-c72a62caaf1a71d03df19789a056bb66e4a2c753.tar.gz |
gpsd: condition the runtime dependence of pyserial on the pygps
The python3-pyserial dependency was introduced in [1].
It is provided by the meta-python layer and so make it conditionally.
Fixes:
| NOTE: Resolving any missing task queue dependencies
| ERROR: Nothing RPROVIDES 'python3-pyserial' (but ../meta-openembedded/meta-oe/recipes-navigation/gpsd/gpsd_3.25.bb RDEPENDS on or otherwise requires it)
| NOTE: Runtime target 'python3-pyserial' is unbuildable, removing...
| Missing or unbuildable dependency chain was: ['python3-pyserial']
| NOTE: Runtime target 'gpsd' is unbuildable, removing...
| Missing or unbuildable dependency chain was: ['gpsd', 'python3-pyserial']
[1] https://git.openembedded.org/meta-openembedded/commit/?id=1266c912afa0abf118eaa5d152a0641c87665fbd
Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r-- | meta-oe/recipes-navigation/gpsd/gpsd_3.25.bb | 3 |
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.25.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.25.bb index f893ac359..e3b2f8bf6 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd_3.25.bb +++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.25.bb | |||
@@ -27,6 +27,7 @@ CLEANBROKEN = "1" | |||
27 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} usb" | 27 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} usb" |
28 | PACKAGECONFIG[bluez] = "bluez='true',bluez='false',bluez5" | 28 | PACKAGECONFIG[bluez] = "bluez='true',bluez='false',bluez5" |
29 | PACKAGECONFIG[qt] = "qt='yes' qt_versioned=5,qt='no',qtbase" | 29 | PACKAGECONFIG[qt] = "qt='yes' qt_versioned=5,qt='no',qtbase" |
30 | PACKAGECONFIG[pyserial] = "" | ||
30 | PACKAGECONFIG[usb] = "usb='true',usb='false',libusb1" | 31 | PACKAGECONFIG[usb] = "usb='true',usb='false',libusb1" |
31 | EXTRA_OESCONS = " \ | 32 | EXTRA_OESCONS = " \ |
32 | sysroot=${STAGING_DIR_TARGET} \ | 33 | sysroot=${STAGING_DIR_TARGET} \ |
@@ -147,7 +148,7 @@ FILES:python3-pygps = "${PYTHON_SITEPACKAGES_DIR}/* ${libdir}/gps/*.py ${libdir} | |||
147 | RDEPENDS:python3-pygps = " \ | 148 | RDEPENDS:python3-pygps = " \ |
148 | python3-core \ | 149 | python3-core \ |
149 | python3-io \ | 150 | python3-io \ |
150 | python3-pyserial \ | 151 | ${@bb.utils.contains('PACKAGECONFIG', 'pyserial', 'python3-pyserial', '', d)} \ |
151 | python3-threading \ | 152 | python3-threading \ |
152 | python3-terminal \ | 153 | python3-terminal \ |
153 | gpsd \ | 154 | gpsd \ |