summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-30 05:59:44 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:43:20 +0200
commitb8deb419369f5d59b77eb73ddea8dbf7b53eec47 (patch)
tree8e953d2aa53d39c31c3afbf93b6628a1298e698b
parent3278be3ac0d296df25928e057ed5d8d54a86ec50 (diff)
downloadmeta-openembedded-b8deb419369f5d59b77eb73ddea8dbf7b53eec47.tar.gz
freerdp: Fix build on mips
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp/0003-add-missing-define.patch45
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp_git.bb1
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/freerdp/freerdp/0003-add-missing-define.patch b/meta-oe/recipes-support/freerdp/freerdp/0003-add-missing-define.patch
new file mode 100644
index 000000000..220edef30
--- /dev/null
+++ b/meta-oe/recipes-support/freerdp/freerdp/0003-add-missing-define.patch
@@ -0,0 +1,45 @@
1libwinpr/comm_seria: fix missing define
2
3FreeRDP uses CMSPAR, which is defined by glibc in bits/termios.h .
4
5glibc has two flavours of bits/termios.h: a genmeric one and an
6architecture-specific one. When installing, glibc will install the
7architecture-specific file if it exists, otherwise it installs the
8generic file. Only Alpha, MIPS, PPC and Sparc have their own
9bits/termios.h.
10
11The generic bits/termios.h, as well as the Alpha, PPC and Sparc flavours
12do define CMSPAR. However, the MIPS flavour does not define it.
13
14Define CMSPAR to the value from the generic value, which is also the
15value known to the Linux kernel for MIPS.
16
17Fixes:
18 http://autobuild.buildroot.org/results/0b4/0b4793f0bf9f4c57933897f3480054a4e06528ad/
19 http://autobuild.buildroot.org/results/7a2/7a2284d0a2987158fa2e78f789b07c8c6fcdb974/
20 http://autobuild.buildroot.org/results/387/3874088c3ccd4bbf76ea0c911ca1ef64c7dc9d1c/
21 ...
22
23Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
24Cc: Peter Korsgaard <jacmet@uclibc.org>
25Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
26
27diff -durN freerdp-17834af7bb378f85a3b3cc4dcadaa5125a337e16.orig/winpr/libwinpr/comm/comm_serial_sys.c freerdp-17834af7bb378f85a3b3cc4dcadaa5125a337e16/winpr/libwinpr/comm/comm_serial_sys.c
28--- freerdp-17834af7bb378f85a3b3cc4dcadaa5125a337e16.orig/winpr/libwinpr/comm/comm_serial_sys.c 2015-09-04 16:20:17.000000000 +0100
29+++ freerdp-17834af7bb378f85a3b3cc4dcadaa5125a337e16/winpr/libwinpr/comm/comm_serial_sys.c 2015-10-04 11:07:41.868513726 +0100
30@@ -27,6 +27,14 @@
31 #include <fcntl.h>
32 #include <sys/ioctl.h>
33 #include <termios.h>
34+
35+/* glibc for MIPS has its own bits/termios.h which does not define
36+ * CMSPAR, so we vampirise the value from the generic bits/termios.h
37+ */
38+#ifndef CMSPAR
39+#define CMSPAR 010000000000
40+#endif
41+
42 #include <unistd.h>
43
44 #include "comm_serial_sys.h"
45
diff --git a/meta-oe/recipes-support/freerdp/freerdp_git.bb b/meta-oe/recipes-support/freerdp/freerdp_git.bb
index f2d0a4dad..f0aa1b6ef 100644
--- a/meta-oe/recipes-support/freerdp/freerdp_git.bb
+++ b/meta-oe/recipes-support/freerdp/freerdp_git.bb
@@ -17,6 +17,7 @@ SRCREV = "62da9d28c674814c81c245c1c7882eb0da7be76b"
17SRC_URI = "git://github.com/FreeRDP/FreeRDP.git \ 17SRC_URI = "git://github.com/FreeRDP/FreeRDP.git \
18 file://winpr-makecert-Build-with-install-RPATH.patch \ 18 file://winpr-makecert-Build-with-install-RPATH.patch \
19 file://0001-FindGStreamer_1_0-fix-build-failure-for-new-gstreame.patch \ 19 file://0001-FindGStreamer_1_0-fix-build-failure-for-new-gstreame.patch \
20 file://0003-add-missing-define.patch \
20" 21"
21 22
22S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"