summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2014-08-06 14:55:35 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-10 16:07:16 +0200
commitb762df7e6a700bde2087ab38f8b5d02b75ca5bdb (patch)
treeded507ace8d044c42103fda89f97c1eb46a7618a
parente5d70fb940b674d374c12303b55630df027ea8b5 (diff)
downloadmeta-openembedded-b762df7e6a700bde2087ab38f8b5d02b75ca5bdb.tar.gz
libwmf: use pkgconfig for freetype
And while we're at it list freetype in DEPENDS as well. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libwmf/libwmf/0001-configure-use-pkg-config-for-freetype.patch67
-rw-r--r--meta-oe/recipes-extended/libwmf/libwmf_0.2.8.4.bb11
2 files changed, 73 insertions, 5 deletions
diff --git a/meta-oe/recipes-extended/libwmf/libwmf/0001-configure-use-pkg-config-for-freetype.patch b/meta-oe/recipes-extended/libwmf/libwmf/0001-configure-use-pkg-config-for-freetype.patch
new file mode 100644
index 000000000..0f133e2e7
--- /dev/null
+++ b/meta-oe/recipes-extended/libwmf/libwmf/0001-configure-use-pkg-config-for-freetype.patch
@@ -0,0 +1,67 @@
1From 61655f82224cadb261e81f8bae111eaaa7bdf531 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 6 Aug 2014 14:53:03 +0200
4Subject: [PATCH] configure: use pkg-config for freetype
5
6Upstream-status: Pending
7Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
8---
9 configure.ac | 37 ++++++++-----------------------------
10 1 file changed, 8 insertions(+), 29 deletions(-)
11
12diff --git a/configure.ac b/configure.ac
13index 3cfe974..0055a8c 100644
14--- a/configure.ac
15+++ b/configure.ac
16@@ -399,40 +399,19 @@ AC_ARG_WITH(freetype,[ --with-freetype=DIR use freetype2 in DIR],[
17 fi
18 ])
19
20-if [ test -n "$FREETYPE_DIR" ]; then
21- AC_PATH_PROG(FREETYPE_CONFIG,freetype-config, ,[$FREETYPE_DIR/bin:$PATH])
22-else
23- AC_PATH_PROG(FREETYPE_CONFIG,freetype-config)
24-fi
25-
26-if [ test -n "$FREETYPE_CONFIG" ]; then
27- if [ test -n "$FREETYPE_DIR" ]; then
28- freetype_cflags="`$FREETYPE_CONFIG --cflags` -I$FREETYPE_DIR/include"
29- freetype_libs=`$FREETYPE_CONFIG --libs`
30- else
31- freetype_cflags=`$FREETYPE_CONFIG --cflags`
32- freetype_libs=`$FREETYPE_CONFIG --libs`
33- fi
34-else
35- if [ test -n "$FREETYPE_DIR" ]; then
36- freetype_cflags="-I$FREETYPE_DIR/include/freetype2 -I$FREETYPE_DIR/include"
37- freetype_libs="-L$FREETYPE_DIR/lib -lfreetype"
38- else
39- freetype_cflags=""
40- freetype_libs="-lfreetype"
41- fi
42-fi
43-
44-CPPFLAGS="$freetype_cflags $CPPFLAGS"
45-LDFLAGS="$LDFLAGS $freetype_libs"
46+PKG_CHECK_MODULES(FREETYPE2, freetype2,
47+ CFLAGS="$CFLAGS $FREETYPE2_CFLAGS"
48+ LDFLAGS="$LDFLAGS $FREETYPE2_LIBS",
49+ AC_MSG_ERROR([*** Unable to find FreeType2 library (http://www.freetype.org/)])
50+)
51
52 AC_CHECK_LIB(freetype,FT_Init_FreeType,[
53- WMF_FT_LDFLAGS="$freetype_libs"
54+ WMF_FT_LDFLAGS="$FREETYPE2_LIBS"
55 ],[ AC_MSG_ERROR([* * * freetype(2) is required * * *])
56 ])
57 AC_CHECK_HEADER(ft2build.h,[
58- WMF_FT_CFLAGS="$freetype_cflags"
59- WMF_FT_CONFIG_CFLAGS="$freetype_cflags"
60+ WMF_FT_CFLAGS="$FREETYPE2_CFLAGS"
61+ WMF_FT_CONFIG_CFLAGS="$FREETYPE2_CFLAGS"
62 ],[ AC_MSG_ERROR([* * * freetype(2) is required * * *])
63 ])
64
65--
661.9.0
67
diff --git a/meta-oe/recipes-extended/libwmf/libwmf_0.2.8.4.bb b/meta-oe/recipes-extended/libwmf/libwmf_0.2.8.4.bb
index 9f88ded98..746c4bd2d 100644
--- a/meta-oe/recipes-extended/libwmf/libwmf_0.2.8.4.bb
+++ b/meta-oe/recipes-extended/libwmf/libwmf_0.2.8.4.bb
@@ -7,10 +7,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7 7
8PR = "r3" 8PR = "r3"
9 9
10PNBLACKLIST[libwmf] = "BROKEN: needs to be updated to use freetype2 pkg-config instead of freetype-config" 10DEPENDS_virtclass-native = "freetype-native libpng-native jpeg-native"
11 11DEPENDS = "freetype libpng jpeg expat gtk+"
12DEPENDS_virtclass-native = "libpng-native jpeg-native"
13DEPENDS = "libpng jpeg expat gtk+"
14 12
15BBCLASSEXTEND = "native" 13BBCLASSEXTEND = "native"
16 14
@@ -18,7 +16,10 @@ inherit autotools
18 16
19SRC_URI = "${SOURCEFORGE_MIRROR}/wvware/${BPN}/${PV}/${BPN}-${PV}.tar.gz;name=tarball \ 17SRC_URI = "${SOURCEFORGE_MIRROR}/wvware/${BPN}/${PV}/${BPN}-${PV}.tar.gz;name=tarball \
20 file://libwmf-0.2.8.4-intoverflow.patch \ 18 file://libwmf-0.2.8.4-intoverflow.patch \
21 file://libwmf-0.2.8.4-useafterfree.patch" 19 file://libwmf-0.2.8.4-useafterfree.patch \
20 file://0001-configure-use-pkg-config-for-freetype.patch \
21 "
22
22SRC_URI[tarball.md5sum] = "d1177739bf1ceb07f57421f0cee191e0" 23SRC_URI[tarball.md5sum] = "d1177739bf1ceb07f57421f0cee191e0"
23SRC_URI[tarball.sha256sum] = "5b345c69220545d003ad52bfd035d5d6f4f075e65204114a9e875e84895a7cf8" 24SRC_URI[tarball.sha256sum] = "5b345c69220545d003ad52bfd035d5d6f4f075e65204114a9e875e84895a7cf8"
24 25