diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-12-25 10:27:02 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-12-26 19:52:55 -0800 |
commit | b52d234cf2ca61e8b9888701b1da553626903877 (patch) | |
tree | 86dbe12c33405e2b471e4aef5d8f585f3fd2ffed | |
parent | af86f2e84d8e2518baf3215c346adb7685224bff (diff) | |
download | meta-openembedded-b52d234cf2ca61e8b9888701b1da553626903877.tar.gz |
wvstreams: Fix build with gcc10
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-connectivity/wvdial/wvstreams/0001-Fix-narrowing-conversion-error.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb | 1 |
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/0001-Fix-narrowing-conversion-error.patch b/meta-oe/recipes-connectivity/wvdial/wvstreams/0001-Fix-narrowing-conversion-error.patch new file mode 100644 index 000000000..fc9abd8e6 --- /dev/null +++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/0001-Fix-narrowing-conversion-error.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From c86c524f951f6e973473bfee76fd5366368b2cbc Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 25 Dec 2019 09:32:41 -0800 | ||
4 | Subject: [PATCH] Fix narrowing conversion error | ||
5 | |||
6 | xplc/moduleloader.cc: In static member function 'static Module* Module::loadModule(const char*)': xplc/moduleloader.cc:67:14: error: narrowing conversion of '-1' from 'int' to 'unsigned int' [-Wnarrowing] 67 | case (int)-1: | ^ | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | xplc/moduleloader.cc | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/xplc/moduleloader.cc b/xplc/moduleloader.cc | ||
15 | index 02dd9a4..c53f5d2 100644 | ||
16 | --- a/xplc/moduleloader.cc | ||
17 | +++ b/xplc/moduleloader.cc | ||
18 | @@ -62,7 +62,7 @@ Module* Module::loadModule(const char* modulename) { | ||
19 | return NULL; | ||
20 | } | ||
21 | |||
22 | - switch(moduleinfo->version_major) { | ||
23 | + switch((int)moduleinfo->version_major) { | ||
24 | #ifdef UNSTABLE | ||
25 | case -1: | ||
26 | /* nothing to do */ | ||
27 | -- | ||
28 | 2.24.1 | ||
29 | |||
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb index b220f9c1b..20becaf57 100644 --- a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb +++ b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb | |||
@@ -22,6 +22,7 @@ SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.gz \ | |||
22 | file://0002-wvrules.mk-Use-_DEFAULT_SOURCE.patch \ | 22 | file://0002-wvrules.mk-Use-_DEFAULT_SOURCE.patch \ |
23 | file://openssl-buildfix.patch \ | 23 | file://openssl-buildfix.patch \ |
24 | file://0001-Forward-port-to-OpenSSL-1.1.x.patch \ | 24 | file://0001-Forward-port-to-OpenSSL-1.1.x.patch \ |
25 | file://0001-Fix-narrowing-conversion-error.patch \ | ||
25 | " | 26 | " |
26 | 27 | ||
27 | SRC_URI[md5sum] = "2760dac31a43d452a19a3147bfde571c" | 28 | SRC_URI[md5sum] = "2760dac31a43d452a19a3147bfde571c" |