diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-11-29 23:37:30 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-12-01 08:48:58 -0800 |
commit | b1d55efe056c5f66dd77ef2e6bf67203300db6dc (patch) | |
tree | 78c73d79a4218faebba5df781bd82ab0e5accb3b | |
parent | 5d7cb6ec416da05209bf2cc329f0da889a2de41d (diff) | |
download | meta-openembedded-b1d55efe056c5f66dd77ef2e6bf67203300db6dc.tar.gz |
sdbus-c++: Install ptests into PTEST_PATH
add rdep on basu and dbus when not using systemd
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rwxr-xr-x | meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest | 4 | ||||
-rw-r--r-- | meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb | 9 |
2 files changed, 6 insertions, 7 deletions
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest index f6ade0c7e..2dc6e1eca 100755 --- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest +++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest | |||
@@ -4,12 +4,12 @@ set -o pipefail | |||
4 | 4 | ||
5 | SCRIPTPATH="$( cd "$(dirname "$0")" ; pwd -P )" | 5 | SCRIPTPATH="$( cd "$(dirname "$0")" ; pwd -P )" |
6 | 6 | ||
7 | ${SCRIPTPATH}/../tests/sdbus-c++-unit-tests 2>&1 | \ | 7 | ${SCRIPTPATH}/sdbus-c++-unit-tests 2>&1 | \ |
8 | sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \ | 8 | sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \ |
9 | sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \ | 9 | sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \ |
10 | awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}' | 10 | awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}' |
11 | 11 | ||
12 | ${SCRIPTPATH}/../tests/sdbus-c++-integration-tests 2>&1 | \ | 12 | ${SCRIPTPATH}/sdbus-c++-integration-tests 2>&1 | \ |
13 | sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \ | 13 | sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \ |
14 | sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \ | 14 | sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \ |
15 | awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}' | 15 | awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}' |
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb index 869bfa951..ca91b351e 100644 --- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb +++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb | |||
@@ -10,9 +10,9 @@ inherit cmake pkgconfig systemd ptest | |||
10 | 10 | ||
11 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'with-external-libsystemd', 'with-builtin-libsystemd', d)} \ | 11 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'with-external-libsystemd', 'with-builtin-libsystemd', d)} \ |
12 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}" | 12 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}" |
13 | PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap" | 13 | PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap,basu" |
14 | PACKAGECONFIG[with-external-libsystemd] = ",,systemd,libsystemd" | 14 | PACKAGECONFIG[with-external-libsystemd] = ",,systemd,libsystemd" |
15 | PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${libdir}/${BPN}/tests,-DBUILD_TESTS=OFF,googletest gmock" | 15 | PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${PTEST_PATH},-DBUILD_TESTS=OFF,googletest gmock" |
16 | 16 | ||
17 | DEPENDS += "expat" | 17 | DEPENDS += "expat" |
18 | 18 | ||
@@ -39,14 +39,13 @@ do_install:append() { | |||
39 | fi | 39 | fi |
40 | } | 40 | } |
41 | 41 | ||
42 | PTEST_PATH = "${libdir}/${BPN}/ptest" | ||
43 | do_install_ptest() { | 42 | do_install_ptest() { |
44 | install -d ${D}${PTEST_PATH} | 43 | DESTDIR='${D}' cmake_runcmake_build --target tests/install |
45 | cp -r ${B}/tests/sdbus-c++-unit-tests ${D}${PTEST_PATH} | ||
46 | } | 44 | } |
47 | 45 | ||
48 | FILES:${PN}-ptest =+ "${sysconfdir}/dbus-1/system.d/" | 46 | FILES:${PN}-ptest =+ "${sysconfdir}/dbus-1/system.d/" |
49 | FILES:${PN}-dev += "${bindir}/sdbus-c++-xml2cpp" | 47 | FILES:${PN}-dev += "${bindir}/sdbus-c++-xml2cpp" |
50 | 48 | ||
49 | RDEPENDS:${PN}-ptest += "dbus" | ||
51 | # It adds -isystem which is spurious, no idea where it gets it from | 50 | # It adds -isystem which is spurious, no idea where it gets it from |
52 | CCACHE_DISABLE = "1" | 51 | CCACHE_DISABLE = "1" |