diff options
author | alperak <alperyasinak1@gmail.com> | 2024-02-08 08:58:12 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-09 09:52:15 -0800 |
commit | ae8d97707663ffaa70dd398c26c3ec74705fa49e (patch) | |
tree | 47132630072edc65cb8f18fd475440aee5d65035 | |
parent | bc5c3e48c15dc4a454b3643b42bf8ce8ac8b41cc (diff) | |
download | meta-openembedded-ae8d97707663ffaa70dd398c26c3ec74705fa49e.tar.gz |
python3-gspread: upgrade 6.0.0 -> 6.0.1
Upstream provides a pyproject.toml which declares a flit_core.buildapi build backend for PEP-517 packaging
Changelog:
Allow client to use external Session object
Remove-py-3.7-support
bugfix/client export
Fix oauth flow typo
check oauth creds type using isinstance
Fix type hints at find method in worksheet.py
Fixup get empty cell value is None
Fix missing attribute spreadsheet in Worksheet
update migration guide
Signed-off-by: alperak <alperyasinak1@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.0.bb | 12 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.1.bb | 14 |
2 files changed, 14 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.0.bb b/meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.0.bb deleted file mode 100644 index c04b1568b..000000000 --- a/meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.0.bb +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | SUMMARY = "Google Spreadsheets Python API" | ||
2 | HOMEPAGE = "https://github.com/burnash/gspread" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9488e21983675fa56dc05af558b83e2f" | ||
5 | |||
6 | SRC_URI[sha256sum] = "3b5efe315aeaa290d21befc8ee7bb0239db78c7b495d8831ae29fd1a182292a1" | ||
7 | |||
8 | S = "${WORKDIR}/gspread-${PV}" | ||
9 | |||
10 | RDEPENDS:${PN} = "python3-requests" | ||
11 | |||
12 | inherit pypi python_poetry_core | ||
diff --git a/meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.1.bb b/meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.1.bb new file mode 100644 index 000000000..7854b7562 --- /dev/null +++ b/meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.1.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | SUMMARY = "Google Spreadsheets Python API" | ||
2 | HOMEPAGE = "https://github.com/burnash/gspread" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9488e21983675fa56dc05af558b83e2f" | ||
5 | |||
6 | SRC_URI[sha256sum] = "8c8bf83be676a019d3a483455d8b17b442f2acfc620172f245422ca4fc960dd0" | ||
7 | |||
8 | RDEPENDS:${PN} = " \ | ||
9 | ${PYTHON_PN}-google-auth \ | ||
10 | ${PYTHON_PN}-google-auth-oauthlib \ | ||
11 | ${PYTHON_PN}-strenum \ | ||
12 | " | ||
13 | |||
14 | inherit pypi python_flit_core | ||