diff options
author | Christian Eggers <ceggers@arri.de> | 2020-06-09 08:32:09 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-06-10 20:55:27 -0700 |
commit | a661a41606d0f0b4bac1665c29ba7d5c7e6ef486 (patch) | |
tree | d4e725518b2949c6bfedabf696c1cda362aac751 | |
parent | 1d6071e97157851dbfbdf26f302fc5ec8f6ee4db (diff) | |
download | meta-openembedded-a661a41606d0f0b4bac1665c29ba7d5c7e6ef486.tar.gz |
graphviz: Extend for nativesdk
The "dot" tool is often used together with doxygen which is already
available for nativesdk.
Cross compiling graphviz for nativesdk looks quite similar as building
for target. At installation time of the SDK, "dot -c" must be called in
order to create <SDK sysroot>/usr/lib/graphviz/config6.
Signed-off-by: Christian Eggers <ceggers@arri.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-graphics/graphviz/graphviz/graphviz-setup.sh | 6 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb | 24 |
2 files changed, 29 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/graphviz/graphviz/graphviz-setup.sh b/meta-oe/recipes-graphics/graphviz/graphviz/graphviz-setup.sh new file mode 100644 index 000000000..df0be9e3e --- /dev/null +++ b/meta-oe/recipes-graphics/graphviz/graphviz/graphviz-setup.sh | |||
@@ -0,0 +1,6 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | echo "Setting up graphviz..." | ||
4 | |||
5 | # Create /usr/lib/graphviz/config6 | ||
6 | $OECORE_NATIVE_SYSROOT/usr/bin/dot -c | ||
diff --git a/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb b/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb index 12ecb9909..aa5c0c820 100644 --- a/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb +++ b/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb | |||
@@ -16,6 +16,7 @@ DEPENDS = " \ | |||
16 | freetype \ | 16 | freetype \ |
17 | " | 17 | " |
18 | DEPENDS_append_class-target = " ${BPN}-native" | 18 | DEPENDS_append_class-target = " ${BPN}-native" |
19 | DEPENDS_append_class-nativesdk = " ${BPN}-native" | ||
19 | 20 | ||
20 | inherit autotools-brokensep pkgconfig gettext | 21 | inherit autotools-brokensep pkgconfig gettext |
21 | 22 | ||
@@ -33,6 +34,10 @@ SRC_URI_append_class-target = "\ | |||
33 | file://0001-Use-native-mkdefs.patch \ | 34 | file://0001-Use-native-mkdefs.patch \ |
34 | file://0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch \ | 35 | file://0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch \ |
35 | " | 36 | " |
37 | SRC_URI_append_class-nativesdk = "\ | ||
38 | file://0001-Use-native-mkdefs.patch \ | ||
39 | file://graphviz-setup.sh \ | ||
40 | " | ||
36 | SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072" | 41 | SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072" |
37 | SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a" | 42 | SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a" |
38 | 43 | ||
@@ -47,7 +52,17 @@ EXTRA_OECONF_class-target = "\ | |||
47 | --disable-r \ | 52 | --disable-r \ |
48 | --disable-sharp \ | 53 | --disable-sharp \ |
49 | " | 54 | " |
55 | EXTRA_OECONF_class-nativesdk = "\ | ||
56 | --with-expatincludedir=${STAGING_INCDIR} \ | ||
57 | --with-expatlibdir=${STAGING_LIBDIR} \ | ||
58 | --without-included-ltdl \ | ||
59 | --disable-java \ | ||
60 | --disable-tcl \ | ||
61 | --disable-r \ | ||
62 | --disable-sharp \ | ||
63 | " | ||
50 | CFLAGS_append_class-target = " -D_typ_ssize_t=1 -D_long_double=1" | 64 | CFLAGS_append_class-target = " -D_typ_ssize_t=1 -D_long_double=1" |
65 | CFLAGS_append_class-nativesdk = " -D_typ_ssize_t=1 -D_long_double=1" | ||
51 | do_configure_prepend() { | 66 | do_configure_prepend() { |
52 | cd ${S} | 67 | cd ${S} |
53 | # create version.m4 and ignore libtoolize errors | 68 | # create version.m4 and ignore libtoolize errors |
@@ -59,6 +74,13 @@ do_install_append_class-native() { | |||
59 | install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir} | 74 | install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir} |
60 | } | 75 | } |
61 | 76 | ||
77 | do_install_append_class-nativesdk() { | ||
78 | # graphviz-setup.sh must be executed at SDK installation | ||
79 | install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d | ||
80 | install -m 0755 ${WORKDIR}/graphviz-setup.sh ${D}${SDKPATHNATIVE}/post-relocate-setup.d | ||
81 | } | ||
82 | FILES_${PN}_class-nativesdk += "${SDKPATHNATIVE}" | ||
83 | |||
62 | PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo" | 84 | PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo" |
63 | 85 | ||
64 | FILES_${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/" | 86 | FILES_${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/" |
@@ -74,4 +96,4 @@ INSANE_SKIP_${PN}-python = "dev-so" | |||
74 | 96 | ||
75 | FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}" | 97 | FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}" |
76 | 98 | ||
77 | BBCLASSEXTEND = "native" | 99 | BBCLASSEXTEND = "native nativesdk" |