diff options
author | Derek Straka <derek@asterius.io> | 2020-02-15 12:35:54 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-02-16 12:52:19 -0800 |
commit | a14a6159f7a7d3d8301bfa320e4c0fd9b1587e34 (patch) | |
tree | 6915dac6e5f0ed1c089beba40395e6e49c8bd453 | |
parent | fb58592c7042d7e2164d0c1da35793d17f85c008 (diff) | |
download | meta-openembedded-a14a6159f7a7d3d8301bfa320e4c0fd9b1587e34.tar.gz |
python3-configargparse: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python-configargparse.inc | 22 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb | 23 |
2 files changed, 21 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-configargparse.inc b/meta-python/recipes-devtools/python/python-configargparse.inc deleted file mode 100644 index 17d296ff8..000000000 --- a/meta-python/recipes-devtools/python/python-configargparse.inc +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | SUMMARY = "A drop-in replacement for argparse that allows options to also be set via config files and/or environment variables." | ||
2 | HOMEPAGE = "https://github.com/bw2/ConfigArgParse" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=da746463714cc35999ed9a42339f2943" | ||
5 | |||
6 | SRC_URI[md5sum] = "aba15b7973b7a70bea86fd69289f8fe3" | ||
7 | SRC_URI[sha256sum] = "baaf0fd2c1c108d007f402dab5481ac5f12d77d034825bf5a27f8224757bd0ac" | ||
8 | |||
9 | PYPI_PACKAGE = "ConfigArgParse" | ||
10 | |||
11 | inherit pypi | ||
12 | |||
13 | PACKAGECONFIG ?= "yaml" | ||
14 | PACKAGECONFIG[yaml] = ",,,${PYTHON_PN}-pyyaml" | ||
15 | |||
16 | RDEPENDS_${PN} += "\ | ||
17 | ${PYTHON_PN}-core \ | ||
18 | ${PYTHON_PN}-shell \ | ||
19 | " | ||
20 | |||
21 | BBCLASSEXTEND = "native nativesdk" | ||
22 | |||
diff --git a/meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb b/meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb index 698eccf66..0797898a9 100644 --- a/meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb +++ b/meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb | |||
@@ -1,3 +1,22 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "A drop-in replacement for argparse that allows options to also be set via config files and/or environment variables." |
2 | require python-configargparse.inc | 2 | HOMEPAGE = "https://github.com/bw2/ConfigArgParse" |
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=da746463714cc35999ed9a42339f2943" | ||
5 | |||
6 | SRC_URI[md5sum] = "aba15b7973b7a70bea86fd69289f8fe3" | ||
7 | SRC_URI[sha256sum] = "baaf0fd2c1c108d007f402dab5481ac5f12d77d034825bf5a27f8224757bd0ac" | ||
8 | |||
9 | PYPI_PACKAGE = "ConfigArgParse" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | PACKAGECONFIG ?= "yaml" | ||
14 | PACKAGECONFIG[yaml] = ",,,${PYTHON_PN}-pyyaml" | ||
15 | |||
16 | RDEPENDS_${PN} += "\ | ||
17 | ${PYTHON_PN}-core \ | ||
18 | ${PYTHON_PN}-shell \ | ||
19 | " | ||
20 | |||
21 | BBCLASSEXTEND = "native nativesdk" | ||
3 | 22 | ||