summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2019-12-11 13:46:58 +0100
committerKhem Raj <raj.khem@gmail.com>2019-12-13 18:29:14 -0800
commita04e0ed79fc9ad048301cafc5c3a79502e466e5c (patch)
tree9d0c29082fa8532beb1b8231a24163c12b9b969d
parentba5fbb239e66b9d201bfffa3436d20003b17786f (diff)
downloadmeta-openembedded-a04e0ed79fc9ad048301cafc5c3a79502e466e5c.tar.gz
libsoc: use python3 for python bindings
With python in PACKAGECONFIGS and with the removal of python2 from host tools the recipe fails to build. Change the recipe to use python3. libsoc configure uses the host python to detect the used version, install and use the python3-native package to have the same version for host and target. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb b/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb
index 01708df35..8b773aefa 100644
--- a/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb
+++ b/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "https://github.com/jackmitch/libsoc"
7LICENSE = "LGPLv2.1" 7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://LICENCE;md5=e0bfebea12a718922225ba987b2126a5" 8LIC_FILES_CHKSUM = "file://LICENCE;md5=e0bfebea12a718922225ba987b2126a5"
9 9
10inherit autotools pkgconfig python-dir 10inherit autotools pkgconfig python3-dir
11 11
12SRCREV = "fd1ad6e7823fa76d8db0d3c5884faffa8ffddafb" 12SRCREV = "fd1ad6e7823fa76d8db0d3c5884faffa8ffddafb"
13SRC_URI = "git://github.com/jackmitch/libsoc.git" 13SRC_URI = "git://github.com/jackmitch/libsoc.git"
@@ -21,7 +21,7 @@ PACKAGECONFIG ?= ""
21PACKAGECONFIG[disabledebug] = "--disable-debug,," 21PACKAGECONFIG[disabledebug] = "--disable-debug,,"
22PACKAGECONFIG[allboardconfigs] = "--with-board-configs,," 22PACKAGECONFIG[allboardconfigs] = "--with-board-configs,,"
23PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},," 23PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},,"
24PACKAGECONFIG[python] = "--enable-python=${PYTHON_PN},,${PYTHON_PN}" 24PACKAGECONFIG[python] = "--enable-python=${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN},,${PYTHON_PN} ${PYTHON_PN}-native"
25 25
26PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \ 26PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \
27 '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}" 27 '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}"