summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-05-10 14:55:11 +0300
committerKhem Raj <raj.khem@gmail.com>2019-05-10 14:07:54 -0700
commit9fa7848415e8a074afeede2dda52628f76ef1954 (patch)
treec5d2aa4e2a84a72b8285ad3a9af1252f2cdd9cf5
parent772421e9e90e0a4c9654fae5fafed54efc15ace2 (diff)
downloadmeta-openembedded-9fa7848415e8a074afeede2dda52628f76ef1954.tar.gz
liboop: Upgrade 1.0 -> 1.0.1
Remove patches applied upstream. Update to the current homepage. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/liboop/liboop/explicit_linking.patch20
-rw-r--r--meta-oe/recipes-support/liboop/liboop/new-readline-typedef.patch11
-rw-r--r--meta-oe/recipes-support/liboop/liboop/read_bugfixes.patch40
-rw-r--r--meta-oe/recipes-support/liboop/liboop/tcl_dev.patch11
-rw-r--r--meta-oe/recipes-support/liboop/liboop_1.0.1.bb (renamed from meta-oe/recipes-support/liboop/liboop_1.0.bb)9
5 files changed, 3 insertions, 88 deletions
diff --git a/meta-oe/recipes-support/liboop/liboop/explicit_linking.patch b/meta-oe/recipes-support/liboop/liboop/explicit_linking.patch
deleted file mode 100644
index 05d3bf6f4..000000000
--- a/meta-oe/recipes-support/liboop/liboop/explicit_linking.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1--- a/Makefile.am
2+++ b/Makefile.am
3@@ -51,7 +51,7 @@ noinst_PROGRAMS = test-oop
4
5 test_oop_SOURCES = test-oop.c
6 test_oop_CFLAGS = $(GLIB2_CFLAGS) $(GLIB_INCLUDES) $(TCL_INCLUDES) $(WWW_INCLUDES)
7-test_oop_LDADD = $(lib_LTLIBRARIES)
8+test_oop_LDADD = $(lib_LTLIBRARIES) $(GLIB2_LIBS) $(ADNS_LIBS) $(TCL_LIBS) $(READLINE_LIBS)
9
10 release: dist
11 gzip -dc $(PACKAGE)-$(VERSION).tar.gz | bzip2 -9 \
12--- a/liboop-glib2.pc.in
13+++ b/liboop-glib2.pc.in
14@@ -7,5 +7,5 @@ Name: liboop-glib2
15 Description: Event loop management library (GLIB2 support)
16 Version: @VERSION@
17 Requires: liboop = @VERSION@ glib-2.0
18-Libs: -L${libdir} -loop-glib2
19+Libs: -L${libdir} -loop-glib2 @GLIB2_LIBS@
20 Cflags: -D_REENTRANT -I${includedir}
diff --git a/meta-oe/recipes-support/liboop/liboop/new-readline-typedef.patch b/meta-oe/recipes-support/liboop/liboop/new-readline-typedef.patch
deleted file mode 100644
index 0a0242032..000000000
--- a/meta-oe/recipes-support/liboop/liboop/new-readline-typedef.patch
+++ /dev/null
@@ -1,11 +0,0 @@
1--- a/test-oop.c
2+++ b/test-oop.c
3@@ -180,7 +180,7 @@ static void *stop_readline(oop_source *s
4 static void add_readline(oop_source *src) {
5 rl_callback_handler_install(
6 (char *) "> ", /* readline isn't const-correct */
7- (VFunction *) on_readline);
8+ (rl_vcpfunc_t *) on_readline);
9 oop_readline_register(src);
10 src->on_signal(src,SIGQUIT,stop_readline,NULL);
11 }
diff --git a/meta-oe/recipes-support/liboop/liboop/read_bugfixes.patch b/meta-oe/recipes-support/liboop/liboop/read_bugfixes.patch
deleted file mode 100644
index 1880a241a..000000000
--- a/meta-oe/recipes-support/liboop/liboop/read_bugfixes.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From: Ian Jackson <ijackson@chiark.greenend.org.uk>
2Applied-Upstream: no
3Bug-Debian: http://bugs.debian.org/579604
4Subject: oop-read.h bugfixes
5
6Some years ago I contributed a feature for reading lines and records
7to liboop: oop-read.h and read.c. Since it took a while for that
8feature to make it into distributed versions, for a long time I've
9been using my own copy of the source file. It seems that I fixed a
10couple of bugs in my copy which are still in the Debian package. I
11can't find any record of me having told anyone about them and now I
12find that 1.0-6 still has the bugs.
13
14There are two fixes:
15 * Initialise "rd->discard" properly
16 * Avoid rd->neednotcheck becoming negative
17
18--- a/read.c
19+++ b/read.c
20@@ -114,6 +114,7 @@ oop_read *oop_rd_new(oop_source *oop, oo
21 rd->allocbuf= 0;
22 rd->used= 0;
23 rd->alloc= buf ? bufsz : 0;
24+ rd->discard= 0;
25 rd->neednotcheck= 0;
26 rd->displacedchar= -1;
27 rd->style= *OOP_RD_STYLE_IMMED;
28@@ -235,7 +236,11 @@ static void *on_process(oop_source *oop,
29
30 if (rd->discard) {
31 rd->used -= rd->discard;
32- rd->neednotcheck -= rd->discard;
33+ if (rd->neednotcheck > rd->discard) {
34+ rd->neednotcheck -= rd->discard;
35+ } else {
36+ rd->neednotcheck= 0;
37+ }
38 memmove(buf, buf + rd->discard, rd->used);
39 rd->discard= 0;
40 }
diff --git a/meta-oe/recipes-support/liboop/liboop/tcl_dev.patch b/meta-oe/recipes-support/liboop/liboop/tcl_dev.patch
index e738be54c..e00cf8014 100644
--- a/meta-oe/recipes-support/liboop/liboop/tcl_dev.patch
+++ b/meta-oe/recipes-support/liboop/liboop/tcl_dev.patch
@@ -1,14 +1,3 @@
1--- a/configure
2+++ b/configure
3@@ -19935,7 +19935,7 @@
4 fi
5
6 if test xno != x$with_tcl; then
7- for version in 8.4 8.3 8.2 8.1 8.0 ; do
8+ for version in "" 8.4 8.3 8.2 8.1 8.0 ; do
9 CPPFLAGS="$save_cppflags -I/usr/include/tcl$version"
10 as_ac_Lib=`echo "ac_cv_lib_tcl$version''_Tcl_Main" | $as_tr_sh`
11 echo "$as_me:$LINENO: checking for Tcl_Main in -ltcl$version" >&5
12--- a/configure.ac 1--- a/configure.ac
13+++ b/configure.ac 2+++ b/configure.ac
14@@ -71,7 +71,7 @@ 3@@ -71,7 +71,7 @@
diff --git a/meta-oe/recipes-support/liboop/liboop_1.0.bb b/meta-oe/recipes-support/liboop/liboop_1.0.1.bb
index 82818c242..8ba3f72b7 100644
--- a/meta-oe/recipes-support/liboop/liboop_1.0.bb
+++ b/meta-oe/recipes-support/liboop/liboop_1.0.1.bb
@@ -1,17 +1,14 @@
1DESCRIPTION = "Liboop is a low-level event loop management library for POSIX-based operating systems" 1DESCRIPTION = "Liboop is a low-level event loop management library for POSIX-based operating systems"
2HOMEPAGE = "http://liboop.org/" 2HOMEPAGE = "http://www.lysator.liu.se/liboop/"
3LICENSE = "GPL-2.0" 3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=8b54f38ccbd44feb80ab90e01af8b700" 4LIC_FILES_CHKSUM = "file://COPYING;md5=8b54f38ccbd44feb80ab90e01af8b700"
5 5
6SRC_URI = "http://ftp.debian.org/debian/pool/main/libo/liboop/liboop_${PV}.orig.tar.gz \ 6SRC_URI = "http://ftp.debian.org/debian/pool/main/libo/liboop/liboop_${PV}.orig.tar.gz \
7 file://read_bugfixes.patch \
8 file://explicit_linking.patch \
9 file://tcl_dev.patch \ 7 file://tcl_dev.patch \
10 file://new-readline-typedef.patch \
11" 8"
12 9
13SRC_URI[md5sum] = "36cb971047d3af02369446f5e0b315a2" 10SRC_URI[md5sum] = "f2b3dff17355fd9a6e2229caca8993f0"
14SRC_URI[sha256sum] = "34d83c6e0f09ee15cb2bc3131e219747c3b612bb57cf7d25318ab90da9a2d97c" 11SRC_URI[sha256sum] = "56af16ad65e7397dadc8268e37ff6f67431db390c60c75e21a33e12b0e0d17e0"
15 12
16PACKAGECONFIG ?= "" 13PACKAGECONFIG ?= ""
17PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline" 14PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"