diff options
author | wangmy <wangmy@fujitsu.com> | 2022-01-07 22:27:34 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-01-07 11:29:09 -0800 |
commit | 9a74f83974e38dae6cefcd24f5b76476dc7cb80c (patch) | |
tree | 8f450e83cf1b095d331baa0330e02cc163956a13 | |
parent | f16f628d1f8c2ca37df10b2d84dea05d6b9ebab1 (diff) | |
download | meta-openembedded-9a74f83974e38dae6cefcd24f5b76476dc7cb80c.tar.gz |
doxygen: upgrade 1.9.2 -> 1.9.3
refresh doxygen-native-only-check-python3.patch
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/doxygen/doxygen/doxygen-native-only-check-python3.patch | 44 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb (renamed from meta-oe/recipes-devtools/doxygen/doxygen_1.9.2.bb) | 2 |
2 files changed, 22 insertions, 24 deletions
diff --git a/meta-oe/recipes-devtools/doxygen/doxygen/doxygen-native-only-check-python3.patch b/meta-oe/recipes-devtools/doxygen/doxygen/doxygen-native-only-check-python3.patch index 9d1a5a93d0..b6d007d8df 100644 --- a/meta-oe/recipes-devtools/doxygen/doxygen/doxygen-native-only-check-python3.patch +++ b/meta-oe/recipes-devtools/doxygen/doxygen/doxygen-native-only-check-python3.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 7aeee92c752f8a4b2524ed6a41d60c1a3ca8bf2d Mon Sep 17 00:00:00 2001 | 1 | From daf686508f2ee4711d93e96e5b100e50bf161656 Mon Sep 17 00:00:00 2001 |
2 | From: Leon Anavi <leon.anavi@konsulko.com> | 2 | From: Leon Anavi <leon.anavi@konsulko.com> |
3 | Date: Wed, 26 Aug 2020 10:52:10 +0300 | 3 | Date: Wed, 26 Aug 2020 10:52:10 +0300 |
4 | Subject: [PATCH] doxygen: Fix Python issues for doxygen-native | 4 | Subject: [PATCH] doxygen: Fix Python issues for doxygen-native |
@@ -39,6 +39,7 @@ Upstream-Status: Inappropriate[oe specific] | |||
39 | Co-Authored-By: Kai Kang <kai.kang@windriver.com> | 39 | Co-Authored-By: Kai Kang <kai.kang@windriver.com> |
40 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | 40 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> |
41 | Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> | 41 | Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> |
42 | |||
42 | --- | 43 | --- |
43 | CMakeLists.txt | 2 +- | 44 | CMakeLists.txt | 2 +- |
44 | addon/doxywizard/CMakeLists.txt | 6 +++--- | 45 | addon/doxywizard/CMakeLists.txt | 6 +++--- |
@@ -50,10 +51,10 @@ Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> | |||
50 | 7 files changed, 17 insertions(+), 17 deletions(-) | 51 | 7 files changed, 17 insertions(+), 17 deletions(-) |
51 | 52 | ||
52 | diff --git a/CMakeLists.txt b/CMakeLists.txt | 53 | diff --git a/CMakeLists.txt b/CMakeLists.txt |
53 | index f30b46b8..50f211c8 100644 | 54 | index 2455793..28f0d83 100644 |
54 | --- a/CMakeLists.txt | 55 | --- a/CMakeLists.txt |
55 | +++ b/CMakeLists.txt | 56 | +++ b/CMakeLists.txt |
56 | @@ -101,7 +101,7 @@ else () | 57 | @@ -105,7 +105,7 @@ else () |
57 | endif () | 58 | endif () |
58 | 59 | ||
59 | find_program(DOT NAMES dot) | 60 | find_program(DOT NAMES dot) |
@@ -63,10 +64,10 @@ index f30b46b8..50f211c8 100644 | |||
63 | find_package(BISON REQUIRED) | 64 | find_package(BISON REQUIRED) |
64 | if (BISON_VERSION VERSION_LESS 2.7) | 65 | if (BISON_VERSION VERSION_LESS 2.7) |
65 | diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt | 66 | diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt |
66 | index a6f65f8d..d163aa5b 100644 | 67 | index 63ac8e3..d37d1d0 100644 |
67 | --- a/addon/doxywizard/CMakeLists.txt | 68 | --- a/addon/doxywizard/CMakeLists.txt |
68 | +++ b/addon/doxywizard/CMakeLists.txt | 69 | +++ b/addon/doxywizard/CMakeLists.txt |
69 | @@ -58,7 +58,7 @@ set_source_files_properties(${GENERATED_SRC_WIZARD}/settings.h PROPERTIES GENERA | 70 | @@ -57,7 +57,7 @@ set_source_files_properties(${GENERATED_SRC_WIZARD}/settings.h PROPERTIES GENERA |
70 | 71 | ||
71 | # generate version.cpp | 72 | # generate version.cpp |
72 | add_custom_command( | 73 | add_custom_command( |
@@ -75,7 +76,7 @@ index a6f65f8d..d163aa5b 100644 | |||
75 | DEPENDS ${PROJECT_SOURCE_DIR}/VERSION ${PROJECT_SOURCE_DIR}/src/version.py | 76 | DEPENDS ${PROJECT_SOURCE_DIR}/VERSION ${PROJECT_SOURCE_DIR}/src/version.py |
76 | OUTPUT ${GENERATED_SRC_WIZARD}/version.cpp | 77 | OUTPUT ${GENERATED_SRC_WIZARD}/version.cpp |
77 | ) | 78 | ) |
78 | @@ -66,7 +66,7 @@ set_source_files_properties(${GENERATED_SRC_WIZARD}/version.cpp PROPERTIES GENER | 79 | @@ -65,7 +65,7 @@ set_source_files_properties(${GENERATED_SRC_WIZARD}/version.cpp PROPERTIES GENER |
79 | 80 | ||
80 | # generate configdoc.cpp | 81 | # generate configdoc.cpp |
81 | add_custom_command( | 82 | add_custom_command( |
@@ -84,7 +85,7 @@ index a6f65f8d..d163aa5b 100644 | |||
84 | DEPENDS ${PROJECT_SOURCE_DIR}/src/configgen.py ${PROJECT_SOURCE_DIR}/src/config.xml | 85 | DEPENDS ${PROJECT_SOURCE_DIR}/src/configgen.py ${PROJECT_SOURCE_DIR}/src/config.xml |
85 | OUTPUT ${GENERATED_SRC_WIZARD}/configdoc.cpp | 86 | OUTPUT ${GENERATED_SRC_WIZARD}/configdoc.cpp |
86 | ) | 87 | ) |
87 | @@ -75,7 +75,7 @@ set_source_files_properties(${GENERATED_SRC_WIZARD}/configdoc.cpp PROPERTIES GEN | 88 | @@ -74,7 +74,7 @@ set_source_files_properties(${GENERATED_SRC_WIZARD}/configdoc.cpp PROPERTIES GEN |
88 | set(LEX_FILES config_doxyw) | 89 | set(LEX_FILES config_doxyw) |
89 | foreach(lex_file ${LEX_FILES}) | 90 | foreach(lex_file ${LEX_FILES}) |
90 | add_custom_command( | 91 | add_custom_command( |
@@ -94,10 +95,10 @@ index a6f65f8d..d163aa5b 100644 | |||
94 | OUTPUT ${GENERATED_SRC_WIZARD}/${lex_file}.l.h | 95 | OUTPUT ${GENERATED_SRC_WIZARD}/${lex_file}.l.h |
95 | ) | 96 | ) |
96 | diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt | 97 | diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt |
97 | index f2d177ed..22a4d602 100644 | 98 | index ec63ceb..49a2bda 100644 |
98 | --- a/doc/CMakeLists.txt | 99 | --- a/doc/CMakeLists.txt |
99 | +++ b/doc/CMakeLists.txt | 100 | +++ b/doc/CMakeLists.txt |
100 | @@ -163,7 +163,7 @@ configure_file(${PROJECT_SOURCE_DIR}/doc/doxyindexer.1 ${PROJECT_BINARY_DIR | 101 | @@ -168,7 +168,7 @@ configure_file(${PROJECT_SOURCE_DIR}/doc/doxyindexer.1 ${PROJECT_BINARY_DIR |
101 | 102 | ||
102 | # doc/language.doc (see tag Doxyfile:INPUT) | 103 | # doc/language.doc (see tag Doxyfile:INPUT) |
103 | add_custom_command( | 104 | add_custom_command( |
@@ -106,7 +107,7 @@ index f2d177ed..22a4d602 100644 | |||
106 | DEPENDS ${PROJECT_SOURCE_DIR}/doc/maintainers.txt ${PROJECT_SOURCE_DIR}/doc/language.tpl ${PROJECT_BINARY_DIR}/doc/translator.py ${LANG_FILES} | 107 | DEPENDS ${PROJECT_SOURCE_DIR}/doc/maintainers.txt ${PROJECT_SOURCE_DIR}/doc/language.tpl ${PROJECT_BINARY_DIR}/doc/translator.py ${LANG_FILES} |
107 | OUTPUT language.doc | 108 | OUTPUT language.doc |
108 | WORKING_DIRECTORY ${PROJECT_BINARY_DIR}/doc | 109 | WORKING_DIRECTORY ${PROJECT_BINARY_DIR}/doc |
109 | @@ -172,7 +172,7 @@ set_source_files_properties(language.doc PROPERTIES GENERATED 1) | 110 | @@ -177,7 +177,7 @@ set_source_files_properties(language.doc PROPERTIES GENERATED 1) |
110 | 111 | ||
111 | # doc/config.doc (see tag Doxyfile:INPUT) | 112 | # doc/config.doc (see tag Doxyfile:INPUT) |
112 | add_custom_command( | 113 | add_custom_command( |
@@ -115,7 +116,7 @@ index f2d177ed..22a4d602 100644 | |||
115 | DEPENDS ${TOP}/src/config.xml ${TOP}/src/configgen.py | 116 | DEPENDS ${TOP}/src/config.xml ${TOP}/src/configgen.py |
116 | OUTPUT config.doc | 117 | OUTPUT config.doc |
117 | WORKING_DIRECTORY ${PROJECT_BINARY_DIR}/doc/ | 118 | WORKING_DIRECTORY ${PROJECT_BINARY_DIR}/doc/ |
118 | @@ -223,7 +223,7 @@ add_custom_target(docs_chm | 119 | @@ -228,7 +228,7 @@ add_custom_target(docs_chm |
119 | COMMAND ${CMAKE_COMMAND} -E echo " for file in files:" >> ${PROJECT_BINARY_DIR}/chm/doxygen_manual_examples_chm.py | 120 | COMMAND ${CMAKE_COMMAND} -E echo " for file in files:" >> ${PROJECT_BINARY_DIR}/chm/doxygen_manual_examples_chm.py |
120 | COMMAND ${CMAKE_COMMAND} -E echo " if file.endswith('.html') or file.endswith('.png') or file.endswith('.css') or file.endswith('.gif'):" >> ${PROJECT_BINARY_DIR}/chm/doxygen_manual_examples_chm.py | 121 | COMMAND ${CMAKE_COMMAND} -E echo " if file.endswith('.html') or file.endswith('.png') or file.endswith('.css') or file.endswith('.gif'):" >> ${PROJECT_BINARY_DIR}/chm/doxygen_manual_examples_chm.py |
121 | COMMAND ${CMAKE_COMMAND} -E echo " print(os.path.join(root, file))" >> ${PROJECT_BINARY_DIR}/chm/doxygen_manual_examples_chm.py | 122 | COMMAND ${CMAKE_COMMAND} -E echo " print(os.path.join(root, file))" >> ${PROJECT_BINARY_DIR}/chm/doxygen_manual_examples_chm.py |
@@ -125,7 +126,7 @@ index f2d177ed..22a4d602 100644 | |||
125 | COMMAND ${CMAKE_COMMAND} -E rename ${PROJECT_BINARY_DIR}/chm/index.chm ${PROJECT_BINARY_DIR}/chm/doxygen_manual.chm | 126 | COMMAND ${CMAKE_COMMAND} -E rename ${PROJECT_BINARY_DIR}/chm/index.chm ${PROJECT_BINARY_DIR}/chm/doxygen_manual.chm |
126 | DEPENDS ${PROJECT_BINARY_DIR}/doc/language.doc ${PROJECT_BINARY_DIR}/doc/config.doc | 127 | DEPENDS ${PROJECT_BINARY_DIR}/doc/language.doc ${PROJECT_BINARY_DIR}/doc/config.doc |
127 | diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt | 128 | diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt |
128 | index 194b4271..248b8076 100644 | 129 | index 194b427..248b807 100644 |
129 | --- a/examples/CMakeLists.txt | 130 | --- a/examples/CMakeLists.txt |
130 | +++ b/examples/CMakeLists.txt | 131 | +++ b/examples/CMakeLists.txt |
131 | @@ -54,7 +54,7 @@ foreach (f_inp ${BASIC_EXAMPLES}) | 132 | @@ -54,7 +54,7 @@ foreach (f_inp ${BASIC_EXAMPLES}) |
@@ -147,7 +148,7 @@ index 194b4271..248b8076 100644 | |||
147 | OUTPUT ${PROJECT_BINARY_DIR}/html/examples/diagrams/html/index.html ${PROJECT_BINARY_DIR}/latex/examples/diagrams/latex/refman_doc.tex | 148 | OUTPUT ${PROJECT_BINARY_DIR}/html/examples/diagrams/html/index.html ${PROJECT_BINARY_DIR}/latex/examples/diagrams/latex/refman_doc.tex |
148 | ) | 149 | ) |
149 | diff --git a/libmscgen/CMakeLists.txt b/libmscgen/CMakeLists.txt | 150 | diff --git a/libmscgen/CMakeLists.txt b/libmscgen/CMakeLists.txt |
150 | index 0a239008..09849e2d 100644 | 151 | index 34cf4d8..f015afc 100644 |
151 | --- a/libmscgen/CMakeLists.txt | 152 | --- a/libmscgen/CMakeLists.txt |
152 | +++ b/libmscgen/CMakeLists.txt | 153 | +++ b/libmscgen/CMakeLists.txt |
153 | @@ -7,7 +7,7 @@ include_directories( | 154 | @@ -7,7 +7,7 @@ include_directories( |
@@ -160,10 +161,10 @@ index 0a239008..09849e2d 100644 | |||
160 | OUTPUT ${GENERATED_SRC}/${lex_file}.l.h | 161 | OUTPUT ${GENERATED_SRC}/${lex_file}.l.h |
161 | ) | 162 | ) |
162 | diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt | 163 | diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt |
163 | index 5004a957..68e803f2 100644 | 164 | index 0e0c5f7..c1d3ca5 100644 |
164 | --- a/src/CMakeLists.txt | 165 | --- a/src/CMakeLists.txt |
165 | +++ b/src/CMakeLists.txt | 166 | +++ b/src/CMakeLists.txt |
166 | @@ -39,7 +39,7 @@ set_source_files_properties(${GENERATED_SRC}/settings.h PROPERTIES GENERATED 1) | 167 | @@ -40,7 +40,7 @@ set_source_files_properties(${GENERATED_SRC}/settings.h PROPERTIES GENERATED 1) |
167 | 168 | ||
168 | # configvalues.h | 169 | # configvalues.h |
169 | add_custom_command( | 170 | add_custom_command( |
@@ -172,7 +173,7 @@ index 5004a957..68e803f2 100644 | |||
172 | DEPENDS ${CMAKE_CURRENT_LIST_DIR}/config.xml ${CMAKE_CURRENT_LIST_DIR}/configgen.py | 173 | DEPENDS ${CMAKE_CURRENT_LIST_DIR}/config.xml ${CMAKE_CURRENT_LIST_DIR}/configgen.py |
173 | OUTPUT ${GENERATED_SRC}/configvalues.h | 174 | OUTPUT ${GENERATED_SRC}/configvalues.h |
174 | ) | 175 | ) |
175 | @@ -51,7 +51,7 @@ add_custom_target( | 176 | @@ -52,7 +52,7 @@ add_custom_target( |
176 | 177 | ||
177 | # configvalues.cpp | 178 | # configvalues.cpp |
178 | add_custom_command( | 179 | add_custom_command( |
@@ -181,7 +182,7 @@ index 5004a957..68e803f2 100644 | |||
181 | DEPENDS ${CMAKE_CURRENT_LIST_DIR}/config.xml ${CMAKE_CURRENT_LIST_DIR}/configgen.py | 182 | DEPENDS ${CMAKE_CURRENT_LIST_DIR}/config.xml ${CMAKE_CURRENT_LIST_DIR}/configgen.py |
182 | OUTPUT ${GENERATED_SRC}/configvalues.cpp | 183 | OUTPUT ${GENERATED_SRC}/configvalues.cpp |
183 | ) | 184 | ) |
184 | @@ -59,7 +59,7 @@ set_source_files_properties(${GENERATED_SRC}/configvalues.cpp PROPERTIES GENERAT | 185 | @@ -60,7 +60,7 @@ set_source_files_properties(${GENERATED_SRC}/configvalues.cpp PROPERTIES GENERAT |
185 | 186 | ||
186 | # configoptions.cpp | 187 | # configoptions.cpp |
187 | add_custom_command( | 188 | add_custom_command( |
@@ -190,7 +191,7 @@ index 5004a957..68e803f2 100644 | |||
190 | DEPENDS ${CMAKE_CURRENT_LIST_DIR}/config.xml ${CMAKE_CURRENT_LIST_DIR}/configgen.py | 191 | DEPENDS ${CMAKE_CURRENT_LIST_DIR}/config.xml ${CMAKE_CURRENT_LIST_DIR}/configgen.py |
191 | OUTPUT ${GENERATED_SRC}/configoptions.cpp | 192 | OUTPUT ${GENERATED_SRC}/configoptions.cpp |
192 | ) | 193 | ) |
193 | @@ -94,7 +94,7 @@ endif() | 194 | @@ -95,7 +95,7 @@ endif() |
194 | # resources.cpp | 195 | # resources.cpp |
195 | add_custom_command( | 196 | add_custom_command( |
196 | COMMENT "Generating ${GENERATED_SRC}/resources.cpp" | 197 | COMMENT "Generating ${GENERATED_SRC}/resources.cpp" |
@@ -199,7 +200,7 @@ index 5004a957..68e803f2 100644 | |||
199 | DEPENDS ${RESOURCES} ${CMAKE_CURRENT_LIST_DIR}/res2cc_cmd.py | 200 | DEPENDS ${RESOURCES} ${CMAKE_CURRENT_LIST_DIR}/res2cc_cmd.py |
200 | OUTPUT ${GENERATED_SRC}/resources.cpp | 201 | OUTPUT ${GENERATED_SRC}/resources.cpp |
201 | ) | 202 | ) |
202 | @@ -124,7 +124,7 @@ foreach(lex_file ${LEX_FILES}) | 203 | @@ -126,7 +126,7 @@ foreach(lex_file ${LEX_FILES}) |
203 | set(LEX_FILES_H ${LEX_FILES_H} " " ${GENERATED_SRC}/${lex_file}.l.h CACHE INTERNAL "Stores generated files") | 204 | set(LEX_FILES_H ${LEX_FILES_H} " " ${GENERATED_SRC}/${lex_file}.l.h CACHE INTERNAL "Stores generated files") |
204 | set(LEX_FILES_CPP ${LEX_FILES_CPP} " " ${GENERATED_SRC}/${lex_file}.cpp CACHE INTERNAL "Stores generated files") | 205 | set(LEX_FILES_CPP ${LEX_FILES_CPP} " " ${GENERATED_SRC}/${lex_file}.cpp CACHE INTERNAL "Stores generated files") |
205 | add_custom_command( | 206 | add_custom_command( |
@@ -209,7 +210,7 @@ index 5004a957..68e803f2 100644 | |||
209 | OUTPUT ${GENERATED_SRC}/${lex_file}.l.h | 210 | OUTPUT ${GENERATED_SRC}/${lex_file}.l.h |
210 | ) | 211 | ) |
211 | diff --git a/testing/CMakeLists.txt b/testing/CMakeLists.txt | 212 | diff --git a/testing/CMakeLists.txt b/testing/CMakeLists.txt |
212 | index fd6912e9..0af1865b 100644 | 213 | index fd6912e..0af1865 100644 |
213 | --- a/testing/CMakeLists.txt | 214 | --- a/testing/CMakeLists.txt |
214 | +++ b/testing/CMakeLists.txt | 215 | +++ b/testing/CMakeLists.txt |
215 | @@ -1,7 +1,7 @@ | 216 | @@ -1,7 +1,7 @@ |
@@ -229,6 +230,3 @@ index fd6912e9..0af1865b 100644 | |||
229 | + COMMAND ${Python3_EXECUTABLE} ${PROJECT_SOURCE_DIR}/testing/runtests.py --id ${TEST_ID} --doxygen $<TARGET_FILE:doxygen> --inputdir ${PROJECT_SOURCE_DIR}/testing --outputdir ${PROJECT_BINARY_DIR}/testing | 230 | + COMMAND ${Python3_EXECUTABLE} ${PROJECT_SOURCE_DIR}/testing/runtests.py --id ${TEST_ID} --doxygen $<TARGET_FILE:doxygen> --inputdir ${PROJECT_SOURCE_DIR}/testing --outputdir ${PROJECT_BINARY_DIR}/testing |
230 | ) | 231 | ) |
231 | endforeach() | 232 | endforeach() |
232 | -- | ||
233 | 2.27.0 | ||
234 | |||
diff --git a/meta-oe/recipes-devtools/doxygen/doxygen_1.9.2.bb b/meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb index fc5df4c71f..7070c1f2d6 100644 --- a/meta-oe/recipes-devtools/doxygen/doxygen_1.9.2.bb +++ b/meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb | |||
@@ -10,7 +10,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.src.tar.gz \ | |||
10 | file://0001-build-don-t-look-for-Iconv.patch \ | 10 | file://0001-build-don-t-look-for-Iconv.patch \ |
11 | " | 11 | " |
12 | SRC_URI:append:class-native = " file://doxygen-native-only-check-python3.patch" | 12 | SRC_URI:append:class-native = " file://doxygen-native-only-check-python3.patch" |
13 | SRC_URI[sha256sum] = "060f254bcef48673cc7ccf542736b7455b67c110b30fdaa33512a5b09bbecee5" | 13 | SRC_URI[sha256sum] = "f352dbc3221af7012b7b00935f2dfdc9fb67a97d43287d2f6c81c50449d254e0" |
14 | 14 | ||
15 | inherit cmake python3native | 15 | inherit cmake python3native |
16 | 16 | ||