summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeace Lee <iipeace5@gmail.com>2020-03-09 21:39:11 +0900
committerKhem Raj <raj.khem@gmail.com>2020-06-10 20:57:01 -0700
commit93c9a20bf358bc10c2d99fc1d3c7247145344c29 (patch)
tree66574ec318001a0eb6b0adeb2e1b085576f249d0
parente921a2f251a325aaa1ea46c42b8ae789c2897cf0 (diff)
downloadmeta-openembedded-93c9a20bf358bc10c2d99fc1d3c7247145344c29.tar.gz
guider: Upgrade to 3.9.7
Signed-off-by: Peace Lee <iipeace5@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/guider/guider_3.9.6.bb39
-rw-r--r--meta-oe/recipes-devtools/guider/guider_3.9.7.bb19
2 files changed, 19 insertions, 39 deletions
diff --git a/meta-oe/recipes-devtools/guider/guider_3.9.6.bb b/meta-oe/recipes-devtools/guider/guider_3.9.6.bb
deleted file mode 100644
index f05900216..000000000
--- a/meta-oe/recipes-devtools/guider/guider_3.9.6.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1SUMMARY = "runtime performance analyzer"
2HOMEPAGE = "https://github.com/iipeace/guider"
3BUGTRACKER = "https://github.com/iipeace/guider/issues"
4AUTHOR = "Peace Lee <ipeace5@gmail.com>"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2"
8
9PV = "3.9.6+git${SRCPV}"
10PR = "r0"
11
12SRC_URI = "git://github.com/iipeace/${BPN}"
13#SRCREV = "${AUTOREV}"
14SRCREV = "fef25c41efb9bde0614ea477d0b90bd9565ae0b4"
15
16S = "${WORKDIR}/git"
17R = "${RECIPE_SYSROOT}"
18
19inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "distutils", "", d)}
20
21GUIDER_OBJ = "guider.pyc"
22GUIDER_SCRIPT = "guider"
23
24do_install() {
25 python ${S}/setup.py install
26
27 install -d ${D}${bindir}
28 install -v -m 0755 ${STAGING_BINDIR_NATIVE}/${GUIDER_SCRIPT} ${D}${bindir}/${GUIDER_SCRIPT}
29
30 install -d ${D}${datadir}/${BPN}
31 install -v -m 0755 ${STAGING_LIBDIR_NATIVE}/python${PYTHON_BASEVERSION}/site-packages/${BPN}/${GUIDER_OBJ} ${D}${datadir}/${BPN}/${GUIDER_OBJ}
32}
33
34RDEPENDS_${PN} = "python-ctypes python-shell \
35 python-json python-subprocess"
36python() {
37 if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
38 raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
39}
diff --git a/meta-oe/recipes-devtools/guider/guider_3.9.7.bb b/meta-oe/recipes-devtools/guider/guider_3.9.7.bb
new file mode 100644
index 000000000..2b799fd5e
--- /dev/null
+++ b/meta-oe/recipes-devtools/guider/guider_3.9.7.bb
@@ -0,0 +1,19 @@
1SUMMARY = "runtime performance analyzer"
2HOMEPAGE = "https://github.com/iipeace/guider"
3BUGTRACKER = "https://github.com/iipeace/guider/issues"
4AUTHOR = "Peace Lee <ipeace5@gmail.com>"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2"
8
9PV = "3.9.7+git${SRCPV}"
10
11SRC_URI = "git://github.com/iipeace/${BPN}"
12SRCREV = "c87269d6d4669d12c99a2a7b9b07c39a5dd24ac6"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools3
17
18RDEPENDS_${PN} = "python3 python3-core \
19 python3-ctypes python3-shell python3-json"