summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-24 18:16:21 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-25 10:22:19 -0700
commit92f8049bc9ec5e4b9655d9a25325a7ca9ab25595 (patch)
tree5d78ea0ccddbff2d54f5cee823bd0ec3789a9853
parent61e52047e1c593ec7902b1ddf34d4ebc5fdc3879 (diff)
downloadmeta-openembedded-92f8049bc9ec5e4b9655d9a25325a7ca9ab25595.tar.gz
python3-netaddr: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-netaddr.inc13
-rw-r--r--meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb15
2 files changed, 13 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-netaddr.inc b/meta-python/recipes-devtools/python/python-netaddr.inc
deleted file mode 100644
index bea9be674..000000000
--- a/meta-python/recipes-devtools/python/python-netaddr.inc
+++ /dev/null
@@ -1,13 +0,0 @@
1SUMMARY = "A network address manipulation library for Python."
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=e6345d695ffe3776f68a56fe7962db44"
4
5SRC_URI[md5sum] = "51019ef59c93f3979bcb37d3b8527e07"
6SRC_URI[sha256sum] = "38aeec7cdd035081d3a4c306394b19d677623bf76fa0913f6695127c7753aefd"
7
8inherit pypi
9
10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-pprint \
12 ${PYTHON_PN}-xml \
13"
diff --git a/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb b/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb
index 30416a4ff..75460caa7 100644
--- a/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb
+++ b/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb
@@ -1,2 +1,13 @@
1require python-netaddr.inc 1SUMMARY = "A network address manipulation library for Python."
2inherit setuptools3 2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=e6345d695ffe3776f68a56fe7962db44"
4
5SRC_URI[md5sum] = "51019ef59c93f3979bcb37d3b8527e07"
6SRC_URI[sha256sum] = "38aeec7cdd035081d3a4c306394b19d677623bf76fa0913f6695127c7753aefd"
7
8inherit pypi setuptools3
9
10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-pprint \
12 ${PYTHON_PN}-xml \
13"