diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-03-31 12:21:03 -0700 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-04-08 17:00:06 -0700 |
commit | 8b472920426e22a3b0102ebbb9db7bebee4cc607 (patch) | |
tree | ccf5760207113f512badc2d0f924a8000f389db1 | |
parent | 190bec6025d4fc40ae488daea1f6dba9d9fbeb77 (diff) | |
download | meta-openembedded-8b472920426e22a3b0102ebbb9db7bebee4cc607.tar.gz |
glibmm: Backport patch to fix invalid code in glibmm/threads.h
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r-- | meta-oe/recipes-core/glib-2.0/glibmm/0001-Glib-Threads-Private-Fix-gobj.patch | 40 | ||||
-rw-r--r-- | meta-oe/recipes-core/glib-2.0/glibmm_2.54.1.bb | 1 |
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/glib-2.0/glibmm/0001-Glib-Threads-Private-Fix-gobj.patch b/meta-oe/recipes-core/glib-2.0/glibmm/0001-Glib-Threads-Private-Fix-gobj.patch new file mode 100644 index 000000000..7899022f1 --- /dev/null +++ b/meta-oe/recipes-core/glib-2.0/glibmm/0001-Glib-Threads-Private-Fix-gobj.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From 838fe84c2ddcc9af51c34f751defbf3dd0ba8a06 Mon Sep 17 00:00:00 2001 | ||
2 | From: Kjell Ahlstedt <kjellahlstedt@gmail.com> | ||
3 | Date: Wed, 20 Dec 2017 20:00:32 +0100 | ||
4 | Subject: [PATCH] Glib::Threads::Private: Fix gobj() | ||
5 | |||
6 | Bug 791711 | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | Upstream-Status: Backport [https://github.com/GNOME/glibmm/commit/37d57ae9572b7d74aa385a30313eceae7f2d3fce] | ||
11 | glib/glibmm/threads.h | 2 +- | ||
12 | glib/src/threads.hg | 2 +- | ||
13 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/glib/glibmm/threads.h b/glib/glibmm/threads.h | ||
16 | index f7e2b82a..2c0cbe8c 100644 | ||
17 | --- a/glib/glibmm/threads.h | ||
18 | +++ b/glib/glibmm/threads.h | ||
19 | @@ -657,7 +657,7 @@ public: | ||
20 | */ | ||
21 | inline void replace(T* data); | ||
22 | |||
23 | - GPrivate* gobj() { return gobject_; } | ||
24 | + GPrivate* gobj() { return &gobject_; } | ||
25 | |||
26 | private: | ||
27 | GPrivate gobject_; | ||
28 | diff --git a/glib/src/threads.hg b/glib/src/threads.hg | ||
29 | index 86d7a17b..c82a6130 100644 | ||
30 | --- a/glib/src/threads.hg | ||
31 | +++ b/glib/src/threads.hg | ||
32 | @@ -628,7 +628,7 @@ public: | ||
33 | */ | ||
34 | inline void replace(T* data); | ||
35 | |||
36 | - GPrivate* gobj() { return gobject_; } | ||
37 | + GPrivate* gobj() { return &gobject_; } | ||
38 | |||
39 | private: | ||
40 | GPrivate gobject_; | ||
diff --git a/meta-oe/recipes-core/glib-2.0/glibmm_2.54.1.bb b/meta-oe/recipes-core/glib-2.0/glibmm_2.54.1.bb index 3a69a7057..4706432ab 100644 --- a/meta-oe/recipes-core/glib-2.0/glibmm_2.54.1.bb +++ b/meta-oe/recipes-core/glib-2.0/glibmm_2.54.1.bb | |||
@@ -13,6 +13,7 @@ SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" | |||
13 | SRC_URI = " \ | 13 | SRC_URI = " \ |
14 | ftp://ftp.gnome.org/pub/GNOME/sources/glibmm/${SHRT_VER}/glibmm-${PV}.tar.xz \ | 14 | ftp://ftp.gnome.org/pub/GNOME/sources/glibmm/${SHRT_VER}/glibmm-${PV}.tar.xz \ |
15 | file://remove-examples.patch \ | 15 | file://remove-examples.patch \ |
16 | file://0001-Glib-Threads-Private-Fix-gobj.patch \ | ||
16 | " | 17 | " |
17 | SRC_URI[md5sum] = "dee5ebe309f5976c3dacfcf5c43a062b" | 18 | SRC_URI[md5sum] = "dee5ebe309f5976c3dacfcf5c43a062b" |
18 | SRC_URI[sha256sum] = "7cc28c732b04d70ed34f0c923543129083cfb90580ea4a2b4be5b38802bf6a4a" | 19 | SRC_URI[sha256sum] = "7cc28c732b04d70ed34f0c923543129083cfb90580ea4a2b4be5b38802bf6a4a" |