summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-08-25 11:54:05 +0300
committerKhem Raj <raj.khem@gmail.com>2023-08-26 17:32:45 -0700
commit87f7eb0aedcd3f13c095e649de83fd1e7a70f9a6 (patch)
treeaf1a20af4381703fd56af08c71a10574e88050d3
parent90fbe305c538b1368cd655e5e5687e794b37a859 (diff)
downloadmeta-openembedded-87f7eb0aedcd3f13c095e649de83fd1e7a70f9a6.tar.gz
neatvnc: add new recipe
Add a new recipe for neatvnc v0.6.0, a liberally licensed VNC server library with a clean interface. It is required for building Weston with VNC backend. Please note that tls is not part of the default PACKAGECONFIG because it requires gnutls. However, to use properly VNC it should be enabled if building Weston 12 with VNC backend. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/neatvnc/neatvnc_git.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/neatvnc/neatvnc_git.bb b/meta-oe/recipes-graphics/neatvnc/neatvnc_git.bb
new file mode 100644
index 000000000..834401520
--- /dev/null
+++ b/meta-oe/recipes-graphics/neatvnc/neatvnc_git.bb
@@ -0,0 +1,40 @@
1SUMMARY = "A liberally licensed VNC server library"
2DESCRIPTION = "This is a liberally licensed VNC server library that's intended to be fast and neat."
3HOMEPAGE = "https://github.com/any1/neatvnc"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94fc374e7174f41e3afe0f027ee59ff7"
6
7SRC_URI = "git://github.com/any1/neatvnc;branch=master;protocol=https"
8
9SRCREV = "8b3dc1ae6099dcfa73aec3ae11df2fdc58540d14"
10
11PV = "0.6.0+git${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15DEPENDS = "libdrm pixman aml zlib"
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[tls] = "-Dtls=enabled,-Dtls=disabled,gnutls"
19PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,libjpeg-turbo"
20PACKAGECONFIG[examples] = "-Dexamples=true,-Dexamples=false,libpng"
21PACKAGECONFIG[benchmarks] = "-Dbenchmarks=true,-Dbenchmarks=false,libpng"
22
23PACKAGE_BEFORE_PN += "${PN}-examples"
24ALLOW_EMPTY:${PN}-examples = "1"
25FILES:${PN}-examples = "${bindir}"
26
27NEATVNC_EXAMPLES = "draw png-server"
28
29inherit meson pkgconfig
30
31do_install:append () {
32 if ${@bb.utils.contains('PACKAGECONFIG', 'examples', 'true', 'false', d)}; then
33 install -d ${D}${bindir}
34 for bin in ${NEATVNC_EXAMPLES}; do
35 install -m 0755 ${B}/examples/$bin ${D}${bindir}
36 done
37 fi
38}
39
40BBCLASSEXTEND = "native"