diff options
author | Fabio Berton <fabio.berton@ossystems.com.br> | 2016-08-22 16:01:19 -0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-09-05 13:27:36 +0200 |
commit | 775a576d2e62d17f4a4b4c24e117ab5241c646de (patch) | |
tree | 2bc893b7cdde315b6dda8de662a3a56a55a0ef14 | |
parent | 96b167037b4d329cc37c3368de99ddc517bf19ee (diff) | |
download | meta-openembedded-775a576d2e62d17f4a4b4c24e117ab5241c646de.tar.gz |
python-pycparser: Extend recipe to support Python 3
- Add Python 3 recipe
- Add native and nativesdk to BBCLASSEXTEND
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
3 files changed, 11 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycparser.inc b/meta-python/recipes-devtools/python/python-pycparser.inc new file mode 100644 index 000000000..bf3b75798 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pycparser.inc | |||
@@ -0,0 +1,8 @@ | |||
1 | SUMMARY = "Parser of the C language, written in pure Python" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8fb364772b1441821d391591f340c35a" | ||
4 | |||
5 | SRC_URI[md5sum] = "a2bc8d28c923b4fe2b2c3b4b51a4f935" | ||
6 | SRC_URI[sha256sum] = "7959b4a74abdc27b312fed1c21e6caf9309ce0b29ea86b591fd2e99ecdf27f73" | ||
7 | |||
8 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-pycparser_2.14.bb b/meta-python/recipes-devtools/python/python-pycparser_2.14.bb index 18006ca6a..adbc1a8f4 100644 --- a/meta-python/recipes-devtools/python/python-pycparser_2.14.bb +++ b/meta-python/recipes-devtools/python/python-pycparser_2.14.bb | |||
@@ -1,10 +1,2 @@ | |||
1 | SUMMARY = "Parser of the C language, written in pure Python" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8fb364772b1441821d391591f340c35a" | ||
4 | |||
5 | SRC_URI[md5sum] = "a2bc8d28c923b4fe2b2c3b4b51a4f935" | ||
6 | SRC_URI[sha256sum] = "7959b4a74abdc27b312fed1c21e6caf9309ce0b29ea86b591fd2e99ecdf27f73" | ||
7 | |||
8 | inherit pypi setuptools | 1 | inherit pypi setuptools |
9 | 2 | require python-pycparser.inc | |
10 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-python/recipes-devtools/python/python3-pycparser_2.14.bb b/meta-python/recipes-devtools/python/python3-pycparser_2.14.bb new file mode 100644 index 000000000..b30db54c5 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pycparser_2.14.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit pypi setuptools3 | ||
2 | require python-pycparser.inc | ||