diff options
author | Armin Kuster <akuster808@gmail.com> | 2018-03-06 07:30:57 -0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-03-12 09:59:32 -0700 |
commit | 729cde51429b62a6d0c36569ced7dfdb66e65c37 (patch) | |
tree | e9be6818d38e55de3a75bd985e7c5f5ebec78fd9 | |
parent | 115d6020d89092a2753b231948ea8d4e81c087d9 (diff) | |
download | meta-openembedded-729cde51429b62a6d0c36569ced7dfdb66e65c37.tar.gz |
vim: only include when x11 in DISTRO_FEATURES
fixes:
vim:do_install: 6a98ed60a33e0915e83ddf4411cb98a4 -> fab6a8f9b3c3978de44b458939712d90
bitbake-diffsigs --task vim do_install --signature 6a98ed60a33e0915e83ddf4411cb98a4 fab6a8f9b3c3978de44b458939712d90
NOTE: Starting bitbake server...
basehash changed from 7302bf635913317779cf6e19324032a4 to 4a66ac61a894cf5b09db9afc053c77e6
Variable do_install value changed:
@@ -11,3 +11,7 @@
# we use --with-features=big as default
mv ${D}${bindir}/${BPN} ${D}${bindir}/${BPN}.${BPN}
+ # The mouse being autoenabled is just annoying in xfce4-terminal (mouse
+ # drag make vim go into visual mode and there is no right click menu),
+ # delete the block.
+ sed -i '/the mouse works just fine/,+4d' ${D}/${datadir}/${BPN}/vimrc
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r-- | meta-xfce/recipes-support/vim/vim_%.bbappend | 7 | ||||
-rw-r--r-- | meta-xfce/recipes-support/vim/vim_xfce.inc | 6 |
2 files changed, 7 insertions, 6 deletions
diff --git a/meta-xfce/recipes-support/vim/vim_%.bbappend b/meta-xfce/recipes-support/vim/vim_%.bbappend index 25403e6cb..7b449630e 100644 --- a/meta-xfce/recipes-support/vim/vim_%.bbappend +++ b/meta-xfce/recipes-support/vim/vim_%.bbappend | |||
@@ -1,6 +1 @@ | |||
1 | do_install_append() { | require ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${BPN}_xfce.inc', '', d)} | |
2 | # The mouse being autoenabled is just annoying in xfce4-terminal (mouse | ||
3 | # drag make vim go into visual mode and there is no right click menu), | ||
4 | # delete the block. | ||
5 | sed -i '/the mouse works just fine/,+4d' ${D}/${datadir}/${BPN}/vimrc | ||
6 | } | ||
diff --git a/meta-xfce/recipes-support/vim/vim_xfce.inc b/meta-xfce/recipes-support/vim/vim_xfce.inc new file mode 100644 index 000000000..25403e6cb --- /dev/null +++ b/meta-xfce/recipes-support/vim/vim_xfce.inc | |||
@@ -0,0 +1,6 @@ | |||
1 | do_install_append() { | ||
2 | # The mouse being autoenabled is just annoying in xfce4-terminal (mouse | ||
3 | # drag make vim go into visual mode and there is no right click menu), | ||
4 | # delete the block. | ||
5 | sed -i '/the mouse works just fine/,+4d' ${D}/${datadir}/${BPN}/vimrc | ||
6 | } | ||