diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2020-01-09 22:05:10 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-01-10 00:50:59 -0800 |
commit | 70ac4381d3193128ac8b8c8e28369a8290176faf (patch) | |
tree | d261e3aa116f6de7b45808f4d45fc924d9cdabf6 | |
parent | 5b92128aea6a15eeb993cb34477c9bdf4fcd66f9 (diff) | |
download | meta-openembedded-70ac4381d3193128ac8b8c8e28369a8290176faf.tar.gz |
poppler: upgrade 0.82.0 -> 0.84.0
>From announcements:
Release 0.84.0:
core:
* Fix crash when converting from Unicode to ASCII-7
* Splash::scaleImageYdXu: Protect against crash if srcWidth is too big
* JBIG2Stream: fix potential crash in malformed documents
* JBIG2Stream: fix leak in reset() if called several times
* Internal code improvements
utils:
* pdfimages: Add error message if first page is larger then number of pages.
* pdfinfo: Improved paper size recognition
* pdfsig: Fix exit code when dumping signatures
* pdftocairo: Error out when even/odd selects 0 pages
* pdftohtml: Fix memory leak
* pdftoppm: Add an option to scale before rotate
* pdftoppm: Add -hide-annotations option
* pdftoppm: Error out when even/odd selects 0 pages
* pdftops: Improve -optimizecolorspace
qt5:
* Code cleanups
glib:
* Fix compiler warnings
Release 0.83.0:
core:
* Improve when a file is recognized as Linearized
* Improve const-ness of the code
* Make code a bit more readable/maintanable
* Fix uninitialized memory uses in broken files
utils:
* pdffonts: Make code a bit more readable/maintanable
* pdftohtml: Make code a bit more readable/maintanable
qt5:
* Remove a bunch of unused internal functions
* trUtf8 -> tr (less warnings)
build system:
* make-glib-api-docs: switch to python3
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler/basename-include.patch | 4 | ||||
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler_0.84.0.bb (renamed from meta-oe/recipes-support/poppler/poppler_0.82.0.bb) | 4 |
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler/basename-include.patch b/meta-oe/recipes-support/poppler/poppler/basename-include.patch index c18a5f5c0..3d6d7a8f1 100644 --- a/meta-oe/recipes-support/poppler/poppler/basename-include.patch +++ b/meta-oe/recipes-support/poppler/poppler/basename-include.patch | |||
@@ -16,8 +16,8 @@ index 830c1c80..e93eb368 100644 | |||
16 | --- a/goo/gbasename.cc | 16 | --- a/goo/gbasename.cc |
17 | +++ b/goo/gbasename.cc | 17 | +++ b/goo/gbasename.cc |
18 | @@ -46,6 +46,10 @@ | 18 | @@ -46,6 +46,10 @@ |
19 | #include <stdlib.h> | 19 | #include <cstdlib> |
20 | #include <string.h> | 20 | #include <cstring> |
21 | 21 | ||
22 | +#if !defined(__GLIBC__) | 22 | +#if !defined(__GLIBC__) |
23 | +#define basename(src) (strrchr(src,'/') ? strrchr(src,'/')+1 : src) | 23 | +#define basename(src) (strrchr(src,'/') ? strrchr(src,'/')+1 : src) |
diff --git a/meta-oe/recipes-support/poppler/poppler_0.82.0.bb b/meta-oe/recipes-support/poppler/poppler_0.84.0.bb index 37f859353..0f3e50571 100644 --- a/meta-oe/recipes-support/poppler/poppler_0.82.0.bb +++ b/meta-oe/recipes-support/poppler/poppler_0.84.0.bb | |||
@@ -6,8 +6,8 @@ SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.xz \ | |||
6 | file://0001-Do-not-overwrite-all-our-build-flags.patch \ | 6 | file://0001-Do-not-overwrite-all-our-build-flags.patch \ |
7 | file://basename-include.patch \ | 7 | file://basename-include.patch \ |
8 | " | 8 | " |
9 | SRC_URI[md5sum] = "4d6106c2382c5e66072e0b355acc3640" | 9 | SRC_URI[md5sum] = "e14a8aca8809908ad4364c32c17bcb92" |
10 | SRC_URI[sha256sum] = "234f8e573ea57fb6a008e7c1e56bfae1af5d1adf0e65f47555e1ae103874e4df" | 10 | SRC_URI[sha256sum] = "c7a130da743b38a548f7a21fe5940506fb1949f4ebdd3209f0e5b302fa139731" |
11 | 11 | ||
12 | DEPENDS = "fontconfig zlib cairo lcms glib-2.0" | 12 | DEPENDS = "fontconfig zlib cairo lcms glib-2.0" |
13 | 13 | ||