diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-08-18 21:53:44 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-08-18 23:41:11 -0700 |
commit | 6c998191cd1070342fbcfc86f93e5ac1201c56ff (patch) | |
tree | fe8465ea5628163a57cbf531fd5e0b982164d304 | |
parent | 9ed1e62bbb17c66f8ab3d0601d4968e4b034484a (diff) | |
download | meta-openembedded-6c998191cd1070342fbcfc86f93e5ac1201c56ff.tar.gz |
fluentbit: Use CMAKE_C_STANDARD_LIBRARIES cmake var to pass libatomic
Since libatomic needs to be linked last in the list of libs, take
advantange of using CMAKE_C_STANDARD_LIBRARIES insread of FLB_DEPS
since DFLB_DEPS is not appended last to linker flags in CMakefiles
it ends up with undefined references for libatomic symbols in libs
appearing after FLB_LIBS in sequence
Use it for mips too
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit_1.9.6.bb | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.6.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.6.bb index ea6f81cbf..a801694f4 100644 --- a/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.6.bb +++ b/meta-oe/recipes-extended/fluentbit/fluentbit_1.9.6.bb | |||
@@ -75,8 +75,9 @@ EXTRA_OECMAKE += "-DFLB_RELEASE=On" | |||
75 | # musl needs these options | 75 | # musl needs these options |
76 | EXTRA_OECMAKE:append:libc-musl = ' -DFLB_JEMALLOC_OPTIONS="--with-jemalloc-prefix=je_ --with-lg-quantum=3" -DFLB_CORO_STACK_SIZE=24576' | 76 | EXTRA_OECMAKE:append:libc-musl = ' -DFLB_JEMALLOC_OPTIONS="--with-jemalloc-prefix=je_ --with-lg-quantum=3" -DFLB_CORO_STACK_SIZE=24576' |
77 | 77 | ||
78 | EXTRA_OECMAKE:append:riscv64 = " -DFLB_DEPS='atomic'" | 78 | EXTRA_OECMAKE:append:riscv64 = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic" |
79 | EXTRA_OECMAKE:append:riscv32 = " -DFLB_DEPS='atomic'" | 79 | EXTRA_OECMAKE:append:riscv32 = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic" |
80 | EXTRA_OECMAKE:append:mips = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic" | ||
80 | 81 | ||
81 | inherit cmake systemd pkgconfig | 82 | inherit cmake systemd pkgconfig |
82 | 83 | ||