diff options
author | Armin Kuster <akuster808@gmail.com> | 2018-04-07 15:25:18 -0700 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-04-13 12:43:40 -0700 |
commit | 68c8fe1aba92ca2ed5e1156fa0050609ab4f73af (patch) | |
tree | 0b97556ce77ef357924cab0df45284778f8a08f6 | |
parent | c3b41c1f3cdb3f2c4b39e295c36c01a1b43abb74 (diff) | |
download | meta-openembedded-68c8fe1aba92ca2ed5e1156fa0050609ab4f73af.tar.gz |
squid: refresh patches
ARNING:
Some of the context lines in patches were ignored. This can lead to incorrectly applied patches.
The context lines in the patches can be updated with devtool:
devtool modify <recipe>
devtool finish --force-patch-refresh <recipe> <layer_path>
Then the updated patches and the source tree (in devtool's workspace)
should be reviewed to make sure the patches apply in the correct place
and don't introduce duplicate lines (which can, and does happen
when some of the context is ignored). Further information:
http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html
https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450
Details:
checking file configure.ac
Hunk #1 succeeded at 27 with fuzz 1 (offset 8 lines).
and others
Signed-off-by: Armin Kuster <akuster808@gmail.com>
10 files changed, 102 insertions, 96 deletions
diff --git a/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch b/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch index 48674c3c5..f482f8088 100644 --- a/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch +++ b/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From f9150a0dc092ab2cbd47ee428436b747dce323a9 Mon Sep 17 00:00:00 2001 | 1 | From 27e10667bf27baf5f119a791e3473bb9435a786a Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sun, 23 Apr 2017 10:28:28 -0700 | 3 | Date: Sun, 23 Apr 2017 10:28:28 -0700 |
4 | Subject: [PATCH] SquidNew: use noexcept instead of throw for C++11 compilers | 4 | Subject: [PATCH] SquidNew: use noexcept instead of throw for C++11 compilers |
@@ -11,6 +11,7 @@ _SQUID_EXTERNNEW_ void *operator new[] (size_t size) throw (std::bad_alloc) | |||
11 | ^~~~~ | 11 | ^~~~~ |
12 | 12 | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
14 | |||
14 | --- | 15 | --- |
15 | include/SquidNew.h | 8 ++++---- | 16 | include/SquidNew.h | 8 ++++---- |
16 | 1 file changed, 4 insertions(+), 4 deletions(-) | 17 | 1 file changed, 4 insertions(+), 4 deletions(-) |
@@ -43,6 +44,3 @@ index 39fcee0..c960347 100644 | |||
43 | { | 44 | { |
44 | xfree(address); | 45 | xfree(address); |
45 | } | 46 | } |
46 | -- | ||
47 | 2.12.2 | ||
48 | |||
diff --git a/meta-networking/recipes-daemons/squid/files/0001-configure-Check-for-Wno-error-format-truncation-comp.patch b/meta-networking/recipes-daemons/squid/files/0001-configure-Check-for-Wno-error-format-truncation-comp.patch index 0c0a3aad1..302136a03 100644 --- a/meta-networking/recipes-daemons/squid/files/0001-configure-Check-for-Wno-error-format-truncation-comp.patch +++ b/meta-networking/recipes-daemons/squid/files/0001-configure-Check-for-Wno-error-format-truncation-comp.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 14d469bc82c758116aef7d549abd49c131b4170f Mon Sep 17 00:00:00 2001 | 1 | From c21adbb0b230ffba97cf5d059e2bd024e13a37df Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 22 Apr 2017 11:54:57 -0700 | 3 | Date: Sat, 22 Apr 2017 11:54:57 -0700 |
4 | Subject: [PATCH] configure: Check for -Wno-error=format-truncation compiler | 4 | Subject: [PATCH] configure: Check for -Wno-error=format-truncation compiler |
@@ -9,36 +9,18 @@ Fixes | |||
9 | client.c:834:23: error: '%s' directive output may be truncated writing up to 1023 bytes into a region of size 1010 [-Werror=format-truncation=] | 9 | client.c:834:23: error: '%s' directive output may be truncated writing up to 1023 bytes into a region of size 1010 [-Werror=format-truncation=] |
10 | 10 | ||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
12 | |||
12 | --- | 13 | --- |
13 | configure.ac | 3 +- | 14 | acinclude/ax_check_compile_flag.m4 | 74 ++++++++++++++++++++++++++++++++++++++ |
14 | m4/ax_check_compile_flag.m4 | 74 +++++++++++++++++++++++++++++++++++++++++++++ | 15 | configure.ac | 2 ++ |
15 | 2 files changed, 76 insertions(+), 1 deletion(-) | 16 | 2 files changed, 76 insertions(+) |
16 | create mode 100644 m4/ax_check_compile_flag.m4 | 17 | create mode 100644 acinclude/ax_check_compile_flag.m4 |
17 | 18 | ||
18 | Index: squid-3.5.26/configure.ac | 19 | diff --git a/acinclude/ax_check_compile_flag.m4 b/acinclude/ax_check_compile_flag.m4 |
19 | =================================================================== | 20 | new file mode 100644 |
20 | --- squid-3.5.26.orig/configure.ac | 21 | index 0000000..dcabb92 |
21 | +++ squid-3.5.26/configure.ac | ||
22 | @@ -26,6 +26,7 @@ m4_include([acinclude/pkg.m4]) | ||
23 | m4_include([acinclude/lib-checks.m4]) | ||
24 | m4_include([acinclude/ax_cxx_compile_stdcxx_11.m4]) | ||
25 | m4_include([acinclude/ax_cxx_0x_types.m4]) | ||
26 | +m4_include([acinclude/ax_check_compile_flag.m4]) | ||
27 | |||
28 | HOSTCXX="$BUILD_CXX" | ||
29 | PRESET_CFLAGS="$CFLAGS" | ||
30 | @@ -44,6 +45,7 @@ AC_PROG_CXX | ||
31 | AC_LANG([C++]) | ||
32 | AC_CANONICAL_HOST | ||
33 | |||
34 | +AX_CHECK_COMPILE_FLAG([-Werror=format-truncation],[CFLAGS="$CFLAGS -Wno-error=format-truncation" CXXFLAGS="$CXXFLAGS -Wno-error=format-truncation"]) | ||
35 | # Clang 3.2 on some CPUs requires -march-native to detect correctly. | ||
36 | # GCC 4.3+ can also produce faster executables when its used. | ||
37 | # But building inside a virtual machine environment has been found to | ||
38 | Index: squid-3.5.26/acinclude/ax_check_compile_flag.m4 | ||
39 | =================================================================== | ||
40 | --- /dev/null | 22 | --- /dev/null |
41 | +++ squid-3.5.26/acinclude/ax_check_compile_flag.m4 | 23 | +++ b/acinclude/ax_check_compile_flag.m4 |
42 | @@ -0,0 +1,74 @@ | 24 | @@ -0,0 +1,74 @@ |
43 | +# =========================================================================== | 25 | +# =========================================================================== |
44 | +# https://www.gnu.org/software/autoconf-archive/ax_check_compile_flag.html | 26 | +# https://www.gnu.org/software/autoconf-archive/ax_check_compile_flag.html |
@@ -114,3 +96,23 @@ Index: squid-3.5.26/acinclude/ax_check_compile_flag.m4 | |||
114 | + [m4_default([$3], :)]) | 96 | + [m4_default([$3], :)]) |
115 | +AS_VAR_POPDEF([CACHEVAR])dnl | 97 | +AS_VAR_POPDEF([CACHEVAR])dnl |
116 | +])dnl AX_CHECK_COMPILE_FLAGS | 98 | +])dnl AX_CHECK_COMPILE_FLAGS |
99 | diff --git a/configure.ac b/configure.ac | ||
100 | index ff4688c..9382fdf 100644 | ||
101 | --- a/configure.ac | ||
102 | +++ b/configure.ac | ||
103 | @@ -26,6 +26,7 @@ m4_include([acinclude/pkg.m4]) | ||
104 | m4_include([acinclude/lib-checks.m4]) | ||
105 | m4_include([acinclude/ax_cxx_compile_stdcxx_11.m4]) | ||
106 | m4_include([acinclude/ax_cxx_0x_types.m4]) | ||
107 | +m4_include([acinclude/ax_check_compile_flag.m4]) | ||
108 | |||
109 | HOSTCXX="$BUILD_CXX" | ||
110 | PRESET_CFLAGS="$CFLAGS" | ||
111 | @@ -44,6 +45,7 @@ AC_PROG_CXX | ||
112 | AC_LANG([C++]) | ||
113 | AC_CANONICAL_HOST | ||
114 | |||
115 | +AX_CHECK_COMPILE_FLAG([-Werror=format-truncation],[CFLAGS="$CFLAGS -Wno-error=format-truncation" CXXFLAGS="$CXXFLAGS -Wno-error=format-truncation"]) | ||
116 | # Clang 3.2 on some CPUs requires -march-native to detect correctly. | ||
117 | # GCC 4.3+ can also produce faster executables when its used. | ||
118 | # But building inside a virtual machine environment has been found to | ||
diff --git a/meta-networking/recipes-daemons/squid/files/0001-tools.cc-fixed-unused-result-warning.patch b/meta-networking/recipes-daemons/squid/files/0001-tools.cc-fixed-unused-result-warning.patch index 082a1114b..8ea55d0e1 100644 --- a/meta-networking/recipes-daemons/squid/files/0001-tools.cc-fixed-unused-result-warning.patch +++ b/meta-networking/recipes-daemons/squid/files/0001-tools.cc-fixed-unused-result-warning.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From a78f2f0feda8f92cb59afe8236bd90726908768f Mon Sep 17 00:00:00 2001 | 1 | From faaa796a138cbd5033b1e53f33faac0cf4162bf5 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sun, 25 Jun 2017 00:59:24 -0700 | 3 | Date: Sun, 25 Jun 2017 00:59:24 -0700 |
4 | Subject: [PATCH] tools.cc: fixed unused-result warning | 4 | Subject: [PATCH] tools.cc: fixed unused-result warning |
@@ -10,9 +10,8 @@ fix | |||
10 | | ~~~~~~^~~ | 10 | | ~~~~~~^~~ |
11 | 11 | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
13 | --- | ||
14 | Upstream-Status: Submitted | ||
15 | 13 | ||
14 | --- | ||
16 | src/tools.cc | 4 ++-- | 15 | src/tools.cc | 4 ++-- |
17 | 1 file changed, 2 insertions(+), 2 deletions(-) | 16 | 1 file changed, 2 insertions(+), 2 deletions(-) |
18 | 17 | ||
@@ -31,6 +30,3 @@ index 8137a03..843e266 100644 | |||
31 | #endif | 30 | #endif |
32 | #if HAVE_PRCTL && defined(PR_SET_DUMPABLE) | 31 | #if HAVE_PRCTL && defined(PR_SET_DUMPABLE) |
33 | /* Set Linux DUMPABLE flag */ | 32 | /* Set Linux DUMPABLE flag */ |
34 | -- | ||
35 | 2.13.1 | ||
36 | |||
diff --git a/meta-networking/recipes-daemons/squid/files/Fix-flawed-dynamic-ldb-link-test-in-configure.patch b/meta-networking/recipes-daemons/squid/files/Fix-flawed-dynamic-ldb-link-test-in-configure.patch index 2304c5f1d..25f68aff8 100644 --- a/meta-networking/recipes-daemons/squid/files/Fix-flawed-dynamic-ldb-link-test-in-configure.patch +++ b/meta-networking/recipes-daemons/squid/files/Fix-flawed-dynamic-ldb-link-test-in-configure.patch | |||
@@ -1,8 +1,7 @@ | |||
1 | From 0d5b337ff5ef7dd48f970f08bd95d6327917cfd1 Mon Sep 17 00:00:00 2001 | 1 | From b4943594654cd340b95aabdc2f3750a4705cc0de Mon Sep 17 00:00:00 2001 |
2 | Message-Id: <0d5b337ff5ef7dd48f970f08bd95d6327917cfd1.1382375807.git.Jim.Somerville@windriver.com> | ||
3 | From: Jim Somerville <Jim.Somerville@windriver.com> | 2 | From: Jim Somerville <Jim.Somerville@windriver.com> |
4 | Date: Mon, 21 Oct 2013 12:50:44 -0400 | 3 | Date: Mon, 21 Oct 2013 12:50:44 -0400 |
5 | Subject: [PATCH 1/1] Fix flawed dynamic -ldb link test in configure | 4 | Subject: [PATCH] Fix flawed dynamic -ldb link test in configure |
6 | 5 | ||
7 | The test uses dbopen, but just ignores the fact | 6 | The test uses dbopen, but just ignores the fact |
8 | that this function may not exist in the db version | 7 | that this function may not exist in the db version |
@@ -11,15 +10,16 @@ and the configure script just making assumptions | |||
11 | about why and setting the need for -ldb incorrectly. | 10 | about why and setting the need for -ldb incorrectly. |
12 | 11 | ||
13 | Signed-off-by: Jim Somerville <Jim.Somerville@windriver.com> | 12 | Signed-off-by: Jim Somerville <Jim.Somerville@windriver.com> |
13 | |||
14 | --- | 14 | --- |
15 | configure.ac | 12 ++++++++++-- | 15 | configure.ac | 12 ++++++++++-- |
16 | 1 files changed, 10 insertions(+), 2 deletions(-) | 16 | 1 file changed, 10 insertions(+), 2 deletions(-) |
17 | 17 | ||
18 | diff --git a/configure.ac b/configure.ac | 18 | diff --git a/configure.ac b/configure.ac |
19 | index 962a748..42e6a93 100644 | 19 | index 57cd1ac..3827222 100644 |
20 | --- a/configure.ac | 20 | --- a/configure.ac |
21 | +++ b/configure.ac | 21 | +++ b/configure.ac |
22 | @@ -3051,8 +3051,16 @@ AC_CHECK_DECL(dbopen,,,[ | 22 | @@ -3229,8 +3229,16 @@ AC_CHECK_DECL(dbopen,,,[ |
23 | #include <db.h> | 23 | #include <db.h> |
24 | #endif]) | 24 | #endif]) |
25 | 25 | ||
@@ -38,6 +38,3 @@ index 962a748..42e6a93 100644 | |||
38 | if test "x$ac_cv_dbopen_libdb" = "xyes"; then | 38 | if test "x$ac_cv_dbopen_libdb" = "xyes"; then |
39 | LIB_DB="-ldb" | 39 | LIB_DB="-ldb" |
40 | fi | 40 | fi |
41 | -- | ||
42 | 1.7.4.1 | ||
43 | |||
diff --git a/meta-networking/recipes-daemons/squid/files/Set-up-for-cross-compilation.patch b/meta-networking/recipes-daemons/squid/files/Set-up-for-cross-compilation.patch index 4ca27444a..3852f7c25 100644 --- a/meta-networking/recipes-daemons/squid/files/Set-up-for-cross-compilation.patch +++ b/meta-networking/recipes-daemons/squid/files/Set-up-for-cross-compilation.patch | |||
@@ -1,29 +1,28 @@ | |||
1 | From 17e5a28667f667859c48bee25e575a072d39ee1b Mon Sep 17 00:00:00 2001 | 1 | From 995aaf30799fa972441354b6feb45f0621968929 Mon Sep 17 00:00:00 2001 |
2 | Message-Id: <17e5a28667f667859c48bee25e575a072d39ee1b.1381956170.git.Jim.Somerville@windriver.com> | ||
3 | From: Jim Somerville <Jim.Somerville@windriver.com> | 2 | From: Jim Somerville <Jim.Somerville@windriver.com> |
4 | Date: Wed, 16 Oct 2013 16:41:03 -0400 | 3 | Date: Wed, 16 Oct 2013 16:41:03 -0400 |
5 | Subject: [PATCH 1/1] Set up for cross compilation | 4 | Subject: [PATCH] Set up for cross compilation |
5 | |||
6 | Message-Id: <17e5a28667f667859c48bee25e575a072d39ee1b.1381956170.git.Jim.Somerville@windriver.com> | ||
6 | 7 | ||
7 | Set the host compiler to BUILD_CXX so | 8 | Set the host compiler to BUILD_CXX so |
8 | proper cross compilation can occur. | 9 | proper cross compilation can occur. |
9 | 10 | ||
10 | Signed-off-by: Jim Somerville <Jim.Somerville@windriver.com> | 11 | Signed-off-by: Jim Somerville <Jim.Somerville@windriver.com> |
12 | |||
11 | --- | 13 | --- |
12 | configure.ac | 1 + | 14 | configure.ac | 1 + |
13 | 1 files changed, 1 insertions(+), 0 deletions(-) | 15 | 1 file changed, 1 insertion(+) |
14 | 16 | ||
15 | diff --git a/configure.ac b/configure.ac | 17 | diff --git a/configure.ac b/configure.ac |
16 | index c2d3033..dda9ed9 100644 | 18 | index fe80ee0..57cd1ac 100644 |
17 | --- a/configure.ac | 19 | --- a/configure.ac |
18 | +++ b/configure.ac | 20 | +++ b/configure.ac |
19 | @@ -19,6 +19,7 @@ m4_include([acinclude/lib-checks.m4]) | 21 | @@ -27,6 +27,7 @@ m4_include([acinclude/lib-checks.m4]) |
20 | m4_include([acinclude/ax_cxx_compile_stdcxx_0x.m4]) | 22 | m4_include([acinclude/ax_cxx_compile_stdcxx_11.m4]) |
21 | m4_include([acinclude/ax_cxx_0x_types.m4]) | 23 | m4_include([acinclude/ax_cxx_0x_types.m4]) |
22 | 24 | ||
23 | +HOSTCXX="$BUILD_CXX" | 25 | +HOSTCXX="$BUILD_CXX" |
24 | PRESET_CFLAGS="$CFLAGS" | 26 | PRESET_CFLAGS="$CFLAGS" |
25 | PRESET_CXXFLAGS="$CXXFLAGS" | 27 | PRESET_CXXFLAGS="$CXXFLAGS" |
26 | PRESET_LDFLAGS="$LDFLAGS" | 28 | PRESET_LDFLAGS="$LDFLAGS" |
27 | -- | ||
28 | 1.7.4.1 | ||
29 | |||
diff --git a/meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch b/meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch index 7b6dcc820..6a3352548 100644 --- a/meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch +++ b/meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch | |||
@@ -1,3 +1,6 @@ | |||
1 | From a85311965707ba2fa78f7ce044e6f61e65e66fd0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jim Somerville <Jim.Somerville@windriver.com> | ||
3 | Date: Tue, 14 Oct 2014 02:56:08 -0400 | ||
1 | Subject: [PATCH] Skip AC_RUN_IFELSE tests | 4 | Subject: [PATCH] Skip AC_RUN_IFELSE tests |
2 | 5 | ||
3 | Upstream-Status: Inappropriate [cross compiling specific] | 6 | Upstream-Status: Inappropriate [cross compiling specific] |
@@ -7,16 +10,17 @@ environment. Choose sane defaults. | |||
7 | 10 | ||
8 | Signed-off-by: Jim Somerville <Jim.Somerville@windriver.com> | 11 | Signed-off-by: Jim Somerville <Jim.Somerville@windriver.com> |
9 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> | 12 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> |
13 | |||
10 | --- | 14 | --- |
11 | acinclude/krb5.m4 | 10 +++++++++- | 15 | acinclude/krb5.m4 | 10 +++++++++- |
12 | acinclude/lib-checks.m4 | 8 ++++++-- | 16 | acinclude/lib-checks.m4 | 8 ++++++-- |
13 | 2 files changed, 15 insertions(+), 3 deletions(-) | 17 | 2 files changed, 15 insertions(+), 3 deletions(-) |
14 | 18 | ||
15 | diff --git a/acinclude/krb5.m4 b/acinclude/krb5.m4 | 19 | diff --git a/acinclude/krb5.m4 b/acinclude/krb5.m4 |
16 | index 946bea8..7a072a2 100644 | 20 | index 5c83d88..c264118 100644 |
17 | --- a/acinclude/krb5.m4 | 21 | --- a/acinclude/krb5.m4 |
18 | +++ b/acinclude/krb5.m4 | 22 | +++ b/acinclude/krb5.m4 |
19 | @@ -82,7 +82,15 @@ main(void) | 23 | @@ -61,7 +61,15 @@ main(void) |
20 | 24 | ||
21 | return 0; | 25 | return 0; |
22 | } | 26 | } |
@@ -34,31 +38,28 @@ index 946bea8..7a072a2 100644 | |||
34 | ]) | 38 | ]) |
35 | ]) dnl SQUID_CHECK_KRB5_HEIMDAL_BROKEN_KRB5_H | 39 | ]) dnl SQUID_CHECK_KRB5_HEIMDAL_BROKEN_KRB5_H |
36 | diff --git a/acinclude/lib-checks.m4 b/acinclude/lib-checks.m4 | 40 | diff --git a/acinclude/lib-checks.m4 b/acinclude/lib-checks.m4 |
37 | index 2bf98ee..50dba9b 100644 | 41 | index c4874da..ba72982 100644 |
38 | --- a/acinclude/lib-checks.m4 | 42 | --- a/acinclude/lib-checks.m4 |
39 | +++ b/acinclude/lib-checks.m4 | 43 | +++ b/acinclude/lib-checks.m4 |
40 | @@ -128,7 +128,9 @@ AC_DEFUN([SQUID_CHECK_OPENSSL_GETCERTIFICATE_WORKS],[ | 44 | @@ -177,7 +177,9 @@ AC_DEFUN([SQUID_CHECK_OPENSSL_CONST_SSL_METHOD],[ |
41 | AC_DEFINE(SQUID_SSLGETCERTIFICATE_BUGGY, 1) | 45 | [ |
42 | AC_MSG_RESULT([yes]) | 46 | AC_MSG_RESULT([no]) |
43 | ], | 47 | ], |
44 | - []) | 48 | - []) |
45 | + [ | 49 | + [ |
46 | + AC_MSG_RESULT([skipped - can't test in cross-compiled env]) | 50 | + AC_MSG_RESULT([skipped - can't test in cross-compiled env]) |
47 | + ]) | 51 | + ]) |
48 | 52 | ||
49 | AC_MSG_CHECKING(whether the workaround for SSL_get_certificate works) | 53 | SQUID_STATE_ROLLBACK(check_const_SSL_METHOD) |
50 | AC_RUN_IFELSE([ | 54 | ] |
51 | @@ -154,7 +156,9 @@ AC_DEFUN([SQUID_CHECK_OPENSSL_GETCERTIFICATE_WORKS],[ | 55 | @@ -265,7 +267,9 @@ AC_DEFUN([SQUID_CHECK_OPENSSL_TXTDB],[ |
52 | [ | 56 | AC_MSG_RESULT([yes]) |
53 | AC_MSG_RESULT([no]) | 57 | AC_DEFINE(SQUID_USE_SSLLHASH_HACK, 1) |
54 | ], | 58 | ], |
55 | -[]) | 59 | -[]) |
56 | +[ | 60 | +[ |
57 | + AC_MSG_RESULT([skipped - can't test in cross-compiled env]) | 61 | + AC_MSG_RESULT([skipped - can't test in cross-compiled env]) |
58 | +]) | 62 | +]) |
59 | 63 | ||
60 | SQUID_STATE_ROLLBACK(check_SSL_get_certificate) | 64 | SQUID_STATE_ROLLBACK(check_TXTDB) |
61 | ]) | 65 | ]) |
62 | -- | ||
63 | 1.7.1 | ||
64 | |||
diff --git a/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch b/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch index cc1ea78a5..2feca4986 100644 --- a/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch +++ b/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch | |||
@@ -1,11 +1,20 @@ | |||
1 | ../../squid-3.5.26/src/DiskIO/DiskThreads/aiops.cc: In function 'void squidaio_init()': ../../squid-3.5.26/src/DiskIO/DiskThreads/DiskThreads.h:30:50: error: '*' in boolean context, suggest '&&' instead [-Werror=int-in-bool-context] #define NUMTHREADS (Config.cacheSwap.n_configured*16) | 1 | From 660fce9cfa00a57e5b7cec46116a31e21595c306 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 19 Jun 2017 23:47:01 -0700 | ||
4 | Subject: [PATCH] squid: Upgrade to 3.5.26 | ||
2 | 5 | ||
6 | ../../squid-3.5.26/src/DiskIO/DiskThreads/aiops.cc: In function 'void squidaio_init()': ../../squid-3.5.26/src/DiskIO/DiskThreads/DiskThreads.h:30:50: error: '*' in boolean context, suggest '&&' instead [-Werror=int-in-bool-context] #define NUMTHREADS (Config.cacheSwap.n_configured*16) | ||
3 | 7 | ||
4 | Upstream-Status: Backport | 8 | Upstream-Status: Backport |
5 | Index: squid-3.5.26/src/DiskIO/DiskThreads/aiops.cc | 9 | |
6 | =================================================================== | 10 | --- |
7 | --- squid-3.5.26.orig/src/DiskIO/DiskThreads/aiops.cc | 11 | src/DiskIO/DiskThreads/aiops.cc | 2 +- |
8 | +++ squid-3.5.26/src/DiskIO/DiskThreads/aiops.cc | 12 | 1 file changed, 1 insertion(+), 1 deletion(-) |
13 | |||
14 | diff --git a/src/DiskIO/DiskThreads/aiops.cc b/src/DiskIO/DiskThreads/aiops.cc | ||
15 | index b44adfa..e11f948 100644 | ||
16 | --- a/src/DiskIO/DiskThreads/aiops.cc | ||
17 | +++ b/src/DiskIO/DiskThreads/aiops.cc | ||
9 | @@ -290,7 +290,7 @@ squidaio_init(void) | 18 | @@ -290,7 +290,7 @@ squidaio_init(void) |
10 | /* Create threads and get them to sit in their wait loop */ | 19 | /* Create threads and get them to sit in their wait loop */ |
11 | squidaio_thread_pool = memPoolCreate("aio_thread", sizeof(squidaio_thread_t)); | 20 | squidaio_thread_pool = memPoolCreate("aio_thread", sizeof(squidaio_thread_t)); |
diff --git a/meta-networking/recipes-daemons/squid/files/set_sysroot_patch.patch b/meta-networking/recipes-daemons/squid/files/set_sysroot_patch.patch index fdcd174d3..e990480a6 100644 --- a/meta-networking/recipes-daemons/squid/files/set_sysroot_patch.patch +++ b/meta-networking/recipes-daemons/squid/files/set_sysroot_patch.patch | |||
@@ -1,15 +1,23 @@ | |||
1 | Set the SYSROOT for libxml2 header file to avoid host contamination. | 1 | From 702bd881b66dc034e711c0ff47805f2da40b6e0d Mon Sep 17 00:00:00 2001 |
2 | From: Yue Tao <yue.tao@windriver.com> | ||
3 | Date: Mon, 8 Aug 2016 16:04:33 +0800 | ||
4 | Subject: [PATCH] Set the SYSROOT for libxml2 header file to avoid host | ||
5 | contamination. | ||
2 | 6 | ||
3 | Upstream-Status: Inappropriate [embedded specific] | 7 | Upstream-Status: Inappropriate [embedded specific] |
4 | 8 | ||
5 | Signed-off-by: Yue Tao <yue.tao@windriver.com> | 9 | Signed-off-by: Yue Tao <yue.tao@windriver.com> |
6 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | 10 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> |
7 | 11 | ||
8 | diff --git a/configure.ac.old b/configure.ac | 12 | --- |
9 | index 54eda73..874f48e 100644 | 13 | configure.ac | 12 ++++++------ |
10 | --- a/configure.ac.old | 14 | 1 file changed, 6 insertions(+), 6 deletions(-) |
15 | |||
16 | diff --git a/configure.ac b/configure.ac | ||
17 | index 504a844..ff4688c 100644 | ||
18 | --- a/configure.ac | ||
11 | +++ b/configure.ac | 19 | +++ b/configure.ac |
12 | @@ -964,15 +964,15 @@ if test "x$squid_opt_use_esi" = "xyes" -a "x$with_libxml2" != "xno" ; then | 20 | @@ -974,15 +974,15 @@ if test "x$squid_opt_use_esi" = "xyes" -a "x$with_libxml2" != "xno" ; then |
13 | dnl Find the main header and include path... | 21 | dnl Find the main header and include path... |
14 | AC_CACHE_CHECK([location of libxml2 include files], [ac_cv_libxml2_include], [ | 22 | AC_CACHE_CHECK([location of libxml2 include files], [ac_cv_libxml2_include], [ |
15 | AC_CHECK_HEADERS([libxml/parser.h], [], [ | 23 | AC_CHECK_HEADERS([libxml/parser.h], [], [ |
diff --git a/meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch b/meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch index 312f44f8e..e5267ea2b 100644 --- a/meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch +++ b/meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 54a9c2ba60adc7ec2724786662fd398e7c03999f Mon Sep 17 00:00:00 2001 | 1 | From 8786b91488dae3f6dfeadd686e80d2ffc5c29320 Mon Sep 17 00:00:00 2001 |
2 | From: Jackie Huang <jackie.huang@windriver.com> | 2 | From: Jackie Huang <jackie.huang@windriver.com> |
3 | Date: Thu, 25 Aug 2016 15:22:57 +0800 | 3 | Date: Thu, 25 Aug 2016 15:22:57 +0800 |
4 | Subject: [PATCH] squid: don't do squid-conf-tests at build time | 4 | Subject: [PATCH] squid: don't do squid-conf-tests at build time |
@@ -14,12 +14,13 @@ Subject: [PATCH] squid: don't do squid-conf-tests at build time | |||
14 | Upstream-Status: Inappropriate [cross compile specific] | 14 | Upstream-Status: Inappropriate [cross compile specific] |
15 | 15 | ||
16 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> | 16 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> |
17 | |||
17 | --- | 18 | --- |
18 | test-suite/Makefile.am | 15 +++++++-------- | 19 | test-suite/Makefile.am | 15 +++++++-------- |
19 | 1 file changed, 7 insertions(+), 8 deletions(-) | 20 | 1 file changed, 7 insertions(+), 8 deletions(-) |
20 | 21 | ||
21 | diff --git a/test-suite/Makefile.am b/test-suite/Makefile.am | 22 | diff --git a/test-suite/Makefile.am b/test-suite/Makefile.am |
22 | index d5468be..77fc480 100644 | 23 | index 061a463..350dfb2 100644 |
23 | --- a/test-suite/Makefile.am | 24 | --- a/test-suite/Makefile.am |
24 | +++ b/test-suite/Makefile.am | 25 | +++ b/test-suite/Makefile.am |
25 | @@ -41,8 +41,7 @@ TESTS += debug \ | 26 | @@ -41,8 +41,7 @@ TESTS += debug \ |
@@ -58,6 +59,3 @@ index d5468be..77fc480 100644 | |||
58 | else break; fi; \ | 59 | else break; fi; \ |
59 | done; \ | 60 | done; \ |
60 | if test "$$failed" -eq 0; then cp $(TRUE) $@ ; fi | 61 | if test "$$failed" -eq 0; then cp $(TRUE) $@ ; fi |
61 | -- | ||
62 | 2.8.3 | ||
63 | |||
diff --git a/meta-networking/recipes-daemons/squid/files/squid-use-serial-tests-config-needed-by-ptest.patch b/meta-networking/recipes-daemons/squid/files/squid-use-serial-tests-config-needed-by-ptest.patch index 01ec59622..9c75f17e7 100644 --- a/meta-networking/recipes-daemons/squid/files/squid-use-serial-tests-config-needed-by-ptest.patch +++ b/meta-networking/recipes-daemons/squid/files/squid-use-serial-tests-config-needed-by-ptest.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From bd58d3672bc267824000f34a37561c7ab2bd571f Mon Sep 17 00:00:00 2001 | 1 | From 9bcec221a2bb438d8a9ed59aed846ffe3be9cffa Mon Sep 17 00:00:00 2001 |
2 | From: Jackie Huang <jackie.huang@windriver.com> | 2 | From: Jackie Huang <jackie.huang@windriver.com> |
3 | Date: Tue, 19 Jul 2016 01:56:23 -0400 | 3 | Date: Tue, 19 Jul 2016 01:56:23 -0400 |
4 | Subject: [PATCH] squid: use serial-tests config needed by ptest | 4 | Subject: [PATCH] squid: use serial-tests config needed by ptest |
@@ -9,12 +9,13 @@ serial-tests is required to generate those targets. | |||
9 | Upstream-Status: Inappropriate [default automake behavior incompatible with ptest] | 9 | Upstream-Status: Inappropriate [default automake behavior incompatible with ptest] |
10 | 10 | ||
11 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> | 11 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> |
12 | |||
12 | --- | 13 | --- |
13 | configure.ac | 2 +- | 14 | configure.ac | 2 +- |
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | 15 | 1 file changed, 1 insertion(+), 1 deletion(-) |
15 | 16 | ||
16 | diff --git a/configure.ac b/configure.ac | 17 | diff --git a/configure.ac b/configure.ac |
17 | index 05ad027..e324b93 100644 | 18 | index 3827222..504a844 100644 |
18 | --- a/configure.ac | 19 | --- a/configure.ac |
19 | +++ b/configure.ac | 20 | +++ b/configure.ac |
20 | @@ -10,7 +10,7 @@ AC_PREREQ(2.61) | 21 | @@ -10,7 +10,7 @@ AC_PREREQ(2.61) |
@@ -26,6 +27,3 @@ index 05ad027..e324b93 100644 | |||
26 | AC_REVISION($Revision$)dnl | 27 | AC_REVISION($Revision$)dnl |
27 | AC_PREFIX_DEFAULT(/usr/local/squid) | 28 | AC_PREFIX_DEFAULT(/usr/local/squid) |
28 | AM_MAINTAINER_MODE | 29 | AM_MAINTAINER_MODE |
29 | -- | ||
30 | 2.8.1 | ||
31 | |||