summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-09 12:11:19 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-10 20:55:29 -0700
commit67cfeab4cfb032822d81b843de339e1938af89b5 (patch)
tree851b84f843a615436e30112c348e6ae48f8f678b
parent9bc750f25d209fe61904ffc11e5e2d306d8c6f6f (diff)
downloadmeta-openembedded-67cfeab4cfb032822d81b843de339e1938af89b5.tar.gz
python3-evdev: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-evdev.inc25
-rw-r--r--meta-python/recipes-devtools/python/python3-evdev_1.3.0.bb22
2 files changed, 21 insertions, 26 deletions
diff --git a/meta-python/recipes-devtools/python/python-evdev.inc b/meta-python/recipes-devtools/python/python-evdev.inc
deleted file mode 100644
index 5f5426aac..000000000
--- a/meta-python/recipes-devtools/python/python-evdev.inc
+++ /dev/null
@@ -1,25 +0,0 @@
1SUMMARY = "Python evdev lib"
2HOMEPAGE = "https://github.com/gvalkov/python-evdev"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2"
5
6FILESEXTRAPATHS_prepend := "${THISDIR}/python-evdev:"
7
8SRC_URI = "${PYPI_SRC_URI}"
9
10SRC_URI[md5sum] = "05f9e900d6e11e1674475d2dd2668f0d"
11SRC_URI[sha256sum] = "b1c649b4fed7252711011da235782b2c260b32e004058d62473471e5cd30634d"
12
13do_compile_prepend() {
14 rm -rf ${S}/evdev/ecodes.c
15}
16
17DISTUTILS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
18
19RDEPENDS_${PN} += "\
20 ${PYTHON_PN}-ctypes \
21 ${PYTHON_PN}-fcntl \
22 ${PYTHON_PN}-io \
23 ${PYTHON_PN}-shell \
24 ${PYTHON_PN}-stringold \
25 "
diff --git a/meta-python/recipes-devtools/python/python3-evdev_1.3.0.bb b/meta-python/recipes-devtools/python/python3-evdev_1.3.0.bb
index d87bf2fec..fe11049ad 100644
--- a/meta-python/recipes-devtools/python/python3-evdev_1.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-evdev_1.3.0.bb
@@ -1,3 +1,23 @@
1SUMMARY = "Python evdev lib"
2HOMEPAGE = "https://github.com/gvalkov/python-evdev"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2"
5
6SRC_URI[md5sum] = "05f9e900d6e11e1674475d2dd2668f0d"
7SRC_URI[sha256sum] = "b1c649b4fed7252711011da235782b2c260b32e004058d62473471e5cd30634d"
8
1inherit pypi setuptools3 9inherit pypi setuptools3
2require python-evdev.inc
3 10
11do_compile_prepend() {
12 rm -rf ${S}/evdev/ecodes.c
13}
14
15DISTUTILS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
16
17RDEPENDS_${PN} += "\
18 ${PYTHON_PN}-ctypes \
19 ${PYTHON_PN}-fcntl \
20 ${PYTHON_PN}-io \
21 ${PYTHON_PN}-shell \
22 ${PYTHON_PN}-stringold \
23 "