diff options
author | Ming Liu <peter.x.liu@external.atlascopco.com> | 2017-07-11 18:44:33 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-14 23:44:34 +0200 |
commit | 61a2e24f601a5e79f0ad42f87c757414dfa8b3fb (patch) | |
tree | 7f6ed41e5ecfc26bbaa16d8d02b1fee5ec7c5c01 | |
parent | c311abb43e41b3c1ef4e4884769039329254248a (diff) | |
download | meta-openembedded-61a2e24f601a5e79f0ad42f87c757414dfa8b3fb.tar.gz |
libterm-readkey-perl: add recipe
Term::ReadKey - A perl module for simple terminal control.
It's being strongly recommended by po4a.
Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.37.bb | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.37.bb b/meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.37.bb new file mode 100644 index 000000000..6b76682c6 --- /dev/null +++ b/meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.37.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | SUMMARY = "Term::ReadKey - A perl module for simple terminal control." | ||
2 | DESCRIPTION = "Term::ReadKey is a compiled perl module dedicated to providing simple \ | ||
3 | control over terminal driver modes (cbreak, raw, cooked, etc.,) support \ | ||
4 | for non-blocking reads, if the architecture allows, and some generalized \ | ||
5 | handy functions for working with terminals. One of the main goals is to \ | ||
6 | have the functions as portable as possible, so you can just plug in "use \ | ||
7 | Term::ReadKey" on any architecture and have a good likelihood of it \ | ||
8 | working." | ||
9 | HOMEPAGE = "http://search.cpan.org/~jstowe/TermReadKey-${PV}" | ||
10 | SECTION = "libraries" | ||
11 | |||
12 | LICENSE = "Artistic-1.0 | GPLv1+" | ||
13 | LIC_FILES_CHKSUM = "file://README;md5=c275db663c8489a5709ebb22b185add5" | ||
14 | |||
15 | SRC_URI = "${CPAN_MIRROR}/authors/id/J/JS/JSTOWE/TermReadKey-${PV}.tar.gz" | ||
16 | |||
17 | SRC_URI[md5sum] = "e8ea15c16333ac4f8d146d702e83cc0c" | ||
18 | SRC_URI[sha256sum] = "4a9383cf2e0e0194668fe2bd546e894ffad41d556b41d2f2f577c8db682db241" | ||
19 | |||
20 | S = "${WORKDIR}/TermReadKey-${PV}" | ||
21 | |||
22 | # It needs depend on native to let dynamic loader use native modules | ||
23 | # rather than target ones. | ||
24 | DEPENDS = "libterm-readkey-perl-native" | ||
25 | |||
26 | inherit cpan | ||
27 | |||
28 | do_configure_append () { | ||
29 | # Hack the dynamic module loader so that it use native modules since it can't load | ||
30 | # the target ones. | ||
31 | if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then | ||
32 | sed -i -e "s#-I\$(INST_ARCHLIB)#-I${STAGING_BINDIR_NATIVE}/perl-native/perl/vendor_perl/${@get_perl_version(d)}#g" Makefile | ||
33 | fi | ||
34 | } | ||
35 | |||
36 | BBCLASSEXTEND = "native" | ||