diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-07-01 14:33:09 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-14 23:44:30 +0200 |
commit | 5e9f83d11aede7113782f41400299582c7750bea (patch) | |
tree | 00045acf7df8c5e208c8019ed387e8494042a2da | |
parent | 23a1d7accaf7c71559944a83cdb8622eb2be6d05 (diff) | |
download | meta-openembedded-5e9f83d11aede7113782f41400299582c7750bea.tar.gz |
crossguid: Add recipe
Needed by kodi
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-multimedia/recipes-support/crossguid/crossguid.bb | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-support/crossguid/crossguid.bb b/meta-multimedia/recipes-support/crossguid/crossguid.bb new file mode 100644 index 000000000..228b8b654 --- /dev/null +++ b/meta-multimedia/recipes-support/crossguid/crossguid.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | # Copyright (C) 2017 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | DESCRIPTION = "Lightweight cross platform C++ GUID/UUID library" | ||
5 | HOMEPAGE = "https://github.com/graeme-hill/crossguid" | ||
6 | LICENSE = "MIT" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68" | ||
8 | DEPENDS += "util-linux" | ||
9 | |||
10 | PV = "0.0+git${SRCPV}" | ||
11 | |||
12 | SRCREV = "b56957ac453575e91ca1b63a80c0077c2b0d011a" | ||
13 | SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_compile() { | ||
18 | ${CXX} -c guid.cpp -o guid.o ${CXXFLAGS} -std=c++11 -DGUID_LIBUUID | ||
19 | ${AR} rvs libcrossguid.a guid.o | ||
20 | } | ||
21 | |||
22 | do_install() { | ||
23 | install -D -m 0644 ${B}/libcrossguid.a ${D}${libdir}/libcrossguid.a | ||
24 | install -D -m 0644 ${S}/guid.h ${D}${includedir}/guid.h | ||
25 | } | ||