diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-08-30 13:23:41 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-08-31 10:06:27 -0700 |
commit | 5e9c8a69682d834939abd0b84d35c83a779234b3 (patch) | |
tree | afab26b15a9138c3ee15dc7bc95b64fa630bbc7c | |
parent | edc39ba949190b5d75cb483d71351a1fa88b40c0 (diff) | |
download | meta-openembedded-5e9c8a69682d834939abd0b84d35c83a779234b3.tar.gz |
libuser: Upgrade to 0.63
Do not build docs, it needs sgml tools which are not available in OE
Fix python type mismatch problems
Generate needed files for reconfiguring the package
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-gnome/recipes-support/libuser/libuser/0001-docs-Disable-building.patch | 29 | ||||
-rw-r--r-- | meta-gnome/recipes-support/libuser/libuser/0001-modules-files.c-parse_field-fix-string-formating-in-.patch | 34 | ||||
-rw-r--r-- | meta-gnome/recipes-support/libuser/libuser/0003-python-Compilation-warnings-update.patch | 84 | ||||
-rw-r--r-- | meta-gnome/recipes-support/libuser/libuser_0.63.bb (renamed from meta-gnome/recipes-support/libuser/libuser_0.62.bb) | 26 |
4 files changed, 132 insertions, 41 deletions
diff --git a/meta-gnome/recipes-support/libuser/libuser/0001-docs-Disable-building.patch b/meta-gnome/recipes-support/libuser/libuser/0001-docs-Disable-building.patch new file mode 100644 index 000000000..add2872cc --- /dev/null +++ b/meta-gnome/recipes-support/libuser/libuser/0001-docs-Disable-building.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From e6bdf74a424652c4f9a38457c7fa93a2051157f5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 30 Aug 2022 13:09:07 -0700 | ||
4 | Subject: [PATCH] docs: Disable building | ||
5 | |||
6 | It needs linuxdoc-tools which we do not have in OE anymore | ||
7 | |||
8 | Upstream-Status: Inappropriate [OE-Specific] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | docs/Makefile.am | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/docs/Makefile.am b/docs/Makefile.am | ||
15 | index daa2288..b355185 100644 | ||
16 | --- a/docs/Makefile.am | ||
17 | +++ b/docs/Makefile.am | ||
18 | @@ -8,7 +8,7 @@ CLEANFILES = $(man_MANS) $(SGML_OUTPUTS) | ||
19 | EXTRA_DIST = attributes.txt libuser.conf.5.in rfc2307.txt sgml/libuser.sgml \ | ||
20 | $(SGML_OUTPUTS) | ||
21 | |||
22 | -all: sgml/libuser.txt sgml/libuser.html | ||
23 | +all: | ||
24 | |||
25 | libuser.conf.5: $(srcdir)/libuser.conf.5.in Makefile | ||
26 | sed 's,@sysconfdir\@,$(sysconfdir),g' \ | ||
27 | -- | ||
28 | 2.37.2 | ||
29 | |||
diff --git a/meta-gnome/recipes-support/libuser/libuser/0001-modules-files.c-parse_field-fix-string-formating-in-.patch b/meta-gnome/recipes-support/libuser/libuser/0001-modules-files.c-parse_field-fix-string-formating-in-.patch deleted file mode 100644 index 7c47df22e..000000000 --- a/meta-gnome/recipes-support/libuser/libuser/0001-modules-files.c-parse_field-fix-string-formating-in-.patch +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | From a4857911ece5ebfcdef42aee4c070eb216f39597 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?An=C3=ADbal=20Lim=C3=B3n?= <anibal.limon@linux.intel.com> | ||
3 | Date: Fri, 13 May 2016 11:40:13 -0500 | ||
4 | Subject: [PATCH] modules/files.c: parse_field fix string formating in | ||
5 | g_warnings | ||
6 | MIME-Version: 1.0 | ||
7 | Content-Type: text/plain; charset=UTF-8 | ||
8 | Content-Transfer-Encoding: 8bit | ||
9 | |||
10 | [YOCTO #9547] | ||
11 | |||
12 | Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | --- | ||
16 | modules/files.c | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/modules/files.c b/modules/files.c | ||
20 | index 4ef0a57..35eafc9 100644 | ||
21 | --- a/modules/files.c | ||
22 | +++ b/modules/files.c | ||
23 | @@ -534,7 +534,7 @@ parse_field(const struct format_specifier *format, GValue *value, | ||
24 | string, &err); | ||
25 | if (ret == FALSE) { | ||
26 | g_assert(err != NULL); | ||
27 | - g_warning(lu_strerror(err)); | ||
28 | + g_warning(lu_strerror(err), NULL); | ||
29 | lu_error_free(&err); | ||
30 | } | ||
31 | return ret; | ||
32 | -- | ||
33 | 2.1.4 | ||
34 | |||
diff --git a/meta-gnome/recipes-support/libuser/libuser/0003-python-Compilation-warnings-update.patch b/meta-gnome/recipes-support/libuser/libuser/0003-python-Compilation-warnings-update.patch new file mode 100644 index 000000000..45d695215 --- /dev/null +++ b/meta-gnome/recipes-support/libuser/libuser/0003-python-Compilation-warnings-update.patch | |||
@@ -0,0 +1,84 @@ | |||
1 | From acd7b051993d501f4b5e3a593e0f18d1336ba2de Mon Sep 17 00:00:00 2001 | ||
2 | From: Tomas Halman <thalman@redhat.com> | ||
3 | Date: Wed, 21 Jul 2021 15:36:59 +0200 | ||
4 | Subject: [PATCH] python: Compilation warnings update | ||
5 | |||
6 | The compilation produces few warnings about discard const qualifier | ||
7 | and pointer to int conversion. This patch fixes the const qualifiers | ||
8 | and replaces the tp_print inicialization in PyTypeObject with 0 instead | ||
9 | of NULL | ||
10 | |||
11 | Upstream-Status: Backport [https://pagure.io/libuser/c/3cb7ea54e7b50da6ea313a0e7c7187c8aa5e6ee9?branch=master] | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | python/admin.c | 2 +- | ||
15 | python/ent.c | 8 ++++---- | ||
16 | python/misc.c | 2 +- | ||
17 | 3 files changed, 6 insertions(+), 6 deletions(-) | ||
18 | |||
19 | diff --git a/python/admin.c b/python/admin.c | ||
20 | index 83595af..e92fca4 100644 | ||
21 | --- a/python/admin.c | ||
22 | +++ b/python/admin.c | ||
23 | @@ -1512,7 +1512,7 @@ PyTypeObject AdminType = { | ||
24 | sizeof(struct libuser_admin), /* tp_basicsize */ | ||
25 | 0, /* tp_itemsize */ | ||
26 | libuser_admin_destroy, /* tp_dealloc */ | ||
27 | - NULL, /* tp_print */ | ||
28 | + 0, /* tp_print */ | ||
29 | NULL, /* tp_getattr */ | ||
30 | NULL, /* tp_setattr */ | ||
31 | NULL, /* tp_compare */ | ||
32 | diff --git a/python/ent.c b/python/ent.c | ||
33 | index ee712d2..fc3d654 100644 | ||
34 | --- a/python/ent.c | ||
35 | +++ b/python/ent.c | ||
36 | @@ -255,7 +255,7 @@ libuser_convert_to_value(PyObject *item, GValue *value) | ||
37 | static int | ||
38 | libuser_entity_setattro(PyObject *self, PyObject *attr_name, PyObject *value) | ||
39 | { | ||
40 | - char *name; | ||
41 | + const char *name; | ||
42 | struct libuser_entity *me; | ||
43 | PyObject *list; | ||
44 | struct lu_ent *copy; | ||
45 | @@ -616,7 +616,7 @@ static PyObject * | ||
46 | libuser_entity_get_item(PyObject *self, PyObject *item) | ||
47 | { | ||
48 | struct libuser_entity *me; | ||
49 | - char *attr; | ||
50 | + const char *attr; | ||
51 | |||
52 | DEBUG_ENTRY; | ||
53 | me = (struct libuser_entity *)self; | ||
54 | @@ -664,7 +664,7 @@ static int | ||
55 | libuser_entity_set_item(PyObject *self, PyObject *item, PyObject *args) | ||
56 | { | ||
57 | struct libuser_entity *me; | ||
58 | - char *attr = NULL; | ||
59 | + const char *attr = NULL; | ||
60 | Py_ssize_t i, size; | ||
61 | int ret; | ||
62 | GValue value; | ||
63 | @@ -800,7 +800,7 @@ PyTypeObject EntityType = { | ||
64 | sizeof(struct libuser_entity), /* tp_basicsize */ | ||
65 | 0, /* tp_itemsize */ | ||
66 | libuser_entity_destroy, /* tp_dealloc */ | ||
67 | - NULL, /* tp_print */ | ||
68 | + 0, /* tp_print */ | ||
69 | NULL, /* tp_getattr */ | ||
70 | NULL, /* tp_setattr */ | ||
71 | NULL, /* tp_compare */ | ||
72 | diff --git a/python/misc.c b/python/misc.c | ||
73 | index c4ce819..810a846 100644 | ||
74 | --- a/python/misc.c | ||
75 | +++ b/python/misc.c | ||
76 | @@ -488,7 +488,7 @@ PyTypeObject PromptType = { | ||
77 | sizeof(struct libuser_prompt), /* tp_basicsize */ | ||
78 | 0, /* tp_itemsize */ | ||
79 | libuser_prompt_destroy, /* tp_dealloc */ | ||
80 | - NULL, /* tp_print */ | ||
81 | + 0, /* tp_print */ | ||
82 | NULL, /* tp_getattr */ | ||
83 | NULL, /* tp_setattr */ | ||
84 | NULL, /* tp_compare */ | ||
diff --git a/meta-gnome/recipes-support/libuser/libuser_0.62.bb b/meta-gnome/recipes-support/libuser/libuser_0.63.bb index 22ddd10a6..e191e115a 100644 --- a/meta-gnome/recipes-support/libuser/libuser_0.62.bb +++ b/meta-gnome/recipes-support/libuser/libuser_0.63.bb | |||
@@ -12,22 +12,34 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | |||
12 | SECTION = "base" | 12 | SECTION = "base" |
13 | 13 | ||
14 | SRC_URI = "https://releases.pagure.org/libuser/libuser-${PV}.tar.xz \ | 14 | SRC_URI = "https://releases.pagure.org/libuser/libuser-${PV}.tar.xz \ |
15 | file://0001-docs-Disable-building.patch \ | ||
15 | file://0002-remove-unused-execinfo.h.patch \ | 16 | file://0002-remove-unused-execinfo.h.patch \ |
16 | file://0001-modules-files.c-parse_field-fix-string-formating-in-.patch \ | 17 | file://0003-python-Compilation-warnings-update.patch \ |
17 | " | 18 | " |
18 | 19 | ||
19 | SRC_URI[md5sum] = "63e5e5c551e99dc5302b40b80bd6d4f2" | 20 | SRC_URI[sha256sum] = "8dc377255452a68e82c4837ba22c3ee4ae3658971bf0f2ef67ed0b77fc497f91" |
20 | SRC_URI[sha256sum] = "a58ff4fabb01a25043b142185a33eeea961109dd60d4b40b6a9df4fa3cace20b" | ||
21 | 21 | ||
22 | DEPENDS = "popt libpam glib-2.0 python3" | 22 | DEPENDS = "bison-native popt libpam glib-2.0 python3" |
23 | 23 | ||
24 | inherit features_check | 24 | inherit autotools features_check gettext python3native python3-dir pkgconfig gtk-doc |
25 | REQUIRED_DISTRO_FEATURES = "pam" | ||
26 | 25 | ||
27 | inherit autotools gettext python3native python3-dir pkgconfig gtk-doc | 26 | REQUIRED_DISTRO_FEATURES = "pam" |
28 | 27 | ||
29 | EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}" | 28 | EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}" |
30 | 29 | ||
30 | GTKDOC_DOCDIR = "${S}/docs/reference" | ||
31 | |||
32 | # run autopoint since it needs ABOUT-NLS and admin/config.rpath from gettext | ||
33 | #EXTRA_AUTORECONF:remove = "--exclude=autopoint" | ||
34 | |||
35 | do_configure:prepend() { | ||
36 | install -d ${S}/admin -d ${S}/m4 | ||
37 | touch ${S}/ABOUT-NLS ${S}/admin/config.rpath | ||
38 | cd ${S} | ||
39 | bison lib/getdate.y -o lib/getdate.c | ||
40 | cd - | ||
41 | } | ||
42 | |||
31 | PACKAGES += "${PN}-python " | 43 | PACKAGES += "${PN}-python " |
32 | 44 | ||
33 | FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" | 45 | FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" |