diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2020-01-14 13:00:47 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-01-14 14:40:52 -0800 |
commit | 57394d5ec611347b28e2bdabcc2cad505cbb76c8 (patch) | |
tree | cdb8bc2847a8b33ff3f3a789167fecbde2b8c69b | |
parent | 84e87356aa7fcd3190b288702f971b6b5c1b8b6f (diff) | |
download | meta-openembedded-57394d5ec611347b28e2bdabcc2cad505cbb76c8.tar.gz |
sysprof: fix ARM builds
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch | 42 | ||||
-rw-r--r-- | meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb | 4 |
2 files changed, 44 insertions, 2 deletions
diff --git a/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch b/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch new file mode 100644 index 000000000..235489226 --- /dev/null +++ b/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From 43c39b5685445242d071b3706af2903efa508b4a Mon Sep 17 00:00:00 2001 | ||
2 | From: Alexander Kanavin <alex.kanavin@gmail.com> | ||
3 | Date: Tue, 14 Jan 2020 12:58:27 +0100 | ||
4 | Subject: [PATCH] meson.build: do not hardcode 'linux' as | ||
5 | host_machine().system() value | ||
6 | |||
7 | In some build environmets such as OpenEmbedded this can be 'linux-gnueabi' | ||
8 | or otherwise not exactly 'linux'. | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> | ||
12 | --- | ||
13 | src/libsysprof/meson.build | 2 +- | ||
14 | src/tools/meson.build | 2 +- | ||
15 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/src/libsysprof/meson.build b/src/libsysprof/meson.build | ||
18 | index 3449961..3c2d186 100644 | ||
19 | --- a/src/libsysprof/meson.build | ||
20 | +++ b/src/libsysprof/meson.build | ||
21 | @@ -84,7 +84,7 @@ libsysprof_deps = [ | ||
22 | polkit_dep, | ||
23 | ] | ||
24 | |||
25 | -if host_machine.system() == 'linux' | ||
26 | +if host_machine.system().contains('linux') | ||
27 | libsysprof_public_sources += [ | ||
28 | 'sysprof-memory-source.c', | ||
29 | 'sysprof-perf-counter.c', | ||
30 | diff --git a/src/tools/meson.build b/src/tools/meson.build | ||
31 | index 670052a..3fb7f0c 100644 | ||
32 | --- a/src/tools/meson.build | ||
33 | +++ b/src/tools/meson.build | ||
34 | @@ -2,7 +2,7 @@ tools_deps = [ | ||
35 | libsysprof_capture_dep, | ||
36 | ] | ||
37 | |||
38 | -if get_option('libsysprof') and host_machine.system() == 'linux' | ||
39 | +if get_option('libsysprof') and host_machine.system().contains('linux') | ||
40 | polkit_agent_dep = dependency('polkit-agent-1') | ||
41 | sysprof_cli = executable('sysprof-cli', 'sysprof-cli.c', | ||
42 | dependencies: tools_deps + [libsysprof_dep, polkit_dep, polkit_agent_dep], | ||
diff --git a/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb b/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb index b7e7bee6b..fd1b77ece 100644 --- a/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb +++ b/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb | |||
@@ -11,8 +11,8 @@ DEPENDS = "glib-2.0 libxml2-native glib-2.0-native" | |||
11 | 11 | ||
12 | SRC_URI[archive.md5sum] = "cc32455277b31afb1965d627ae3e3629" | 12 | SRC_URI[archive.md5sum] = "cc32455277b31afb1965d627ae3e3629" |
13 | SRC_URI[archive.sha256sum] = "844bbb8d8b65071b3bca96f8e921319ceef81f2d2c51fcc9da63a4b355c893d0" | 13 | SRC_URI[archive.sha256sum] = "844bbb8d8b65071b3bca96f8e921319ceef81f2d2c51fcc9da63a4b355c893d0" |
14 | SRC_URI += " \ | 14 | SRC_URI += "file://0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch \ |
15 | file://0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch \ | 15 | file://0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch \ |
16 | " | 16 | " |
17 | 17 | ||
18 | PACKAGECONFIG ?= "sysprofd libsysprof ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}" | 18 | PACKAGECONFIG ?= "sysprofd libsysprof ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}" |